#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:57:55 UTC (full logs).

Meeting summary

  1. Roll Call , TSC members (ChrisPriceAB, 14:58:14)
    1. Frank Brockners (frankbrockners, 14:58:17)
    2. Chris Price (ChrisPriceAB, 14:58:20)
    3. Ashiq (Ashiq, 15:00:30)
    4. Uli (uli_, 15:00:38)
    5. Bryan Sullivan (bryan_att, 15:00:42)
    6. FYI Bin Hu will stand in for me as AT&T TSC member on any votes after I leave the call (flying) (bryan_att, 15:01:53)
    7. palani (Palani, 15:02:08)
    8. Hui (rpaik, 15:03:30)
    9. Bin Hu (bin_, 15:03:32)
    10. Chris Wright (cdub, 15:03:44)
    11. Parviz Yegani (Parviz, 15:04:01)

  2. Approval of minutes (ChrisPriceAB, 15:04:24)
    1. AGREED: Minutes approved without comment (ChrisPriceAB, 15:04:52)

  3. Agenda Bashing (ChrisPriceAB, 15:04:59)
    1. Wenjing Chu (Wenjing, 15:05:28)
    2. ACTION: ChrisPriceAB establish a specific topic in the e-mails for requesting creation reviews. (ChrisPriceAB, 15:08:31)
    3. OSCAR project to be further discussed in the community prior to formal TSC review (ChrisPriceAB, 15:10:55)

  4. Project Repo's (ChrisPriceAB, 15:11:10)
  5. project repos (uli_, 15:11:33)
    1. Ray describes that there are now 7 repositories in place with committer e-mails being sent out. (ChrisPriceAB, 15:11:42)
    2. Gerrit and other tools on the OPNFV web site questions can be sent to the e-mail that is monitored: (ChrisPriceAB, 15:12:14)
    3. opnfv-helpdesk@rt.linuxfoundation.org (rpaik, 15:12:14)
    4. not all committers are established in the all the repo's due to missing linux foundation accounts (ChrisPriceAB, 15:12:52)
    5. corporate e-mail addresses should be used when creating the LinuxFoundation account to be used in OPNFV. (ChrisPriceAB, 15:13:19)
    6. HELP: (TapioT, 15:14:20)
    7. aricg: informs that there are no announcement e-mails for committers on projects. (ChrisPriceAB, 15:14:30)
    8. https://gerrit.opnfv.org/gerrit/#/admin/projects/ (rpaik, 15:15:17)
    9. here is where I am trying to capture steps to getting started with accounts etc: #link https://wiki.opnfv.org/dev_step_by_step (ChrisPriceAB, 15:16:27)

  6. Meet-up and HackFest committee's (ChrisPriceAB, 15:18:13)
    1. Ray sent a number of e-mails to the lists to rally help for setting agenda's, topics & goals for the meet-up's and hack-fests during 2015 (ChrisPriceAB, 15:19:09)
    2. Registration links will be sent out soon for registering to the meet-up in santa rosa. (ChrisPriceAB, 15:20:08)
    3. frankbrockners mentions that on the main wiki page the events page can be updated with an etherpad to help organise and attend events. (ChrisPriceAB, 15:21:44)
    4. I will be in Santa Rosa and can help organize topics and hacking around Copper. As we kick off the project this will be one of the first discussion points. (bryan_att, 15:22:13)
    5. Prague hack-fest (ChrisPriceAB, 15:22:24)
    6. there are no venues within walking distance of the ETSI event. The closest event venue is 15 minutes away by metro train at the Marriot. (ChrisPriceAB, 15:23:08)
    7. the LinuxFoundation has some awareness of the location and have a good impression of it. (ChrisPriceAB, 15:23:31)
    8. we will need to confirm the facility by the end of this week. (ChrisPriceAB, 15:23:47)
    9. The HackFest will be on the Monday and Tuesday of the week (ChrisPriceAB, 15:24:25)
    10. also AFAIK Dan Druta on my team (or maybe Margaret) will stand in for me at Prague and attend the hack fest IF it doesn't conflict with the ETSI meeting. (bryan_att, 15:24:28)
    11. a discussion occurs on the location of the event being a subway ride away and if this may cause any issues. (ChrisPriceAB, 15:28:24)
    12. main wiki page has been updated with links to etherpads which are to supply additional info on meetups/hackfests (for Feb19, Feb 23) (frankbrockners, 15:30:31)
    13. I have to drop now, Bin will stand in for me now (bryan_att, 15:31:29)
    14. AGREED: The TSC has come to concensus that the locations proposed by the LinuxFoundation for the HackFest will be sufficient and that they should proceed to secure the venue. (ChrisPriceAB, 15:32:35)

  7. Development process (ChrisPriceAB, 15:33:21)
    1. agree that's specifically the plan for copper... To create blueprints etc as output of the first release (bryan_att, 15:37:30)
    2. I can help do that (bryan_att, 15:37:51)
    3. ie facilitate the discussion (bryan_att, 15:38:13)
    4. ACTION: bryann_att to kick offf discussions around the design process for requirements rpojects (ChrisPriceAB, 15:39:21)
    5. ChrisPriceAB opens the floor to discussions around our collaborative development project structure (ChrisPriceAB, 15:42:00)
    6. cdub: comments that structuring our development projects around upstream communities provides a structure to engage with the communities. (ChrisPriceAB, 15:42:42)
    7. as yet we do not have mechanisms for working with upstream projects, not the deployment scripts for our CI. (ChrisPriceAB, 15:43:13)
    8. frankbrockners indicates using a "trial project" will provide guidance one our development process. Proving the process by activity would seem to be the best way. (ChrisPriceAB, 15:45:08)
    9. I would start our assuming that projects with multiple up streams should directly commit to them, e.g. Copper will commit to ODL and OpenStack (bryan_att, 15:45:25)
    10. cdub indicates kicking off an OpenStack project would be a good starting point. Feedback has been received that OPNFV could improve it's collaboration with OpenStack. (ChrisPriceAB, 15:45:59)
    11. https://etherpad.opnfv.org/p/DevProcess <-- strawman proposal (cdub, 15:46:12)
    12. frankbrockners agreed that kicking off a project on OpenStack would be a great way to start. (ChrisPriceAB, 15:46:28)
    13. having a SPOC as commit passthru will potentially create a bottleneck. Not that it might not optimize some projects, but for others may be a unnecessary overhead (bryan_att, 15:46:37)
    14. we need to keep subject areas contiguous and not arbitrarily split projects across multiple collab dev projects. IPv6 and Copper are good examples of how we need them to be mostly autonomous (bryan_att, 15:49:32)
    15. these projects will commit code in later phases (bryan_att, 15:49:53)
    16. frankbrockners noted that a beachhead project should be concise in nature - i.e. no "general engagement with O/S" but focused on e.g. HA, or IPv6 etc. (frankbrockners, 15:50:00)
    17. ChrisPriceAB notes config isn't trivial (cdub, 15:53:32)
    18. I think committing happens directly to the upstream but is done by the OPNFV projects. So I still am confused by the last discussion on that point. I think we need some more clarity on the list re how people expect the code to get to the upstream, and the role of discrete projects in pushing commits upstream. (bryan_att, 15:55:41)
    19. ACTION: ChrisPriceAB and cdub to organise inviting members of the OpenStack TC to the OPNFv TSC call for a 30 minute bilateral discussion (ChrisPriceAB, 15:56:49)
    20. semantics (bryan_att, 15:57:10)
    21. in practical terms OPNFV members will be committing to the upstream on behalf of various projects, whether you view than as individuals or as a team in OPNFV (bryan_att, 15:58:19)
    22. gotta drop for real this time. I look forward to the discussion on how we interact with the upstream. I'm not a SME there and probably have some things to learn. I just suggest we team an OPNFV team/project approach to upstreaming. (bryan_att, 16:02:24)

  8. Project Approvals Name and committer check - opnfv_telco_kpi_monitoring (ChrisPriceAB, 16:08:16)
    1. https://wiki.opnfv.org/collaborative_development_projects/opnfv_telco_kpi_monitoring (ChrisPriceAB, 16:08:33)
    2. the project has been renamed to Software Fastpath Service Quality Metrics (ChrisPriceAB, 16:08:57)
    3. discussion around the project being requirements or development ensues (ChrisPriceAB, 16:10:35)
    4. frankbrockners asks if the project would act as a "beach-head" project for working through the development process in OPNFV. (ChrisPriceAB, 16:13:17)
    5. We would monitor and discuss the methodologies and challenges of this project as a method of iteratively improving and refining our processes. (ChrisPriceAB, 16:13:58)
    6. Ashiq agrees with Frank. cdub agrees it is a good target project for evaluating our processes. (ChrisPriceAB, 16:15:23)
    7. AGREED: fastpathmetrics project creation approved by the TSC (ChrisPriceAB, 16:27:22)

  9. Review of the vSwitch Performance project (ChrisPriceAB, 16:28:14)
    1. https://wiki.opnfv.org/characterize_vswitch_performance_for_telco_nfv_use_cases (ChrisPriceAB, 16:28:17)
    2. Mark Gray presents the project proposal (ChrisPriceAB, 16:28:56)
    3. Parviz asks if there is a table or such for benchmarking today on jitter and delay (ChrisPriceAB, 16:34:50)
    4. Mark answers that the project intends to help create such a benchmark (ChrisPriceAB, 16:35:12)
    5. Parvis asks if the ETSI NFV documents have been referenced (ChrisPriceAB, 16:36:14)
    6. Mike responds that they have and are intending to remain aligned with those references (ChrisPriceAB, 16:36:37)
    7. frankbrockners asks if there is a vSwitch identified as a starting point. The response is to start with OVS/DPDK however the project does not limit itself to that vSwitch (ChrisPriceAB, 16:40:10)
    8. Mark answers that some specific hardware will be required and that it will be described for the OPNFV infrastructure (ChrisPriceAB, 16:52:12)
    9. frankbrockners asks what requirements exist on the hardware for this project. (frankbrockners, 16:52:33)
    10. trevor_intel explains that there is a description of the required hardware on the test and infrastructure page. (ChrisPriceAB, 16:53:50)


Meeting ended at 17:00:02 UTC (full logs).

Action items

  1. ChrisPriceAB establish a specific topic in the e-mails for requesting creation reviews.
  2. bryann_att to kick offf discussions around the design process for requirements rpojects
  3. ChrisPriceAB and cdub to organise inviting members of the OpenStack TC to the OPNFv TSC call for a 30 minute bilateral discussion


Action items, by person

  1. cdub
    1. ChrisPriceAB and cdub to organise inviting members of the OpenStack TC to the OPNFv TSC call for a 30 minute bilateral discussion
  2. ChrisPriceAB
    1. ChrisPriceAB establish a specific topic in the e-mails for requesting creation reviews.
    2. ChrisPriceAB and cdub to organise inviting members of the OpenStack TC to the OPNFv TSC call for a 30 minute bilateral discussion


People present (lines said)

  1. ChrisPriceAB (71)
  2. bryan_att (16)
  3. frankbrockners (8)
  4. cdub (6)
  5. collabot` (6)
  6. TapioT (5)
  7. uli_ (4)
  8. bin_ (3)
  9. Wenjing_Chu (3)
  10. Ashiq (3)
  11. rpaik (3)
  12. Parviz (2)
  13. aricg (1)
  14. Palani (1)
  15. morgan_orange (1)
  16. B_Smith (1)
  17. Wenjing (1)


Generated by MeetBot 0.1.4.