#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:57:35 UTC (full logs).

Meeting summary

    1. Gerald Kunzmann (DOCOMO) (GeraldK, 14:57:43)
    2. Chris Price (ChrisPriceAB, 14:58:05)
    3. Uli Kleber (uli_, 14:58:24)
    4. Frank Brockners (frankbrockners, 15:01:06)
    5. Julien (julien_ZTE, 15:01:40)
    6. Trevor Cooper (trevor_intel, 15:01:56)
    7. Bryan Sullivan (bryan_att, 15:03:05)
    8. Pranav Mehta (Pranav, 15:04:11)
    9. Carlos Goncalves (cgoncalves, 15:04:20)
    10. Tapio Tallgren (TapioT, 15:04:44)
    11. Bin Hu (bin_, 15:06:38)

  1. OPNFV interim hardware solutions (ChrisPriceAB, 15:06:50)
    1. GeraldK (for Ashiq @DOCOMO) (rpaik, 15:07:06)
    2. frankbrockners describes that there are two environments that could be leveraged and asks for a description of each to be provided for the community. (ChrisPriceAB, 15:07:49)
    3. Sheng-Ann from Ericsson describes that there is an environment available from Ericsson. (ChrisPriceAB, 15:08:51)
    4. Jonas Bjurel adds that there is a POD with 12 blades, including 64GB Ram and SSD storage. (ChrisPriceAB, 15:09:40)
    5. Needs to go through VPN currently (rpaik, 15:10:05)
    6. There are restrictions on access with no SSH access available, the solutions requires a VPN tunnel which is cumbersome for accessing the lab. (ChrisPriceAB, 15:10:10)
    7. ACTION: Jonas to post information on the wiki on how to get access to hardware at Ericsson (rpaik, 15:11:23)
    8. Trevor shared status of Intel infrastructure @Hillsboro, OR (rpaik, 15:13:38)
    9. it would be great, and more effective on TSC calls, if this info could be posted to the wiki in advance of the meeting so we could review it instead of going over it in realtime (bryan_att, 15:14:34)
    10. palani (Palani, 15:16:35)
    11. Palani and others were able to access the hardware, but Trevor still need to setup individual accounts (rpaik, 15:19:19)
    12. Wenjing Chu (Wenjing, 15:21:38)
    13. frank asks how many servers could be dedicated to OPNFV projects (ChrisPriceAB, 15:21:53)
    14. also how does the community gain access to the equipment (ChrisPriceAB, 15:22:02)
    15. Trevor answers that currently 6 servers are available for bootstrap/get started (ChrisPriceAB, 15:22:23)
    16. it may be possible to include more servers (ChrisPriceAB, 15:22:46)
    17. franks mentions 2 PODs would be ideal (one of the PODs would be for testing) (rpaik, 15:24:31)
    18. Trevor clarifies that access to the facilities will be incremented slowly and once the system is operational access would be granted by asking Trevor (ChrisPriceAB, 15:25:06)
    19. ACTION: Trevor to provide an update by the next TSC call (Jan 20th) or send a note to the mailing lists (rpaik, 15:26:54)
    20. Wenjing notes that Dell will also have infrastructure that can be used (rpaik, 15:31:00)

  2. OPNFV hardware discussion and decision (ChrisPriceAB, 15:32:22)
    1. https://wiki.opnfv.org/get_started/get_started_work_environment (rpaik, 15:32:37)
    2. Chris mentions that the number of servers per PODs may need to be corrected (3 Control Node + 2 Compute Node + 1 Jump Server?) (rpaik, 15:39:35)
    3. I have updated wiki (julien_ZTE, 15:42:14)
    4. question if non-members can contribute hardware (rpaik, 15:42:55)
    5. OPNFV accepts contribution from everyone (rpaik, 15:44:42)
    6. question frankbrockners why the board requires 7 disks (julien_ZTE, 15:47:09)
    7. Frank replied that it should be 6 servers per POD (rpaik, 15:49:30)
    8. ACTION: frank and chris to bring a proposal to the TSC for voting and decision next week. (ChrisPriceAB, 15:52:12)
    9. ACTION: Frank & Chris P. to come back with a set of proposals/quotes (rpaik, 15:52:13)

  3. Bootstrap update & discussion - 5 mins (ChrisPriceAB, 15:53:04)
    1. Since last TSC the team has met and discussions on the BS project have agreed on a conference call at 08:00 Mondays (PST) (ChrisPriceAB, 15:53:50)
    2. HW requirements have been the focus in the last days. (ChrisPriceAB, 15:54:08)
    3. IRC meeting also moved to 8am PT (rpaik, 15:54:18)

  4. CI update & discussion < 5 mins (ChrisPriceAB, 15:55:59)
    1. nothing to report (ChrisPriceAB, 15:56:23)

  5. Parser project aspects of interest to release 1 - 5 mins (ChrisPriceAB, 15:56:27)
    1. I will update wiki with schedule etc (bin_, 15:57:05)
    2. Parser project may bring additional value to the release as it is independant from projects and integration. (ChrisPriceAB, 15:57:39)
    3. Release 1 will provide an executable platform, even if it has 0 new features it will be valuable. (bryan_att, 15:59:32)
    4. I think we need to be realistic, and just establishing a lab environment in which we can cobble together (cobbling *well* of course) *one* platform definition into a useful platform, will be enough and probably the most we can really achieve IMO. (bryan_att, 16:00:51)
    5. Chris concerned that Parser may take resources/focus away from work needed for Release 1 (rpaik, 16:05:10)
    6. I see no reason why projects can't be approved with a Release 2 timeline. (bryan_att, 16:05:32)
    7. Suggestion was made that it’d be helpful to clarify the scope of Release 1 (rpaik, 16:07:55)

  6. WiKi page maintenance and procedures (ChrisPriceAB, 16:08:00)
    1. ACTION: Chris to begin a WiKi maintenance and governance team on the OPNFV mailing lists (ChrisPriceAB, 16:09:33)

  7. Project Review: OSCAR - continuous deployment project (ChrisPriceAB, 16:09:47)
    1. https://wiki.opnfv.org/oscar/project_proposal (rpaik, 16:10:02)
    2. I think that project leads should be able to (and proactive in) managing the wiki for their projects. General sections of the wiki need a maintainer but overall I don't see any major issue with wiki management. People just need to post the current info and remove the old, proactively. (bryan_att, 16:10:13)
    3. Uli ask if Stack #2 is available to the community (rpaik, 16:21:29)
    4. Stuart Mackie replied that it is available on github & OpenContrail site (rpaik, 16:22:54)
    5. OSCAR can provide another installer (rpaik, 16:26:23)
    6. Discussion if March’15 release is acheivable (rpaik, 16:29:07)
    7. suggestion was made to change the repo name to oscar (rpaik, 16:29:39)
    8. updated the repo name (rpaik, 16:31:18)
    9. VOTE: Voted on "Vote to create the OSCAR project as an incubation project in OPNFV?" Results are, +1: 11 (ChrisPriceAB, 16:32:09)

  8. Project Review: Pharos - Testbed Infrastructure project (ChrisPriceAB, 16:32:51)
    1. https://wiki.opnfv.org/opnfv_testbed_infrastructure (rpaik, 16:32:58)
    2. Wenjing describes the need for creating a common federated solution for working with the breadth of the community test beds prviding a common interface to the community. (ChrisPriceAB, 16:35:59)
    3. hosted sites in asia, europe and the US have been identified. (ChrisPriceAB, 16:37:12)
    4. A common set of test tools, behaviours & reports is the primary goal of the project. (ChrisPriceAB, 16:37:53)
    5. the project will not cover; performance & benchmarking, VNF deployment testing, Carrier grade requirements. (ChrisPriceAB, 16:40:00)
    6. Pravan asks how the test bed will allow both functional and performance test cases to be run. (ChrisPriceAB, 16:43:46)
    7. Wenjing describes that there will be a specific project for performance testing which may require specific hardware capabilities. The scope of this project is a "minimum scope" that can run general testing including "generic performance" testing. (ChrisPriceAB, 16:45:20)
    8. frankbrockners asks how companies can join the project to participate in the test bed. Does the project define what can be included or is the test bed able to define itself in the project? (ChrisPriceAB, 16:50:40)
    9. Wenjing answers that this project can help bring new test beds into the federation faster, the project does not dictate the definition of the test bed, however some expectation will exist. (ChrisPriceAB, 16:51:56)
    10. Wenjing clarifies that a work item exists to define access needs for labs wanting to participate. No conclusions have been arrived at at this stage. (ChrisPriceAB, 16:53:22)
    11. VOTE: Voted on "Vote to create the Pharos project as an incubation project in OPNFV?" Results are, +1: 12 (ChrisPriceAB, 16:57:56)

  9. Events for Q1 2015 (ChrisPriceAB, 16:58:01)
    1. Ray outlines that there are 2 events in February, collab summit and a hack-fest (ChrisPriceAB, 16:58:35)
    2. opnfv trello page (zhipeng, 16:58:57)
    3. https://etherpad.opnfv.org/p/MeetUpFeb19 (ChrisPriceAB, 16:59:01)
    4. https://trello.com/opnfvdev (zhipeng, 16:59:01)
    5. I will be at the LF meetup in Santa Rosa, if you need help let me know. (bryan_att, 16:59:26)
    6. https://etherpad.opnfv.org/p/HackfestFeb23 (ChrisPriceAB, 16:59:32)
    7. please add notes and information in the etherpads for input into the event planning calls (ChrisPriceAB, 16:59:49)
    8. will we have a functional testbed before the LF meetup? (bryan_att, 17:00:18)


Meeting ended at 17:01:13 UTC (full logs).

Action items

  1. Jonas to post information on the wiki on how to get access to hardware at Ericsson
  2. Trevor to provide an update by the next TSC call (Jan 20th) or send a note to the mailing lists
  3. frank and chris to bring a proposal to the TSC for voting and decision next week.
  4. Frank & Chris P. to come back with a set of proposals/quotes
  5. Chris to begin a WiKi maintenance and governance team on the OPNFV mailing lists


People present (lines said)

  1. ChrisPriceAB (50)
  2. rpaik (25)
  3. collabot` (14)
  4. bryan_att (10)
  5. dneary (7)
  6. TapioT (5)
  7. julien_ZTE (4)
  8. Pranav (4)
  9. cgoncalves (4)
  10. frankbrockners (4)
  11. uli_ (3)
  12. GeraldK (3)
  13. Wenjing (3)
  14. cdub (2)
  15. bin_ (2)
  16. Parviz (2)
  17. zhipeng (2)
  18. Hui (1)
  19. Andrea_ (1)
  20. Palani (1)
  21. B_Smith (1)
  22. trevor_intel (1)


Generated by MeetBot 0.1.4.