#opnfv-meeting: Octopus

Meeting started by ulik at 15:13:39 UTC (full logs).

Meeting summary

    1. Fatih explains his work on the LF setup and walks us through the new infrastructure wiki page (ulik, 15:14:25)
    2. https://wiki.opnfv.org/octopus/infrastructure (ulik, 15:15:01)
    3. discussion on which plugins are needed (ulik, 15:15:26)
    4. Jerry (Zhaoxinyu) proposes to use zuul (ulik, 15:15:59)
    5. Carlos asks about forge.io (ulik, 15:17:25)
    6. Uli asks how much we can re-use from ODL or OpenStack CI setup? (ulik, 15:21:00)
    7. Jerry mentions the problem of permissions for jenkins (ulik, 15:21:34)
    8. Jerry proposes to solve this using the jenkins job builder (ulik, 15:21:55)
    9. Jerry explains more about job builder. (ulik, 15:25:07)
    10. we need job creation permission to get the plugins installed and use job builder (ulik, 15:27:00)
    11. Jerry explains that this way we don't need to ask Aric for every plugin. (ulik, 15:27:46)
    12. AGREED: to use job builder and ask Aric to install the cron job and necessary plugins for this (ulik, 15:28:59)
    13. Uli proposes to collect here the information which plugins Aric should install initially (ulik, 15:29:49)
    14. Jenkins Job Builder plugin can help addressing the way to create/use/configure jobs (fdegir, 15:30:53)
    15. Correction: Jenkins Job Builder is not a plugin. It is just an application to install. (fdegir, 15:32:13)
    16. Uli asks about what permissions are needed. (ulik, 15:34:27)
    17. Fatih says job creation permission should be enough. (ulik, 15:34:44)
    18. Uli proposes Fatih and Jerry be provided with job creation permission and may be few more contributors. (ulik, 15:36:37)
    19. ACTION: ulik to ask Aric for 2 more people with job creation permission (ulik, 15:39:13)
    20. Fatih shows what he has proposed for release 1 (ulik, 15:40:00)
    21. https://wiki.opnfv.org/octopus/flows (ulik, 15:41:11)
    22. the page talks about contributors/committers of other projects in that flow. The first commit should be getting BGS output to rerun BGS work automatically. (ulik, 15:44:37)
    23. Frank confirms that this is the goal. (ulik, 15:45:30)
    24. discussion on the runtime of such jenkins job (ulik, 15:46:36)
    25. ACTION: to all to review this wiki page and further define these work flows. (ulik, 15:48:40)
    26. Uli asks about the test inputs (ulik, 15:49:20)
    27. tempest and robot will help organize the tests. (ulik, 15:50:02)
    28. Jerry proposes also to use rally (ulik, 15:50:46)
    29. Jerry explains that openstack uses these and deep down inside all use "tester" to run the tests. (ulik, 15:52:10)
    30. uli asks if these tools need installation. Answer: rally needs to be installed. (ulik, 15:54:50)
    31. We should wait for functest to decide whether they need that. (ulik, 15:55:33)
    32. on tempest installation: http://fosshelp.blogspot.in/2014/02/how-to-manually-install-openstack.html (frankbrockners, 15:55:59)


Meeting ended at 16:02:12 UTC (full logs).

Action items

  1. ulik to ask Aric for 2 more people with job creation permission
  2. to all to review this wiki page and further define these work flows.


Action items, by person

  1. ulik
    1. ulik to ask Aric for 2 more people with job creation permission


People present (lines said)

  1. ulik (34)
  2. collabot (6)
  3. frankbrockners (3)
  4. fdegir (2)
  5. jerryz (0)


Generated by MeetBot 0.1.4.