#opnfv-meeting: TSC Meeting

Meeting started by ChrisPriceAB at 14:59:14 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:59:24)
    1. Chris Price (ChrisPriceAB, 14:59:30)
    2. Uli Kleber (ulik, 14:59:57)
    3. Frank Brockners (frankbrockners, 15:00:56)
    4. Dirk Kutscher (dku, 15:00:59)
    5. dlenrow (dlenrow, 15:01:03)
    6. Parviz Yegani (Parviz, 15:02:03)
    7. Pierre Lynch (plynch, 15:02:12)
    8. Thomas Nadeau (Thomas_, 15:02:21)
    9. Pranav Mehta (Pranav, 15:03:09)
    10. Bryan Sullivan (bryan_att, 15:03:43)
    11. Thinh Nguyenphu (Thinh_, 15:03:50)

  2. Approval of previous minutes (ChrisPriceAB, 15:03:54)
    1. Ashiq Khan (Ashiq, 15:03:56)
    2. AGREED: TSC approves the precious minutes of the meeting (ChrisPriceAB, 15:04:18)

  3. agenda bashing (ChrisPriceAB, 15:06:07)
    1. due to chinese new year the following project will not be able to be presented today: Resource Schdeuler - Resource Scheduler: (ChrisPriceAB, 15:06:42)
    2. Julien (julien_ZTE, 15:07:18)
    3. adding a discussion on licencing of software in OPNFV (ChrisPriceAB, 15:07:26)
    4. adding a board meeting review to the agenda (ChrisPriceAB, 15:08:22)

  4. Formation of an OPNFV Security Group (ChrisPriceAB, 15:09:29)
    1. luke has been leading community discussions around security for OPNFV (ChrisPriceAB, 15:10:04)
    2. the team have identified themselves as more of a working group than a project as such. (ChrisPriceAB, 15:10:23)
    3. https://wiki.opnfv.org/security (ChrisPriceAB, 15:10:53)
    4. luke has in addition sent an e-mial to the community outlining the intentions and actions to be addressed by the security group in OPNFV. (ChrisPriceAB, 15:12:08)
    5. there is a big interest in working with upstream security working groups (ChrisPriceAB, 15:13:43)
    6. Pranav asks what the deliverable would be for such a working group, he feels a requirements project might be a good way to capture anticipated needs on the platform. (ChrisPriceAB, 15:14:27)
    7. Luke refers to the e-mail identifying research areas and working closely with project to improve the security aspects of the platform (ChrisPriceAB, 15:15:08)
    8. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2015-February/001120.html (ChrisPriceAB, 15:16:11)
    9. the above link refers to the mentioned e-mail (ChrisPriceAB, 15:16:27)
    10. Parviz asks what would be relevant to this group, if the ETSI NFV security group would have influence (ChrisPriceAB, 15:17:57)
    11. Luke answers that the ETSI NFV SG have already been invited to the discussion and there is an intention to feed-back to that and other upstream teams (ChrisPriceAB, 15:18:41)
    12. Pranav stresses the need to work toward actionable items for development that lead to security improvements in the platform (ChrisPriceAB, 15:19:32)
    13. AGREED: the TSC agrees to support the establishment of an OPNFV security group as outlined in the linked e-mail and WiKI pages. (ChrisPriceAB, 15:34:43)

  5. Discussion on licencing of sourced software in OPNFV. (ChrisPriceAB, 15:36:17)
    1. Bryan refers to the use of software in OPNFV where we are using software with GPL licenses, where we have a goal of being an Apache licensed project. (ChrisPriceAB, 15:37:20)
    2. ACTION: rpaik to request clarity on working with upstream GPL licenses in the OPNFV platform. (ChrisPriceAB, 15:41:29)
    3. ACTION: rpaik to add guidelines for contributions upstream under different licenses to https://wiki.opnfv.org/developer (ChrisPriceAB, 15:44:04)
    4. ACTION: rpaik to identify how code scanning is being implemented in OPNFV and if it is automated (ChrisPriceAB, 15:45:18)

  6. OPNFV Release 1 discussion (ulik, 15:48:30)
  7. OPNFV Release 1 discussion (ChrisPriceAB, 15:48:31)
    1. https://etherpad.opnfv.org/p/bgs (frankbrockners, 15:48:49)
    2. https://wiki.opnfv.org/get_started/get_started_release_plan (frankbrockners, 15:49:00)
    3. BGS milestones: End of Feb. base installer completed (rpaik, 15:50:11)
    4. mid-March: Install on OPNFV hardware & CI integration (rpaik, 15:51:32)
    5. end-of-March: Tempest / Robot scenario tests avail (rpaik, 15:52:12)
    6. . Recommend 2-4 additional weeks for Release 1 (rpaik, 15:53:52)
    7. multiple installers is not a gating factor for timeline as work is being done in parallel (rpaik, 15:57:40)
    8. Frank notes that by end of Feb, HA limited to OpenStack (rpaik, 16:02:59)
    9. Uli provided CI update and noted that Jenkins is setup (rpaik, 16:04:24)
    10. https://wiki.opnfv.org/octopus/infrastructure (ulik, 16:05:27)
    11. https://wiki.opnfv.org/octopus/flows (ulik, 16:05:41)
    12. Trevor outlines the function test requirements (ChrisPriceAB, 16:06:47)
    13. https://etherpad.opnfv.org/p/functiontestrelease1activities (ChrisPriceAB, 16:06:50)
    14. Chirs notes the expectation is that the CI first deploys and tesing will be invoked from the staging server and Jenkins will determine success/failure (rpaik, 16:11:36)
    15. Chris noted that BGS documentation is also needed (rpaik, 16:22:36)
    16. Thomas Nadeau (Guest52317, 16:26:36)
    17. AGREED: The TSC agrees to target the release for April, during the next week further work will continue to define the exact target date in April. To be agreed in the next TSC meeting. (ChrisPriceAB, 16:27:15)

  8. TSC update to the board (ChrisPriceAB, 16:28:22)
    1. the TSC update to the board was shared, there were questions around other topics on the board calls. (ChrisPriceAB, 16:48:07)
    2. the general agenda was discussed and it was proposed that other groups cross report to the TSC on related topics as well as to the board. (ChrisPriceAB, 16:48:47)

  9. creation review of the openstack based vnf forwarding graph project. (ChrisPriceAB, 16:51:41)
    1. next week will be Chinese New Year. Shall we cancel next week TSC meeting? (julien_ZTE, 16:51:45)
    2. https://wiki.opnfv.org/requirements_projects/openstack_based_vnf_forwarding_graph (ChrisPriceAB, 16:51:55)
    3. Cathy updated the diagram as and text in the document. (ChrisPriceAB, 16:53:03)
    4. discussion on how the project proposal fits within the scope of OPNFV (rpaik, 17:05:54)
    5. VOTE: Voted on "TSC vote to create the openstack based VNF forwarding graph project?" Results are, +1: 9 (ChrisPriceAB, 17:08:16)


Meeting ended at 17:08:25 UTC (full logs).

Action items

  1. rpaik to request clarity on working with upstream GPL licenses in the OPNFV platform.
  2. rpaik to add guidelines for contributions upstream under different licenses to https://wiki.opnfv.org/developer
  3. rpaik to identify how code scanning is being implemented in OPNFV and if it is automated


Action items, by person

  1. rpaik
    1. rpaik to request clarity on working with upstream GPL licenses in the OPNFV platform.
    2. rpaik to add guidelines for contributions upstream under different licenses to https://wiki.opnfv.org/developer
    3. rpaik to identify how code scanning is being implemented in OPNFV and if it is automated


People present (lines said)

  1. ChrisPriceAB (50)
  2. collabot (12)
  3. rpaik (11)
  4. ulik (6)
  5. Guest52317 (4)
  6. frankbrockners (3)
  7. aricg (3)
  8. Pranav (2)
  9. dku (2)
  10. dlenrow (2)
  11. bryan_att (2)
  12. rprakash__ (2)
  13. Ashiq (2)
  14. julien_ZTE (2)
  15. plynch (1)
  16. AndreaP (1)
  17. Thinh_ (1)
  18. fdegir (1)
  19. Thomas_ (1)
  20. Parviz (1)


Generated by MeetBot 0.1.4.