#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:01:28 UTC (full logs).

Meeting summary

    1. dlenrow (dlenrow, 15:01:32)
    2. Chris Price (ChrisPriceAB, 15:01:35)
    3. Bryan Sullivan (bryan_att, 15:01:41)
    4. Uli Kleber (ulik, 15:01:46)
    5. Frank Brockners (frankbrockners, 15:01:46)
    6. Tapio Tallgren (Nokia) (tapio__, 15:02:10)
    7. fuqiao (proxy (fuqiao, 15:02:29)

  1. Approval of previous minute (ChrisPriceAB, 15:02:39)
    1. AGREED: TSC approved the previous minutes (ChrisPriceAB, 15:03:06)

  2. Agenda Bashing (ChrisPriceAB, 15:03:13)
    1. Gerald Kunzmann (DOCOMO) (Gerald_K, 15:03:59)
    2. I would like to add a discussion about OpenStack blueprint deadlines and how we act in a coordinated manner across OPNFV. (bryan_att, 15:04:21)
    3. I'll help (dlenrow, 15:05:56)

  3. Review of NFV#9 meeting (ChrisPriceAB, 15:06:38)
    1. Chris at TST meeting at ETSI, proposed a contribution re similarity between reqs & defs on Phase 2 for testing (bryan_att, 15:07:43)
    2. ... similarities etc call for closer collaboration with OPNFV (bryan_att, 15:08:29)
    3. ... we need to get access to the ETSI proposals e.g. a link if it can be open (bryan_att, 15:10:04)
    4. ... Chris will add a note to the list on what was stated in case we dont have access (bryan_att, 15:10:26)
    5. CP stated to SDO collab meeting agreed to LOI between ETSI and OPNFV (dlenrow, 15:10:56)
    6. ... ETSI plans to write a letter of intent re cross-group coorindation, leveraging work across groups (bryan_att, 15:11:02)
    7. ... cross-consortia discussion went on later, anyone there to share what happened? (bryan_att, 15:11:51)
    8. Parviz was there (bryan_att, 15:12:03)
    9. TMF, ETSI NFV, 3GPP SA5 will work closely together (Gerald_K, 15:12:32)
    10. ... TMF, ETSI ISG, 3GPP SA5 will work to enhance the mgmt stack. Immediate OPNFV impact may be minimal (bryan_att, 15:12:36)
    11. ... TMF ZOOM will work with ISG on Phase 2 POCS (bryan_att, 15:13:13)
    12. JUlien (julien_ZTE, 15:13:16)
    13. ... Work in SA5 will inform specs for MANO stack (bryan_att, 15:13:48)
    14. ... open question is how to coordinate the ISG IFA WG (interfaces & arch) and SA5 (bryan_att, 15:14:24)
    15. ... ZOOM is being used as "marketing collateral" to influence the industry on NFV (bryan_att, 15:15:02)
    16. http://docbox.etsi.org/ISG/NFV/05-CONTRIBUTIONS/2015/NFV(15)000057_Further_collaboration_between_OPNFV_and_ETSI_NFV.docx (ETSI Portal; closed for ETSI members) (Gerald_K, 15:15:28)
    17. (available to ETSI members) (Gerald_K, 15:15:48)
    18. Dave L was there; ETSI was happy OPNFV supported it also. (bryan_att, 15:15:48)
    19. dlenrow adds that ETSI NFV leadership was very happy that OPNFV attended, and were also apologetic about the lack of agility/bureaucracy in the ETSI process (dneary, 15:16:11)
    20. no action items for OPNFV from that workshop (Gerald_K, 15:16:48)

  4. OPNFV Release 1 Naming (ChrisPriceAB, 15:17:12)
    1. Ray sent the suggestions on names out to the list based on current inputs (ChrisPriceAB, 15:17:56)
    2. Ray asks if we settled on "A" and real names (bryan_att, 15:18:01)
    3. Chris: we haven't voted on methodology - that should be implicit in the vote (bryan_att, 15:18:36)
    4. ... we need to trim the options; any we can drop, or any higher priority? (bryan_att, 15:19:00)
    5. ... it can be anything at this point - we have not eliminated all but "A" e.g. (bryan_att, 15:19:31)
    6. in OpenStack there is also a legal review (Gerald_K, 15:19:40)
    7. we should also do this filter before doing the voting (Gerald_K, 15:19:54)
    8. ... e.g. for (TM) (bryan_att, 15:20:25)
    9. The filter is to names which could lead to trademark issues (like Amazon, perhaps) (dneary, 15:20:34)
    10. Pranav Mehta (Pranav_, 15:21:19)
    11. I like fictional rivers (bryan_att, 15:21:48)
    12. how about Phoenix (bryan_att, 15:22:21)
    13. what about "anchor" holding OPNFV together a river name (rprakash, 15:22:36)
    14. or Styx (bryan_att, 15:24:05)
    15. alphabetical order has benefit of being "predictable" and will avoid for the same discussion all over (Gerald_K, 15:24:06)
    16. Chris: OK to allow Ray to simplify the list and get legal approval, run a doodle etc? (bryan_att, 15:24:51)
    17. Frank: only the TSC can vote? (bryan_att, 15:25:54)
    18. Chris: good question - put to the TSC, community, or anyone? (bryan_att, 15:26:25)
    19. Ray: it would be hard to open it too wide (bryan_att, 15:26:41)
    20. Dave keep it simple, to the tech-discuss list. (bryan_att, 15:27:22)
    21. I'd go with the community voting if feasible (AndreaP, 15:27:47)
    22. Chris: it is a community right to have a vote on this (Gerald_K, 15:28:01)
    23. Frank: we should include name with vote (bryan_att, 15:28:10)
    24. AGREED: That voting shall be open to all participants of the opnfv-tech-discuss list, we will ask voters to enter their name when voting. (ChrisPriceAB, 15:29:02)

  5. opnfv-tech-discuss topic filters (ChrisPriceAB, 15:29:28)
    1. Parviz Yegani (Parviz, 15:29:31)
    2. Ray: topic filter email sent out last week - use Jira name rather than repo name (ChrisPriceAB, 15:30:26)
    3. Bryan: why do we need to change (bryan_att, 15:32:17)
    4. why not use filter on email client side? (Gerald_K, 15:32:48)
    5. if you want to address a specific project, use a specific tag in the email subject (Gerald_K, 15:33:27)
    6. A tag includes the project tag [BGS] in the e-mail header (ChrisPriceAB, 15:33:40)
    7. you can choose in the mailman config which tags to receive (Gerald_K, 15:34:05)
    8. should be "disabled" by default. anyone who wants to use it can "enable" it (Gerald_K, 15:34:59)
    9. enable auto-filtering in subject-line with project-name=repo-name or project specified tag and this optional (rprakash, 15:37:46)
    10. AGREED: TSC agrees to enable filters on opnfv-tech-discuss, Ray will provide clarification on the wiki. (ChrisPriceAB, 15:38:13)
    11. Chris: need to address project naming conventions etc (bryan_att, 15:38:46)
    12. ... call for a proposal for project name & tool chain proposals (bryan_att, 15:39:05)
    13. Project naming conventions, repo names, Jeera project tags (volunteers?) (rprakash, 15:39:50)
    14. https://wiki.opnfv.org/developers/project_page_template (rpaik, 15:39:50)
    15. Ray: project page template can include instructions (bryan_att, 15:40:11)
    16. ACTION: Ray & Chris to update the project page template and project key facts sections to reflect the naming needs across Jira/mail/repositories (ChrisPriceAB, 15:40:17)

  6. Maintaining project leader, committer & contributor list (ChrisPriceAB, 15:40:51)
    1. Ray: Aric had an idea for source info better than the wiki (bryan_att, 15:41:31)
    2. Ray explains that the current method of managing project leader, committer and contributors on the wiki is creating some confusion. (ChrisPriceAB, 15:41:34)
    3. Aric: wiki list can be modified - have to go back and review changes; adding a list of contributors to the repo would enable automatic reports (bryan_att, 15:43:02)
    4. aric proposes that when a project is created a file is created in the repository that describes the current list of committers & project lead. (ChrisPriceAB, 15:43:04)
    5. "commiters" should be in repo, but contributors can be many and change , so access control should be for commiters? (rprakash, 15:44:57)
    6. pals (pals, 15:44:57)
    7. Frank: it would be good to have HTTP access to the wiki so that it can be easily synced with the wiki (bryan_att, 15:46:10)
    8. ... "access to the repo"... (bryan_att, 15:46:27)
    9. ... key project facts should be stable and visible on the wiki - a uniform source of info (bryan_att, 15:46:53)
    10. +1 to Frank's proposal (bryan_att, 15:47:06)
    11. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=summary (aricg, 15:47:41)
    12. Aric: gitweb doesn't need authentication (bryan_att, 15:48:07)
    13. ACTION: frankbrockers and hinds to work with aric to prototype autogenerating key project facts onto the wiki pages. (ChrisPriceAB, 15:49:26)
    14. Chris: every project needs a leader / contact person (bryan_att, 15:50:07)
    15. ACTION: hinds to propose a security project for documentation and activity (ChrisPriceAB, 15:50:49)

  7. Development tool training, Jira, Gerrit, Git, Jenkins (ChrisPriceAB, 15:51:09)
    1. Chris: not all are familiar with tools e.g. agile, jira, tying to gerrit etc (bryan_att, 15:51:50)
    2. ... some members would be willing to do basic walkthrus (bryan_att, 15:52:06)
    3. +1 (bryan_att, 15:52:19)
    4. ... how do we move forward (bryan_att, 15:52:44)
    5. Bryan just get people started setting up the sessions (bryan_att, 15:52:56)
    6. Chris: will do that, record on GTM etc for later use (bryan_att, 15:53:20)
    7. ACTION: chris to oraganise training sessions and record them for others to follow (ChrisPriceAB, 15:53:30)
    8. some tutorial and recording of training sessions for getting started on tools (rprakash, 15:53:36)

  8. Release 1 Updates (bryan_att, 15:53:54)
    1. Chris: goal is R1 happens when we have achieved our intent, but is time-boxed (bryan_att, 15:54:27)
    2. ... Uli captured some text on that (bryan_att, 15:54:45)
    3. Uli: sent an email with text, and put it on an etherpad (bryan_att, 15:55:19)
    4. https://etherpad.opnfv.org/p/release1 (ulik, 15:55:19)
    5. ... Added Chris' intro, comments, and a summary, functionality, documentation, operations environment, availability (bryan_att, 15:56:20)
    6. ... should serve as a R1 description - we can continue to edit on etherpad (bryan_att, 15:56:48)
    7. ... first sentence sets the overview (bryan_att, 15:57:07)
    8. Frank: how relates to Chris' email (bryan_att, 15:57:22)
    9. Uli: took the email and comments, with the result being the current text on etherpad (bryan_att, 15:57:51)
    10. Chris: R1 is not addressed on wiki yet. Do we need a specific page for it, and other things related? (bryan_att, 15:58:30)
    11. Uli: we need that, for openness on what we want to achieve beyond TSC and OPNFV (bryan_att, 15:59:04)
    12. +1 (bryan_att, 15:59:08)
    13. +1 (rprakash, 15:59:26)
    14. Frank: public info can set things in stone - marketing team may want to edit the storyline (bryan_att, 15:59:54)
    15. ... barebones tech detail could be used by marketing to create the public storyline (bryan_att, 16:00:18)
    16. +1 (julien_ZTE, 16:00:19)
    17. +1 - it would be good to get marketing directly involved in public messsaging (bryan_att, 16:00:55)
    18. Frank: we can add components as tag lines as they get firmed up, and avoid the marketing type description (bryan_att, 16:01:44)
    19. Uli: we are not too early - 7 weeks left and we should know now what we want there (bryan_att, 16:02:05)
    20. Frank: just recommend tht we let marketing craft the "tagline" (descriptive text) (bryan_att, 16:02:33)
    21. Chris: this is worth starting to collect on the wiki (bryan_att, 16:03:03)
    22. Prathima: will create the marketing message given the basic input from the TSC (bryan_att, 16:03:43)
    23. Uli: should we get basic agreement on the existing descriptive content now (bryan_att, 16:04:41)
    24. Chris: defer that due to MWC focus - focus on our intent for the wiki (bryan_att, 16:05:08)
    25. AGREED: to begin to describe release one on the OPNFV wiki page, capturing the intended activities and objectives (ChrisPriceAB, 16:05:33)
    26. ACTION: ulik to begin to put this material on the wiki page (ChrisPriceAB, 16:06:00)

  9. Project plans & tracking (ChrisPriceAB, 16:06:25)
    1. https://wiki.opnfv.org/get_started/get_started_installer_approach (frankbrockners, 16:06:28)
    2. Frank indicates there are a number of deployment tools being worked on. Each has a status page showing current activity. (ChrisPriceAB, 16:07:30)
    3. Frank: on BGS, we have three (Fuel, Foreman, OpenSteak) efforts on basic installer - page linked has info on each (bryan_att, 16:07:42)
    4. Frank invites OPNFV members to look into the status pages and help where they are able to. (ChrisPriceAB, 16:07:54)
    5. ... opportunities to help in various places (bryan_att, 16:08:32)
    6. the team is starting to put the material into Jira for more public visibility (ChrisPriceAB, 16:08:46)
    7. ... 50% are certain April date is achieveable (bryan_att, 16:08:49)
    8. ... thus we need more hands on deck (bryan_att, 16:09:00)
    9. Frank asks for more engineers to engage where possible in order to hit the April deadline. (ChrisPriceAB, 16:09:25)
    10. ulik outlines the current activity in CI, they are currently focused on integrating with other projects for automated test (ChrisPriceAB, 16:09:53)
    11. Uli: for Octopus, hackfest showed Jenkins setup etc (bryan_att, 16:09:54)
    12. Bryan: would be great to get info on presentations and takeaways from the hackfest, on the wiki (bryan_att, 16:10:59)
    13. https://wiki.opnfv.org/events/meetupfeb19-2015 (ChrisPriceAB, 16:11:10)
    14. Palani: for FuncTest, jira project was created. Any TSC guidelines on creating user stories? (bryan_att, 16:11:58)
    15. pals outlines the functest activity. Jira is created and the team is looking to structure the epics/stories/activities for clarity. (ChrisPriceAB, 16:12:32)
    16. Frank: create a bunch of epics for various installer approaches for a high level grouping purpose (bryan_att, 16:12:33)
    17. ... individual cases underneath avoids flat high-level confusion (bryan_att, 16:13:09)
    18. Palani: have outlined 5 stories in basic FuncTest (bryan_att, 16:13:25)
    19. ... prototyping / development - two are working incl Morgan, started using devstack & tempest (bryan_att, 16:13:53)
    20. ... tech issues are being worked; I'm not duplicating that effort (bryan_att, 16:14:20)
    21. ... using devstack are started using tempest tests on OpenStack in a VM (bryan_att, 16:14:57)
    22. palani looking for volunteers to work on stories. (ChrisPriceAB, 16:15:14)
    23. ... would be great to assign stories to get community action (bryan_att, 16:15:27)
    24. Chris: just need to be people willing to do the work, not committers (bryan_att, 16:15:49)
    25. Palani: will create stories and send to the list (bryan_att, 16:16:02)
    26. Frank: Tim and Dan were successul/mostly on bringing up Foreman in Intel lab - should sync up with them on testing e.g. Robot once we have a stable environment. Running tempest in top eg. via CI should be possible (bryan_att, 16:17:35)

  10. Documentation (bryan_att, 16:17:49)
    1. Chris has documenation template (rprakash, 16:19:10)
    2. Chris: reach out if you want to help on thdocumentaiton (bryan_att, 16:19:41)
    3. https://wiki.opnfv.org/documentation_projects/opnfv_documentation (Gerald_K, 16:20:01)
    4. ulik Uli K is leaving im2bz2p__ (MIke Young) will stand in his place. (ChrisPriceAB, 16:22:09)

  11. OpenStack blueprint handling (ChrisPriceAB, 16:22:14)
    1. request in last week meeting to submit BPs, but there was no process defined yet how to handle this (Gerald_K, 16:22:58)
    2. proposed BPs should be as visible and aligned among multiple projects (Gerald_K, 16:23:49)
    3. Brian outlines the need to have a well formed set of ideas on how we will work toward openstack. (ChrisPriceAB, 16:24:14)
    4. Chris: proposal to have 30mins discussion prior to next TSC call (Gerald_K, 16:25:38)
    5. Bryan: can someone provide info on the deadline (bryan_att, 16:26:06)
    6. he asks for OPNFV to coordinate internally before discussing too much externally to reduce confusion (ChrisPriceAB, 16:26:15)
    7. http://www.openstack.org/blog/2015/02/sign-up-for-openstack-upstream-training-in-vancouver/ (ChrisPriceAB, 16:26:30)
    8. Dave will send mail with details on it (Gerald_K, 16:28:08)
    9. final call for BPs for L-release will be Vancouver meeting in May (Gerald_K, 16:29:21)
    10. reviewer resources is currently a bottleneck in OpenStack (Gerald_K, 16:30:18)
    11. we need reach out to people involved in OpenStack (Gerald_K, 16:31:19)
    12. Bryan: I take the result of this as that Requirements projects are not cadenced with OPNFV releases (bryan_att, 16:32:26)
    13. Gerald: we may need high-level description of the BPs in the Wiki, but shall use OpenStack terminology in the OpenStack Launchpad (Gerald_K, 16:34:19)
    14. https://wiki.opnfv.org/community (ChrisPriceAB, 16:34:24)
    15. Bryan: we will also meet on IRC to tune the doctor blueprints e.g. for alignment with copper (bryan_att, 16:34:26)
    16. DaveN will add the OpenStack release information, suggest we have similar for OpenDaylight, Open vSwitch, DPDK, Linaro, OpenContrail and other projects (bryan_att, 16:36:10)

  12. Project Approvals (ChrisPriceAB, 16:36:29)
    1. ... and a knowledge base about how decisions get made in upstream projects (bryan_att, 16:36:32)
    2. https://wiki.opnfv.org/requirements_projects/data_collection_of_failure_prediction (ChrisPriceAB, 16:36:57)
    3. ???/Huawei: goal is to avoid failures in advance (bryan_att, 16:37:11)
    4. ...(sharing screen) (bryan_att, 16:38:48)
    5. presenter is Linghui Zeng/Huawei (Gerald_K, 16:39:17)
    6. ... ETSI has defined general requirements for failure prediction (bryan_att, 16:39:51)
    7. ... most important is data collection and depends upon real-time data sources; second major component is a failure predictor (bryan_att, 16:41:38)
    8. ... goal of this project is to investigate functional gaps and identify data needing to be collected (bryan_att, 16:42:27)
    9. ... current gaps known are e.g. re state of guest OS (bryan_att, 16:43:10)
    10. architecture: predictor will provide input to Doctor module (Gerald_K, 16:43:21)
    11. data collection is done by Ceilometer, Zabbix, ... (Gerald_K, 16:43:48)
    12. ... predictor will send notifications to other handlers e.g. doctor module (bryan_att, 16:44:27)
    13. first goal is to focus on the data collector (Gerald_K, 16:44:52)
    14. Chris: scope is to find out data that shall be collected, but is not yet available (Gerald_K, 16:45:51)
    15. Bryan: is the scope limited to what is available thru OpenStack? (bryan_att, 16:47:24)
    16. the first release will not consider the interface to "FaultManagement" (Gerald_K, 16:48:46)
    17. Linghui: data collection is different to Doctor data collection (Gerald_K, 16:50:43)
    18. investigates on how to hook various open source monitors in Monasca (Gerald_K, 16:53:57)
    19. VOTE: Voted on "TSC to approve the creation of the collector (data collection for failure prediction) project?" Results are, +1: 9 (ChrisPriceAB, 16:57:09)
    20. ACTION: everyone cheer for bryan for taking notes (ChrisPriceAB, 16:58:30)


Meeting ended at 16:59:33 UTC (full logs).

Action items

  1. Ray & Chris to update the project page template and project key facts sections to reflect the naming needs across Jira/mail/repositories
  2. frankbrockers and hinds to work with aric to prototype autogenerating key project facts onto the wiki pages.
  3. hinds to propose a security project for documentation and activity
  4. chris to oraganise training sessions and record them for others to follow
  5. ulik to begin to put this material on the wiki page
  6. everyone cheer for bryan for taking notes


Action items, by person

  1. ulik
    1. ulik to begin to put this material on the wiki page
  2. UNASSIGNED
    1. Ray & Chris to update the project page template and project key facts sections to reflect the naming needs across Jira/mail/repositories
    2. frankbrockers and hinds to work with aric to prototype autogenerating key project facts onto the wiki pages.
    3. hinds to propose a security project for documentation and activity
    4. chris to oraganise training sessions and record them for others to follow
    5. everyone cheer for bryan for taking notes


People present (lines said)

  1. bryan_att (105)
  2. ChrisPriceAB (58)
  3. Gerald_K (38)
  4. collabot (16)
  5. dneary (7)
  6. rprakash (7)
  7. dlenrow (5)
  8. frankbrockners (4)
  9. fuqiao (3)
  10. aricg (2)
  11. Pranav_ (2)
  12. rpaik (2)
  13. tapio__ (2)
  14. julien_ZTE (2)
  15. ulik (2)
  16. AndreaP (1)
  17. joekidder (1)
  18. im2bz2p__ (1)
  19. pals (1)
  20. Parviz (1)
  21. dnaery (0)


Generated by MeetBot 0.1.4.