#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:02:23 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:02:34)
    1. Frank Brockners (frankbrockners, 14:02:37)
    2. Bryan Sullivan (bryan_att, 14:02:39)
    3. Chris Price (ChrisPriceAB, 14:02:40)
    4. Uli Kleber (ulik, 14:02:40)
    5. Ashiq Khan (Ashiq, 14:02:44)
    6. Dirk Kutscher (dku, 14:02:47)
    7. Heather Kirksey (HKirksey, 14:03:03)
    8. Pierre Lynch (plynch, 14:03:08)
    9. fuqiao (proxy for denghui) (fuqiao, 14:03:17)

  2. approval or previous minutes (ChrisPriceAB, 14:03:33)
    1. AGREED: minutes approved (ChrisPriceAB, 14:03:39)
    2. Tapio Tallgren (tapio__, 14:03:50)

  3. Agenda Bashing (ChrisPriceAB, 14:04:01)
    1. dlenrow (dlenrow, 14:05:13)
    2. Chris Wright (cdub, 14:05:20)
    3. Wenjing (Wenjing, 14:05:29)
    4. Parviz (Parviz, 14:05:40)
    5. Louis Fourie (LouisF, 14:05:45)

  4. Update from the board f2f (ChrisPriceAB, 14:05:45)
    1. Thinh Nguyenphu (Thinh_, 14:06:15)
    2. discussion on whether OPNFV should issue certificates; discussion moved to kind of trademark; need to come back to this discussion in April (Gerald_K, 14:12:26)
    3. add certification discussion to the TSC call close to Release 1 (rpaik, 14:13:05)

  5. Hack-fest planning and updates (ChrisPriceAB, 14:15:48)
    1. discussion to collocate with OpenStack summit. openstack would prefer not to have two hackfest at the same time. (Gerald_K, 14:17:04)
    2. ongoing dicussion on how to best engage with openstack community? (Gerald_K, 14:18:06)
    3. talk to Telco WG and OpenStack event team (Gerald_K, 14:19:02)
    4. working with OpenStack community to organize our participation at the Vancouver OpenStack summit (rpaik, 14:19:37)
    5. IMO we need OPNFV-centric events (bryan_att, 14:21:07)
    6. hackfest planned for OPNFV summit in Q4 2015. question whether additional hackfest middle of this year would be needed? (Gerald_K, 14:21:14)
    7. I agree that we want to integrate with the upstream communities, not park an OPNFV meeting in the middle of their events - so we need some events that are OPNFV-centric (bryan_att, 14:22:16)
    8. idea of "virtual hackfests" to avoid travelling (Gerald_K, 14:22:19)
    9. I also support virtual hackfests, but I think they are less successful as a community outreach method - but OK for existing projects to focus on quick progress (bryan_att, 14:24:17)
    10. AGREED: The TSC agrees to follow the existing schedule for summits and determine the need for an additional event later in the year. (ChrisPriceAB, 14:25:17)

  6. Follow up- Development tool training, Jira, Gerrit, Git, Jenkins (ChrisPriceAB, 14:25:50)
    1. looking for volunteers to organize those sessions (Gerald_K, 14:26:34)
    2. bryan asks if we have a quick guide to how we intend to use the tools (ChrisPriceAB, 14:27:24)
    3. No. Currently each project is using the tools in different ways. (Gerald_K, 14:28:12)
    4. Chris suggests that we might mandate project leads to get trained on the tools (bryan_att, 14:29:03)
    5. Eric has written a Wiki page on this (Gerald_K, 14:29:54)
    6. https://wiki.opnfv.org/developer (ChrisPriceAB, 14:30:07)
    7. contains information on how to work with the tools (ChrisPriceAB, 14:30:27)
    8. https://wiki.opnfv.org/developer (frankbrockners, 14:30:56)
    9. ACTION: Ray to look into LinuxFoundation training on the OPNFV toolchain (ChrisPriceAB, 14:31:30)
    10. https://wiki.opnfv.org/developer/contribution_guidelines - also has a reference to git commit styles. (frankbrockners, 14:32:24)
    11. Uli mention it may only be a problem of WHERE to find this information. (Gerald_K, 14:32:50)
    12. I don't see any specific conventions listed on that page - e.g. something even as simple as the git commit message - but there are also likely things that will come up as conventions in practice - we need to collect and publish them (bryan_att, 14:33:02)
    13. Fatih Degirmenci (fdegir, 14:33:08)
    14. Fatih offers to work on a training session regarding Jenkins and Jira (ChrisPriceAB, 14:34:05)
    15. Iben to help Fatih on OPNFV related information to clarify project needs. (ChrisPriceAB, 14:35:29)
    16. ACTION: Fatih, Iben and Aric will look to build training material for OPNFV (ChrisPriceAB, 14:37:09)
    17. +1 to putting the docs in git so that we can update them using the tools themselves (bryan_att, 14:37:27)
    18. Pranav (Pranav, 14:39:47)
    19. Key facts are served via iframe https://wiki.opnfv.org/get_started (aricg, 14:43:17)

  7. Update on OPNFV hardware @LF data center (ChrisPriceAB, 14:45:25)
    1. this is the new plugin for serving the keys facts: https://www.dokuwiki.org/plugin:scrape (aricg, 14:45:46)
    2. ray outlines that the hardware order has been delivered to the LF Data Center (ChrisPriceAB, 14:45:49)
    3. currently doing inventory of items prior to installation. (ChrisPriceAB, 14:46:05)
    4. Konstantin will provide a detailed update at the next TSC call. (ChrisPriceAB, 14:46:40)

  8. Update on the Release 1 naming (ChrisPriceAB, 14:48:09)
    1. Ray describes that we should reduce the list of names from the list to reduce the scanning isues and time for infringements. (ChrisPriceAB, 14:49:04)
    2. list was sent to legal counsel for review. recommendation to reduce number of names first to top 5, then they will execute the legal check (Gerald_K, 14:49:11)
    3. Ray will start a vote on the mailing list for the top choices (ChrisPriceAB, 14:49:57)
    4. the vote should be out today, it will close by Monday next week. (ChrisPriceAB, 14:50:35)
    5. this will reduce the list of the top 5 for a name search (ChrisPriceAB, 14:51:19)

  9. Discussion on awards programs for the OPNFV technical community (ChrisPriceAB, 14:54:10)
    1. awards program can be run once a year to top contributors (e.g. at the end of a release) (Gerald_K, 14:54:57)
    2. cdub indicates seperating into categories may be a good idea in OPNFV (ChrisPriceAB, 14:58:50)
    3. possible categories: documentation, collaboration, testing, integration (rpaik, 15:00:01)
    4. ACTION: ray to begin discussion on the lists about OPNFV recognition and awards. A concrete proposal is required for budget approvals. (ChrisPriceAB, 15:03:45)

  10. Project plans & tracking - for release 1 (ChrisPriceAB, 15:04:26)
    1. https://wiki.opnfv.org/get_started/get_started_installer_approach (frankbrockners, 15:04:51)
    2. frankbrockners provides an update on the BGS project. Each team is working on the backlog of development for the release 1 timeframe. (ChrisPriceAB, 15:05:33)
    3. the team is looking to establish commonality and converging on those areas. (ChrisPriceAB, 15:05:52)
    4. the team has begun moving to Jira for backlog management, not yet complete but the idea is to increase transaprency and visibility into the project. (ChrisPriceAB, 15:06:26)
    5. ACTION: frankbrockners and konstantin to establish communication channels regarding the hardware configuration for the linuxfoundation data-center. (ChrisPriceAB, 15:08:28)
    6. the plan is not to have manual instalation occuring on the linuxfoundation hardware. This should be deployed using the existing toolchain. (ChrisPriceAB, 15:09:48)
    7. https://jira.opnfv.org/browse/BGS-7?jql=project%20%3D%20BGS - Jira for BGS (frankbrockners, 15:10:08)
    8. octopus overview (ChrisPriceAB, 15:10:13)
    9. Uli indicates the project has begun working in Jira and that the working mode is now Jira based. (ChrisPriceAB, 15:10:36)
    10. octopus is awaiting build scripts to be made available from the projects (ChrisPriceAB, 15:11:03)
    11. the scripts are currently described on an etherpad outlining how they should be structured (ChrisPriceAB, 15:12:14)
    12. fdegir indicates there are some syntactical scripts being enabled on the CI pipeline (ChrisPriceAB, 15:12:58)
    13. Link to BGS build/deploy script blueprint/proposal https://etherpad.opnfv.org/p/BGS_CI (fdegir, 15:13:35)
    14. functiontest update (ChrisPriceAB, 15:13:36)
    15. palani and morgan have ben working with Tempest and Rally against a manually installed BGS environment (ChrisPriceAB, 15:14:10)
    16. the team is working with the tools currently and how to integrate that with CI (ChrisPriceAB, 15:14:44)
    17. fdegir explains that the toolchains required to be installed on the hardware should be made known to the linuxfoundation team as backlog items (ChrisPriceAB, 15:16:36)
    18. documentation for release 1 (ChrisPriceAB, 15:17:10)
    19. Trevor describes that clear demarcation between documentation activities will be important to set the scope for release 1 (ChrisPriceAB, 15:17:44)
    20. https://wiki.opnfv.org/documentation_projects/opnfv_documentation (ChrisPriceAB, 15:18:12)
    21. Iben explains that not all documentation should be captured in the documentation project but should be drawn out of project specific documentation areas (ChrisPriceAB, 15:20:05)
    22. TSC discussed to hire a technical writer to bootstrap the documentation (Gerald_K, 15:24:18)
    23. suggest to run a poll and give people time to consider the need for a writer (bryan_att, 15:25:10)

  11. Creation review for the Resource Scheduler project (ChrisPriceAB, 15:27:52)
    1. Presenter is Zhiqi Wang (rpaik, 15:28:36)
    2. https://wiki.opnfv.org/requirements_projects/resource_scheduler (Gerald_K, 15:29:24)
    3. quick comment is that Congress gets data from various sources not just Nova - and Copper focuses on policy engine features through and beyond Congress (bryan_att, 15:35:56)
    4. recommendation for close coordination with OPNFV project teaams like Copper & Promise (rpaik, 15:39:01)
    5. Discussion on if there is a need to add more details in the Planned Deliverables section (rpaik, 15:47:36)
    6. VOTE: Voted on "Do you approve create of the Resource Scheduler Projects?" Results are, +1: 9 (rpaik, 15:52:28)

  12. openstack community update (ChrisPriceAB, 15:53:16)
    1. https://wiki.opnfv.org/community/openstack (ChrisPriceAB, 15:53:58)
    2. FYI I added draft blueprint info for Copper to the page (bryan_att, 15:54:12)
    3. dneary outlines some of the challenges in engaging in openstack and our responsibilities when engaging with the commuinty (ChrisPriceAB, 15:54:26)
    4. the openstack community page on the OPNFV wiki is intended to be a common information repository for our openstack actiities (ChrisPriceAB, 15:54:55)
    5. dneary outlines the blueprint process for openstack, including the level if detail required including implemementation details and high level use cases associated with the feature (ChrisPriceAB, 15:55:36)
    6. dneary invites all project with active blueprints to list them on the wiki page so the community can collaborate on them (ChrisPriceAB, 15:56:31)
    7. the target is to be ready by May with OPNFV blueprints with the right level of detail and structure (ChrisPriceAB, 15:56:58)
    8. The first idea is to develop a comprehensive/reusable event-driven policy engine support across Openstack core components - the first step is to investigate current Openstack support for such event-driven operation. The second idea is to extend the data sources supported by Congress for specific OPNFV use cases. (bryan_att, 15:57:18)
    9. meetings may be planned for "blueprint best practices" in order to have consistency. (ChrisPriceAB, 15:59:19)


Meeting ended at 16:00:23 UTC (full logs).

Action items

  1. Ray to look into LinuxFoundation training on the OPNFV toolchain
  2. Fatih, Iben and Aric will look to build training material for OPNFV
  3. ray to begin discussion on the lists about OPNFV recognition and awards. A concrete proposal is required for budget approvals.
  4. frankbrockners and konstantin to establish communication channels regarding the hardware configuration for the linuxfoundation data-center.


Action items, by person

  1. frankbrockners
    1. frankbrockners and konstantin to establish communication channels regarding the hardware configuration for the linuxfoundation data-center.
  2. UNASSIGNED
    1. Ray to look into LinuxFoundation training on the OPNFV toolchain
    2. Fatih, Iben and Aric will look to build training material for OPNFV
    3. ray to begin discussion on the lists about OPNFV recognition and awards. A concrete proposal is required for budget approvals.


People present (lines said)

  1. ChrisPriceAB (68)
  2. Gerald_K (19)
  3. collabot (13)
  4. bryan_att (13)
  5. rpaik (10)
  6. dlenrow (9)
  7. aricg (9)
  8. frankbrockners (7)
  9. ulik (3)
  10. tapio__ (3)
  11. Pranav (2)
  12. fdegir (2)
  13. fuqiao (2)
  14. LouisF (2)
  15. cdub (2)
  16. dneary (1)
  17. plynch (1)
  18. Thinh_ (1)
  19. cgoncalves (1)
  20. Parviz (1)
  21. TNadeau (1)
  22. zhipeng_ (1)
  23. B_Smith_ (1)
  24. HKirksey (1)
  25. Wenjing (1)
  26. dku (1)
  27. Ashiq (1)


Generated by MeetBot 0.1.4.