#opnfv-meeting: Octopus Team meeting

Meeting started by ulik at 14:07:05 UTC (full logs).

Meeting summary

    1. yes we can start with Recap on test & Performance meeting (rprakash, 14:08:06)

  1. - Recap from Test&Performance meeting (ulik, 14:11:57)
    1. https://etherpad.opnfv.org/p/octopus (fdegir, 14:12:33)
    2. Look for How to Connect Servers from Labs to OPNFV Jenkins (fdegir, 14:12:47)
    3. Fatih explains that the current plan opens the LF lab so jenkins slaves can listen to the central master (ulik, 14:12:50)
    4. Short term solution -Labs opening firewall on Server using JNMP - its on opnfv site (any links?) (rprakash, 14:13:20)
    5. there may be some limitations with some permission issues (ulik, 14:13:22)
    6. The method explained in Etherpad is called JNLP (fdegir, 14:13:50)
    7. and a server from Ericsson lab is currently connected to OPNFV Jenkins (fdegir, 14:14:08)
    8. https://build.opnfv.org/ci/ (fdegir, 14:14:41)
    9. Fatih shows how Ericsson lab connects to LF jenkins (ulik, 14:15:28)
    10. This way, a lab has full control, e.g. disconnect for maintenance purpose (ulik, 14:16:54)
    11. Fatih encourages to test this by connecting any local jenkins slave. (ulik, 14:17:39)
    12. Intel lab is using this (ulik, 14:18:06)
    13. no action open on octopus side now. Test and Performance team needs to come back to us (ulik, 14:20:28)
    14. Question about labs talking to each other. Fatih doesn't expect this at the moment. (ulik, 14:21:15)
    15. Iben explains that for ODL, Spirent listens to the artifacts repository. (ulik, 14:21:54)
    16. Fatih thinks this might be good for later releases but not release 1. (ulik, 14:22:18)

  2. Define way to use hartdware (ulik, 14:25:14)
    1. Jerry explains which jobs would have hardware dependencies or which would better run in virtual environment (ulik, 14:26:58)
    2. Fatih explains we have the necessary information only from Fuel track. (ulik, 14:27:23)
    3. Jerry explains from experience using virtual machines for the builds and the way to use VLANs (ulik, 14:34:12)
    4. https://wiki.opnfv.org/get_started/foreman_quickstack_status (rprakash, 14:36:42)
    5. Tim Rozet reports from BGS how they use network during deploy (ulik, 14:37:15)
    6. is thre a topology digram for the configuration you expalined now? (rprakash, 14:40:15)
    7. one deploy server could serve multiple PODs (ulik, 14:41:50)
    8. see Topology section: https://wiki.opnfv.org/get_started_experiment1 (trozet, 14:42:14)
    9. there will be no issue when a lab uses same installer. The issue comes up, when using different installers in LF environment. (ulik, 14:43:28)
    10. Iben explains from experience at Spirent for this. (ulik, 14:45:21)
    11. Iben will share some documentation with the team. (ulik, 14:46:26)
    12. Iben sure we like to see that on opnfv site with links added for different labs (rprakash, 14:46:48)

  3. artifact repository (ulik, 14:48:27)
    1. Google Storage to be used for OPNFV Artifacts (rprakash, 14:49:43)
    2. https://wiki.opnfv.org/wiki/artifactrepos#what_will_be_used_as_artifact_repository_for_opnfv (fdegir, 14:50:13)
    3. aric explains the possibilities with Google store (ulik, 14:50:45)
    4. We will need to be able to pick the latest artifact from Google Storage (fdegir, 14:51:36)
    5. This will be made available while we move (fdegir, 14:51:55)
    6. Prakash asks why not use Swift on LF hardware and Aric explains that we don't have big hard drives (ulik, 14:52:33)
    7. Google Storage is blocked in China - this may require further thinking (fdegir, 14:53:11)
    8. Jerry explains that Google is not available from China (ulik, 14:53:20)
    9. Another shortage are missing backups (ulik, 14:53:41)
    10. Google shares between different locations, but there is no SLA. (ulik, 14:54:41)
    11. this could be sufficient, since build artifacts can be rebuilt if necessary. (ulik, 14:55:02)
    12. as long as we have full traceablity (fdegir, 14:55:17)
    13. http://storage.googleapis.com/opnfv-test/opnfv-P0000.iso (aricg, 14:56:23)
    14. http://storage.googleapis.com/opnfv-test/opnfv-P0000.iso (rprakash, 14:58:11)
    15. mirror this repo on each lab if acceptable to all (rprakash, 14:58:52)
    16. ACTION: Jerry, Iben, Fatih, to think about how to setup mirrors or other to solve this. (ulik, 14:59:29)


Meeting ended at 15:00:21 UTC (full logs).

Action items

  1. Jerry, Iben, Fatih, to think about how to setup mirrors or other to solve this.


Action items, by person

  1. iben
    1. Jerry, Iben, Fatih, to think about how to setup mirrors or other to solve this.


People present (lines said)

  1. ulik (33)
  2. fdegir (12)
  3. rprakash (8)
  4. collabot (5)
  5. alexpilotti (3)
  6. aricg (2)
  7. trozet (2)
  8. iben (1)
  9. dfarrell07 (1)
  10. jerryz (0)


Generated by MeetBot 0.1.4.