#opnfv-meeting: OPNFV RC0 Meeting - Release image readiness

Meeting started by ChrisPriceAB at 14:00:45 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:01:06)
    1. Frank Brockners (frankbrockners, 14:01:10)
    2. Chris Price (ChrisPriceAB, 14:01:12)
    3. Fatih Degirmenci (fdegir, 14:01:18)
    4. Aric Gardner (aricg, 14:01:27)
    5. Jerry Zhao (jerryz, 14:01:30)

  2. Agenda for the meeting (ChrisPriceAB, 14:05:25)
    1. RC execution reporting and issue logging – Fatih/Aric (ChrisPriceAB, 14:06:09)
    2. Project reports on RC completion and next RC readiness – Project Leads (ChrisPriceAB, 14:06:21)
    3. Actions and activities planned - All (ChrisPriceAB, 14:06:31)
    4. any other topics people would like to see on the meeting? (ChrisPriceAB, 14:06:45)

  3. RC execution reporting and issue logging – Fatih/Aric (ChrisPriceAB, 14:07:24)
    1. Fuel and Foreman images have successfully built and stored on OPNFV Artifact Repository (fdegir, 14:08:06)
    2. Links to Fuel ISO and build logs (fdegir, 14:08:25)
    3. http://artifacts.opnfv.org/genesis/fuel/opnfv-32.iso (fdegir, 14:08:36)
    4. https://build.opnfv.org/ci/job/genesis-fuel-daily-master/32/consoleFull (fdegir, 14:08:46)
    5. Links to Foreman ISO and build logs (fdegir, 14:08:55)
    6. http://artifacts.opnfv.org/genesis/foreman/opnfv-4.iso (fdegir, 14:09:02)
    7. https://build.opnfv.org/ci/view/genesis/job/genesis-foreman-daily-master/4/consoleFull (fdegir, 14:09:12)
    8. Fuel and Foreman Daily Jenkins jobs have also been enabled (fdegir, 14:09:31)
    9. they will build latest master every night and store latest images on OPNFV Artifact Repository (fdegir, 14:09:48)
    10. Any questions on the RC0 status? (ChrisPriceAB, 14:10:21)
    11. is ISO required for other installers to make it to R1? (jerryz, 14:10:59)
    12. could the link be posted with reqs for R1? (radez, 14:11:41)
    13. Arno RC schedule is here (frankbrockners, 14:12:05)
    14. https://wiki.opnfv.org/releases/arno/releasecandidates (frankbrockners, 14:12:07)
    15. jerryz: That is the expectation, it would be very hard to catch up when we have only 2 RC - deploy weeks (ChrisPriceAB, 14:12:51)
    16. Metadata for Fuel and Foreman are also stored on Artifact Repository (fdegir, 14:13:04)
    17. The SHA1s used for building ISOs are stored in metadata files (fdegir, 14:13:21)
    18. http://artifacts.opnfv.org/genesis/fuel/opnfv-32.properties (fdegir, 14:13:29)
    19. http://artifacts.opnfv.org/genesis/foreman/opnfv-4.properties (fdegir, 14:13:37)
    20. thanks fdegir, any other questions/comments or I will move on (ChrisPriceAB, 14:14:03)
    21. ChrisPriceAB: we can get deploy.sh to work but build.sh still need some work for Compass (jerryz, 14:14:20)
    22. yes we will do R1 planning and actions as the last point (ChrisPriceAB, 14:15:12)

  4. Project reports on RC completion and next RC readiness – Project Leads (ChrisPriceAB, 14:15:18)
    1. frankbrockners can you report on BGS? RC0 and moving to RC1 readiness (ChrisPriceAB, 14:15:45)
    2. Sent out a request for status to the alias yesterday. Got details for Foreman and Fuel deployment approaches. (frankbrockners, 14:16:33)
    3. Details are summarized on the BGS wiki as part of the release plan (frankbrockners, 14:16:54)
    4. https://wiki.opnfv.org/get_started/get_started_release_plan (frankbrockners, 14:17:08)
    5. For RC0: Successful built for Foreman and Fuel deployment approaches (frankbrockners, 14:17:43)
    6. For RC0: Common puppet manifests mostly in place - some patches still in gerrit. See wiki for details. (frankbrockners, 14:18:40)
    7. Q: So equivalent of code freeze achieved, with bug-fixes pending? (ChrisPriceAB, 14:19:13)
    8. R1 readiness: Teams active on deploy scripts. (frankbrockners, 14:19:15)
    9. R1 will also depend on LF infra fully available. (frankbrockners, 14:19:34)
    10. "bug fixes" pending is appropriate (frankbrockners, 14:20:03)
    11. One clarification would be good to have here: (frankbrockners, 14:20:27)
    12. R1 question. Can we get a description on the wiki of what "deploy.sh" is supposed to do exactly. Just want to have the right expectations clear for everyone. (trozet, 14:20:48)
    13. Teams are working on the assumption that "deploy.sh" will *not* include any testing. I.e. testing is run *post* installation and is independent from deploy (frankbrockners, 14:21:06)
    14. Is this everyone's understanding? (frankbrockners, 14:21:24)
    15. erm: Yes. Deploy should install the SW, validation shall occur post install as a standard functest suite. (ChrisPriceAB, 14:21:43)
    16. but testing may need some input from deploy.sh, url, username, password,etc (jerryz, 14:22:06)
    17. Robot and Tempest would be installed independently from any install/deploy approach (frankbrockners, 14:22:20)
    18. as part of post install processes (rprakash, 14:22:44)
    19. Q: As part of RC1 readiness have we identified consistent user names and passwords to be used? (ChrisPriceAB, 14:23:32)
    20. how about self-contained virtualized deployment test (jerryz, 14:24:02)
    21. foreman has tempest fired off as part of deploy but it can be separated without trouble (radez, 14:24:35)
    22. ChrisPriceAB: no I don't think we have standards user/pass. We have been using octopus/octopus for all OpenStack user/pass and "Op3nStack" for linux root login (trozet, 14:24:43)
    23. ACTION: BGS team to resolve consistent user names for RC1. (ChrisPriceAB, 14:25:10)
    24. user names goes beyond BGS... - given that you have to reconfigure the switches every time you switch installers (frankbrockners, 14:25:52)
    25. ChrisPriceAB: still have a question about deploy.sh (trozet, 14:25:59)
    26. so an AI for pharos (frankbrockners, 14:26:04)
    27. ACTION: Pharos team to provide consistent usernames for infrastucture. (ChrisPriceAB, 14:26:20)
    28. HW readiness Wiring started yesterday, should be completed today. (aricg, 14:26:21)
    29. so deploy.sh will not require to boot the iso created by build.sh? or deploy the install server? (trozet, 14:26:34)
    30. my understanding is that deploy.sh will need to deploy the jumphost/install server (frankbrockners, 14:27:17)
    31. trozet & bgs team please clarify deploy sequence details in the BGS project. (ChrisPriceAB, 14:27:29)
    32. though it does not need to work off the ISO (frankbrockners, 14:27:31)
    33. so build.sh iso needs to deploy.sh but not vise versa? (radez, 14:28:11)
    34. for OPNFV purposes I would vote to use a VM and not rebuild baremetal install server with an ISO, for speed and reliability (trozet, 14:28:15)
    35. CI readiness report. RC0 and moving to RC1 readiness. (ChrisPriceAB, 14:28:25)
    36. CI jobs that verify changes that are done in genesis/common, genesis/fuel, and genesis/foreman are now activated (fdegir, 14:29:24)
    37. go ahead Jerry (rprakash, 14:29:38)
    38. any change in genesis repo that is still pending for review needs to rebase to master (fdegir, 14:29:56)
    39. in order to get them tested with fuel and foreman verify jobs (fdegir, 14:30:15)
    40. CI jobs created and triggered periodically for build.sh (jerryz, 14:30:17)
    41. artifacts uploaded to google storage after each build (jerryz, 14:30:49)
    42. Q: are the on commit and on merge jobs in place as well? (ChrisPriceAB, 14:32:07)
    43. Jobs run for each commit are in place (fdegir, 14:32:40)
    44. gerrit trigger in job template (jerryz, 14:32:58)
    45. any commit that touches genesis/common, genesis/fuel, and genesis/foreman will trigger verify job (fdegir, 14:33:09)
    46. Q: artifacts uploaded at each build or nightly? (ChrisPriceAB, 14:33:27)
    47. artifacts are uploaded nightly (fdegir, 14:33:38)
    48. no artifact is uploaded from verify and merge jobs (fdegir, 14:33:47)
    49. work is still in progress for merge jobs (fdegir, 14:34:02)
    50. RC1 readiness report, pending actions on Deploy & Test? (ChrisPriceAB, 14:34:22)
    51. for CI (ChrisPriceAB, 14:34:36)
    52. depending on how to test deploy, with what resource? (jerryz, 14:34:55)
    53. We are waiting for BGS and FuncTest to provide mechanisms to deploy and test (fdegir, 14:35:19)
    54. : deploy job template is there, no resource for deploy jobs yet (jerryz, 14:35:22)
    55. We currently download ISOs from Google Storage in deploy phase as "dummy" jobs (fdegir, 14:35:47)
    56. it will be replaced with real deployment once it is ready (fdegir, 14:36:04)
    57. Q: so pending actions on functest and bgs to complete scripts in Jira? (ChrisPriceAB, 14:36:11)
    58. correct (fdegir, 14:36:17)
    59. slaves for deploy need to be in plae (jerryz, 14:36:36)
    60. s/plae/place (jerryz, 14:36:48)
    61. LF hardware is the prerequisite for RC1 (fdegir, 14:36:56)
    62. as we lack build and deploy resources at the moment (fdegir, 14:37:14)
    63. OK, more question on CI? otherwise I will move to Pharos (ChrisPriceAB, 14:37:20)
    64. Pharos (LinuxFoundation infra) RC1 readiness report? (ChrisPriceAB, 14:37:51)
    65. artur did you create mass juju fillers for rc0 in genesis (rprakash, 14:38:00)
    66. Wiring started yesterday, some hangups, should complete today (aricg, 14:38:29)
    67. ok done for ci on juju track (rprakash, 14:38:51)
    68. Q: will we provide scripts for deploy tools for switch config etc? (maybe a better q for trevor_intel) (ChrisPriceAB, 14:39:29)
    69. rprakash yes (arturt, 14:39:39)
    70. ChrisPriceAB I dont think that is necessary. We have an agreed upon VLAN layout for the target system that should work with any installer (trozet, 14:40:07)
    71. ok, thanks trozet (ChrisPriceAB, 14:40:24)
    72. I have a different understanding (frankbrockners, 14:40:35)
    73. depending on installer hosts send packets either VLAN tagged or not (frankbrockners, 14:40:54)
    74. based on this, switch config would differ (either switch applies VLAN tag or not) (frankbrockners, 14:41:13)
    75. no reason to use tagging unless we don't have enough ports per server. We agreed on this in the meeting yesterday. (trozet, 14:41:20)
    76. requires clarification from teams (frankbrockners, 14:41:23)
    77. action: bgs team to clarify if any abstraction is required from the Pharos project for deploy and add Jira jobs where neccessary. (ChrisPriceAB, 14:41:44)
    78. functest RC1 readiness report. (ChrisPriceAB, 14:42:29)
    79. is new project lead assigned for func test? (rprakash, 14:43:40)
    80. the new commiters now have access. https://git.opnfv.org/cgit/functest/tree/INFO (aricg, 14:44:22)
    81. currently the acting is trevor_intel, nominations have started (ChrisPriceAB, 14:44:33)
    82. unable to secure functest reporting for RC1 readiness. (ChrisPriceAB, 14:45:04)
    83. ACTION: ChrisPriceAB to secure functest updates and preparation for RC1 is on track (ChrisPriceAB, 14:45:42)
    84. RC1 readiness for opnfvdocs (ChrisPriceAB, 14:45:46)
    85. opnfvdocs repo was created yesterday, tooling is being prepared and we expect to get foundation templates in place over the weekend. (ChrisPriceAB, 14:46:18)
    86. risk that we will not be ready for RC1, although I hope to have a clear structure and all Jira actions in place with templates by that time. (ChrisPriceAB, 14:46:45)
    87. opnfvdocs team will help project teams complete the documentation in the templates in order to arrive at Release 1 (ChrisPriceAB, 14:47:33)
    88. expected documents include: (ChrisPriceAB, 14:47:40)
    89. - Release documentation (ChrisPriceAB, 14:47:50)
    90. is all documentation work being scheduled through Jira? (rprakash, 14:47:51)
    91. Installation docuemtation (ChrisPriceAB, 14:48:05)
    92. - User guides, leveraging references to upstream documentation (ChrisPriceAB, 14:48:22)
    93. - Test coverage documentation (ChrisPriceAB, 14:48:32)
    94. the release documentation will derive from project source document files in order to enable the documents to be maintained with the projects. (ChrisPriceAB, 14:49:39)
    95. opnfv docs while produceing release specific content will not replicate project specific infrmation (ChrisPriceAB, 14:49:59)
    96. Ask: Can we agree on an RC1 milestone for docs? (frankbrockners, 14:50:24)
    97. any questions on the opnfvdoc progress. (the little there is) (ChrisPriceAB, 14:50:28)
    98. We can, due to easter being in the middle I am not confident on what to set as a goal. (ChrisPriceAB, 14:50:56)
    99. How about "draft doc templates available to projects" (frankbrockners, 14:51:19)
    100. tooling, templates and Jira actions might be a good start (ChrisPriceAB, 14:51:25)
    101. ACTION: opnfvdocs project to ensure templates are available for all Release 1 projects by RC1, with associated structure and documentation 'guidelines' (ChrisPriceAB, 14:53:05)

  5. Actions and activities planned (ChrisPriceAB, 14:54:41)
    1. there will be an overall OPNFV doc describing the target deployment, functest, CI pipeline, and separate docs for the specific installers and projects (dneary, 14:54:46)
    2. pending actions, let's capture needed steps leading to RC1. (ChrisPriceAB, 14:54:57)
    3. LF hardware should be available by the end of this week. CI needs to move targets to the LF lab and begin building/deploy testing there. (ChrisPriceAB, 14:56:18)
    4. for BGS/JuJu we gat POD5 next week so thats the wait for hold up you asked (rprakash, 14:56:46)
    5. functest needs to migrate all work into the repository so it can begin to be tested against target automatically. (ChrisPriceAB, 14:56:58)
    6. and functest infra (tempest, robot) needs to be avail on LF HW by RC1 (frankbrockners, 14:57:59)


Meeting ended at 14:59:22 UTC (full logs).

Action items

  1. BGS team to resolve consistent user names for RC1.
  2. Pharos team to provide consistent usernames for infrastucture.
  3. ChrisPriceAB to secure functest updates and preparation for RC1 is on track
  4. opnfvdocs project to ensure templates are available for all Release 1 projects by RC1, with associated structure and documentation 'guidelines'


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to secure functest updates and preparation for RC1 is on track
  2. UNASSIGNED
    1. BGS team to resolve consistent user names for RC1.
    2. Pharos team to provide consistent usernames for infrastucture.
    3. opnfvdocs project to ensure templates are available for all Release 1 projects by RC1, with associated structure and documentation 'guidelines'


People present (lines said)

  1. ChrisPriceAB (97)
  2. frankbrockners (46)
  3. fdegir (33)
  4. dneary (22)
  5. jerryz (14)
  6. trozet (13)
  7. rprakash (11)
  8. radez (6)
  9. aricg (5)
  10. collabot (5)
  11. bryan_att (3)
  12. trevor_intel (1)
  13. arturt (1)


Generated by MeetBot 0.1.4.