#opnfv-meeting: BGS weekly meeting

Meeting started by frankbrockners at 14:59:09 UTC (full logs).

Meeting summary

    1. Draft agenda: https://wiki.opnfv.org/meetings/bgs#april132015 (frankbrockners, 14:59:41)

  1. roll call (frankbrockners, 14:59:58)
    1. pbandzi (pbandzi, 15:00:35)
    2. Frank Brockners (frankbrockners, 15:00:45)
    3. dradez (radez, 15:00:50)
    4. Malla (Malla, 15:01:14)
    5. dneary (dneary, 15:01:30)
    6. dfarrell07 (dfarrell07, 15:01:43)
    7. hkirksey (HKirksey, 15:01:56)
    8. Jonas Bjurel ([1]JonasB, 15:02:33)
    9. fdegir (fdegir, 15:03:08)

  2. agenda bashing (frankbrockners, 15:03:42)
    1. Chris Price (ChrisPriceAB, 15:03:45)
    2. https://wiki.opnfv.org/meetings/bgs#april132015 (frankbrockners, 15:03:49)
    3. Mike Dolan (mdolan, 15:03:52)
    4. any updates on the draft agenda? (frankbrockners, 15:03:58)

  3. Code scanning requirements for OPNFV (Mike, Heather) (frankbrockners, 15:05:01)
    1. We are looking for the full details of the packages that are being pulled in by the scripts to understand the licensing involved (mdolan, 15:06:20)
    2. Frank referred me this morning to Jonas Bjurel and Daniel Smith for Fuel and Tim Rozet and Daniel Radez for Foreman (mdolan, 15:07:16)
    3. so I guess we'll go down that path, but we really just need to know beyond the code in the OPNFV git repos, what other 3rd party codebases are being pulled in by any script (mdolan, 15:08:11)
    4. rprakash (rprakash, 15:08:46)
    5. Does that include code being pulled into code that we are pulling? (ChrisPriceAB, 15:08:47)
    6. radez: yes, probably best to connect 1x1 I guess, just wanted to make everyone aware that we need to document what these other packages are, where they come from and the licensing. It would probably be good to setup a process to capture it at code time, but for the first release we're likely going to have to do it a bit manually looking at what was done already. (mdolan, 15:09:39)
    7. ack, we'll be in touch (radez, 15:10:01)
    8. lets get in touch for the fuel repos ([1]JonasB, 15:10:56)
    9. "based on CentOS 7.1-1046" is a bit broad, but it depends on the use case - there are a lot of packages in "CentOS" (mdolan, 15:11:10)
    10. Believe that should be done as part of code review by respective team (rprakash, 15:12:04)
    11. How many upstream projects are being pulled in? I also noticed the artifacts.opnfv.org and it appears there are binaries, we need to ensure the corresponding sources used to build those are available (mdolan, 15:12:07)
    12. that was all I had - just wanted to get the right contacts and make sure everyone is aware of this requirement (mdolan, 15:13:28)
    13. frankbrockers thanks for your pointers to the right contacts this morning (mdolan, 15:13:54)
    14. automatic detection of licenses is not practical and hence code review is the better way and each track like Fuel, Foreman setup their own code erveiw teams and licensing being one as[pect to revieqw (rprakash, 15:14:12)
    15. dneary yes, better (mdolan, 15:14:29)
    16. component/artifact details info to be supplied to Mike Dolan by end of this week (frankbrockners, 15:14:37)
    17. dneary, ideally with a link to the source for that as well (mdolan, 15:14:45)
    18. dneary I think the answer is that depends, are we distributing the binaries from OPNFV? What license is the binary under? (e.g. GPL probably has a different answer than Apache binary) (mdolan, 15:16:25)
    19. trying to keep this as light weight as possible; we can do some cleanup after the release, but we also can't violate the licensing requirements from the upstream projects (mdolan, 15:17:58)

  4. BGS status and workplan review (frankbrockners, 15:18:10)
    1. LF HW is available by now (frankbrockners, 15:18:51)
    2. Are we fully wired up and functional? (ChrisPriceAB, 15:19:29)
    3. One ask by the RC1 review meeting was that we agree on common usernames for use by CI. Do we have a suggestion here? (frankbrockners, 15:19:37)
    4. For Octopus to use the LF HW, we need to connect needed servers to OPNFV Jenkins (fdegir, 15:23:08)
    5. https://wiki.opnfv.org/wiki/jenkins#jenkins_slaves (rprakash, 15:27:20)
    6. https://build.opnfv.org/ci/computer/ (rprakash, 15:28:12)
    7. Foreman uses "Op3nStack" as root password for machines. Uses "octopus" for user,pass, and tokens for openstack services (trozet, 15:29:44)
    8. Only thing I can think is to simplify them a little. and maybe make them OPNFV specific rather than based on a component name. (ChrisPriceAB, 15:31:16)
    9. root password has to be 8 characters thats why it is not octopus :) (trozet, 15:32:07)
    10. well at least 8 chars. :) (ChrisPriceAB, 15:33:00)
    11. every entry to CI must have an ID and thus octopus+ID like octopus10 for Fuel, octopus20 for Foreman .. will be better (rprakash, 15:37:12)
    12. opnfv/openplatformfornetworkfunctionvirtualization as username / password (frankbrockners, 15:37:33)
    13. agreement is difficlut let each track decide what they think is their way and document it (rprakash, 15:39:30)
    14. AGREED: opnfv/opnfvstack as username/password (frankbrockners, 15:39:41)
    15. Foreman is going to commit deploy.sh after this meeting (trozet, 15:41:10)
    16. ready to test on LF hardware (trozet, 15:41:24)
    17. We're working on something autodeployable for this Thu, no gold edges but a start. ([1]JonasB, 15:41:58)
    18. will try to get deploy.sh working on Intel POD1 then connect to jenkins (trozet, 15:45:11)
    19. https://build.opnfv.org/ci/computer/intel-build/ (fdegir, 15:47:56)
    20. This week will do nested deployment and get that working flawlessly. From there it should be a straight forward task to write the python HW adaptor for LF. ([1]JonasB, 15:53:06)
    21. LF or not depends on the availability. ([1]JonasB, 15:53:35)

  5. additional status updates - docs and testing (frankbrockners, 15:54:24)
    1. Any updates on docs for BGS? (frankbrockners, 15:54:44)
    2. Victor submitted a "template": https://gerrit.opnfv.org/gerrit/#/c/268/ (frankbrockners, 15:55:06)
    3. which is our main project page in .rst format (frankbrockners, 15:55:37)
    4. what are the plans to have userdocs for the different deployment approaches? (frankbrockners, 15:55:58)
    5. I will focus on docs this week, I will probably propose templates for relesenotes and indstallation and userguide. ([1]JonasB, 15:57:31)
    6. Jonas will supply templates for releasenotes, user- and installationguide (frankbrockners, 16:02:28)


Meeting ended at 16:03:50 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. frankbrockners (66)
  2. trozet (26)
  3. mdolan (17)
  4. ChrisPriceAB (16)
  5. [1]JonasB (12)
  6. rprakash (10)
  7. dneary (8)
  8. fdegir (8)
  9. SzilardCserey_ER (6)
  10. radez (6)
  11. dfarrell07 (5)
  12. collabot (4)
  13. Malla (3)
  14. iben_ (2)
  15. HKirksey (2)
  16. pbandzi (1)
  17. narindergupta (1)


Generated by MeetBot 0.1.4.