#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:44 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 13:59:50)
    1. Chris Price (ChrisPriceAB, 13:59:58)
    2. Tapio Tallgren (Tapio_ta, 14:00:12)
    3. Wenjing Chu (Wenjing, 14:00:13)
    4. Morgan Richomme (morgan_orange, 14:00:38)
    5. Uli Kleber (uli-k, 14:01:27)
    6. Chris Wright (cdub, 14:01:47)
    7. Dirk Kutscher (dku, 14:01:55)
    8. rprakash (rprakash, 14:02:41)
    9. Bryan Sullivan (bryan_att, 14:02:51)

  2. Approval of previous minutes (ChrisPriceAB, 14:03:15)
    1. Frank Brockners (frankbrockners, 14:03:35)
    2. AGREED: TSC approves the previous minutes (ChrisPriceAB, 14:03:50)

  3. Agenda Bashing (ChrisPriceAB, 14:03:55)
    1. https://wiki.opnfv.org/wiki/tsc (ChrisPriceAB, 14:04:07)
    2. Larry Lamers (VMware) (ljlamers, 14:05:13)
    3. dlenrow (dlenrow, 14:05:21)
    4. Ildiko Vancsa (ildikov, 14:05:46)
    5. Hui (hui, 14:06:23)

  4. Introducing Debra Scott (OPNFV Release Manager) (ChrisPriceAB, 14:06:55)
    1. Debra will work with our community to establish our release processes and shepherd our projects through future OPNFV releases. (ChrisPriceAB, 14:08:15)

  5. Arno Project plans & tracking (ChrisPriceAB, 14:09:02)
    1. discuss ongoing release activities. (ChrisPriceAB, 14:09:21)
    2. Chris reports that release documentation needs to be finalized tonight/tomorrow morning (rpaik, 14:12:03)
    3. https://wiki.opnfv.org/meetings/bgs#june12015 (frankbrockners, 14:15:28)
    4. BGS status update (ChrisPriceAB, 14:15:41)
    5. Rajeev Koodli (rajeev, 14:15:50)
    6. three remaining issues in the BGS project which we hope to complete prior to release. (ChrisPriceAB, 14:21:27)
    7. functest update (ChrisPriceAB, 14:21:33)
    8. morgan outlines that there have been discrepancies in executing testing when altering the platform. (ChrisPriceAB, 14:22:12)
    9. morgan describes that all issues are known and able to be defined and documented in the release. (ChrisPriceAB, 14:22:35)
    10. Issues in upstream community bugs result in limitations in our platform that are not able to be solved prior to the release. (ChrisPriceAB, 14:23:18)
    11. documentation updates are required prior to release, stability remains an issue but is not able to be solved with the current release components. (ChrisPriceAB, 14:25:26)
    12. every-one is exhausted :-) (understandably) (ChrisPriceAB, 14:25:49)
    13. morgan_orange reports that there will be documentation on tests that are failing (rpaik, 14:34:23)
    14. CI update (ChrisPriceAB, 14:35:04)
    15. octopus has prepared a release procedure to be reviewed (ChrisPriceAB, 14:35:39)

  6. Release process, labeling and artifact cutting (ChrisPriceAB, 14:35:46)
    1. https://wiki.opnfv.org/octopus/releasepipeline (uli-k, 14:36:03)
    2. https://wiki.opnfv.org/octopus/releasepipeline release process (ChrisPriceAB, 14:36:03)
    3. Uli walks through the process described on the above link (ChrisPriceAB, 14:37:38)
    4. Julien (julien_ZTE, 14:40:08)
    5. Want to go through steps outlined by Uli on Wedesday (June 3rd) in preparation for the release on Thursday (rpaik, 14:44:31)
    6. propose that we identify a cut off time/date so that the prep for the release has time to execute (RayNugent, 14:48:18)
    7. Uli asks the TSC for a decision on the release tag format. (ChrisPriceAB, 14:48:46)
    8. cdub agree that a format is needed and should work well with updates. (ChrisPriceAB, 14:49:06)
    9. Proposed formats are (fdegir, 14:49:12)
    10. using Openstack alike named tag (julien_ZTE, 14:49:19)
    11. release/arno (ODL way) (fdegir, 14:49:20)
    12. 2015.1.0 (fdegir, 14:49:25)
    13. Arno.2015.1.0 (fdegir, 14:49:32)
    14. arno_1.0.0 (fdegir, 14:49:39)
    15. AGREED: TSC agrees to use arno.2015.1.0 as our release tag (ChrisPriceAB, 14:51:02)
    16. arno_2515.1.0? (julien_ZTE, 14:51:31)
    17. looks ok to me. (tnadeau, 14:51:36)
    18. AGREED: TSC agrees to use stable/arno as our stable branch (ChrisPriceAB, 14:51:36)
    19. frankbrockners asks for the artifact storage to include /scripts and /images (ChrisPriceAB, 14:55:18)
    20. source code tag link, image or iso and documents will be released? (julien_ZTE, 14:59:52)

  7. Arno landing page review (ChrisPriceAB, 15:03:20)
    1. Ray demonstrates the Arno download landing page (ChrisPriceAB, 15:03:56)
    2. https://wiki.opnfv.org/documentation/Arno current release documents (ChrisPriceAB, 15:06:21)

  8. Arno support (ChrisPriceAB, 15:15:08)
    1. a support mailing address exists support@opnfv.org (ChrisPriceAB, 15:16:26)
    2. this can be set with a mailing list that is open for anyone to post to that we can use for OPNFV support (ChrisPriceAB, 15:17:27)
    3. consensus would indicate a mailing list alias called opnfv-user would seem to be the best approach (ChrisPriceAB, 15:18:30)
    4. ACTION: create a mailing list called “opnfv-user” (rpaik, 15:18:36)
    5. support offered for OPNFV is community support, with no sla's associated. (ChrisPriceAB, 15:18:56)
    6. use Jira to report bugs (rpaik, 15:21:12)
    7. establishing an ask-bot to the users mailing list could be a valuable addition in the future. (ChrisPriceAB, 15:25:14)

  9. WiKi structure & Layout (ChrisPriceAB, 15:25:33)
    1. dneary raises the point that a community manager for OPNFV would be able to handle many of these issues (ChrisPriceAB, 15:28:49)
    2. I agree with dneary, community management is a full time job and we'll need a dedicated person to do the job (RayNugent, 15:30:01)

  10. Development process/project categories (ChrisPriceAB, 15:30:13)
    1. cdub thinks the process may need review, preferably done after the release. (ChrisPriceAB, 15:32:34)
    2. dlenrow indicates some additional work could improve the way the projects integrate with the overall OPNFV project (ChrisPriceAB, 15:34:13)
    3. AGREED: to postpone the discussion until after Arno is released (ChrisPriceAB, 15:34:43)

  11. OPNFV Release 2 "marquee feature" discussion (ChrisPriceAB, 15:35:45)
    1. Ray indicates some concern that focusing on a feature a thematic approach may be better. (ChrisPriceAB, 15:37:48)
    2. of the topics under discussion dneary describes SFC as a theme due to it's functional breadth (ChrisPriceAB, 15:39:02)
    3. uli-k states that the value of OPNFV can be easily identified when considering a feature set that combines a number of upstream components (ChrisPriceAB, 15:40:59)
    4. Rajeev indicates that a clear definition of what we are trying to achieve with the marquee feature is required (ChrisPriceAB, 15:42:20)
    5. from the link https://www.opnfv.org/about, carrier-grade is OPNFV's one of targets "OPNFV will establish a carrier-grade, integrated, open source reference platform that industry peers will build together to advance the evolution of NFV and to ensure consistency, performance and interoperability among multiple open source components" (julien_ZTE, 15:50:39)
    6. rpaik please add carrier grade as a suggestion (RayNugent, 15:53:34)
    7. discussion that SFC and Faulat mgmt/HA maybe achievable in 6 months. Will need more time for Policy (rpaik, 15:53:40)

  12. Release 2 planning (ChrisPriceAB, 15:53:47)
    1. SFC+HA=carrier grade phase 1 (RayNugent, 15:54:19)
    2. https://wiki.opnfv.org/simultaneous_release_process_and_guidelines wiki page for simultaneous release process (rpaik, 15:56:09)
    3. can we output a schedule like openstack, https://wiki.openstack.org/wiki/Liberty_Release_Schedule (julien_ZTE, 15:57:11)
    4. ACTION: Debra to initiate the development of the release plan for release 2 (ChrisPriceAB, 15:57:25)
    5. dlenrow and uli-k to head up the community team (ChrisPriceAB, 15:57:45)
    6. julian_ZTE agree with schedule proposal (RayNugent, 15:58:07)

  13. AOB (ChrisPriceAB, 15:58:11)


Meeting ended at 15:58:31 UTC (full logs).

Action items

  1. create a mailing list called “opnfv-user”
  2. Debra to initiate the development of the release plan for release 2


People present (lines said)

  1. ChrisPriceAB (64)
  2. dneary (33)
  3. bryan_att (12)
  4. RayNugent (12)
  5. tnadeau (11)
  6. rpaik (11)
  7. fdegir (10)
  8. dlenrow (8)
  9. collabot (7)
  10. julien_ZTE (7)
  11. uli-k (7)
  12. cdub (5)
  13. morgan_orange (3)
  14. dku (3)
  15. tapio__ (3)
  16. frankbrockners (2)
  17. Tapio_ta (1)
  18. ildikov (1)
  19. cgoncalves (1)
  20. rajeev (1)
  21. hui (1)
  22. ljlamers (1)
  23. HKirksey (1)
  24. Wenjing (1)
  25. rprakash (1)


Generated by MeetBot 0.1.4.