#opnfv-meeting: Octopus Weekly Meeting

Meeting started by fdegir at 14:03:16 UTC (full logs).

Meeting summary

    1. Dave Neary (dneary, 14:03:21)

  1. roll call (fdegir, 14:03:44)
    1. Fatih Degirmenci (fdegir, 14:04:08)
    2. meimei (meimei, 14:04:15)
    3. Tim Rozet (trozet, 14:04:24)

  2. Agenda Bashing (fdegir, 14:04:59)
    1. action item review / lab compliancy / E2E CI / Jira Issues / B-Release CI work (fdegir, 14:05:46)

  3. Action Item Review (fdegir, 14:06:11)
    1. First action item is on uli-k and trozet (fdegir, 14:06:56)
    2. uli-k and trozet to bring to the TSC whether Brahmaputra should be released using LF lab or differently. (fdegir, 14:07:02)
    3. we asked last TSC meeting, ChrisPriceAB said he would have to find out (trozet, 14:07:33)
    4. ACTION: uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab (fdegir, 14:08:52)
    5. chigang to try on a POD to apply new naming scheme to a slave. (fdegir, 14:09:19)
    6. ACTION: chigang to try on a POD to apply new naming scheme to a slave. (fdegir, 14:11:45)
    7. slave name change requires coordination since it requires a new secret (fdegir, 14:13:26)
    8. slave naming scheme work is still going on (fdegir, 14:13:43)
    9. ACTION: uli-k to contact silent committers and encourage them to start working. (fdegir, 14:15:27)

  4. lab compliancy (fdegir, 14:16:00)
    1. meimei put some input to etherpad regarding this (fdegir, 14:16:24)
    2. https://etherpad.opnfv.org/p/octopusR2 (fdegir, 14:16:28)
    3. Under the heading Octopus requirements on lab compliance (fdegir, 14:16:45)
    4. thx meimei for starting it up (fdegir, 14:17:40)
    5. once it is settled, it will be provided to pharos and the OPNFV community as input (fdegir, 14:18:28)

  5. E2E CI (fdegir, 14:19:26)
    1. We've been having some discussions within Octopus team regarding E2E CI (fdegir, 14:19:41)
    2. due to lack of resources, current E2E CI is quite limited; done by timer /daily and limited in scope (fdegir, 14:20:31)
    3. as meimei points out on etherpad and I quite agree the CI should start with a change (fdegir, 14:23:05)
    4. and different jobs should be triggered based on the nature of the change, realizing our loops in CI (fdegir, 14:23:36)
    5. all the changes that are sent for review should travel our CI, creating feedback to developer and the wider community regarding the quality of the change (fdegir, 14:24:18)
    6. and if any change that fails to pass certain loop should not be allowed to merge to master (fdegir, 14:24:52)
    7. when it comes to longer loops such as our daily loops and perhaps later on weekly (fdegir, 14:25:21)
    8. we should perhaps employ some kind of promotion mechanism to carry artifacts known to have better quality to longer loops (fdegir, 14:25:59)
    9. please go ahead and share your thoughts on etherpad under the heading of "the scope and concept of E2E CI" (fdegir, 14:29:18)
    10. https://etherpad.opnfv.org/p/octopusR2 (fdegir, 14:29:26)

  6. Jira Issues and B-release CI Work (fdegir, 14:30:19)
    1. We need to start cleaning up the backlog and populating the new one on Jira for B-Release (fdegir, 14:31:48)
    2. Please have a look at Jira and close/cancel the Jira issues that you fixed already but haven't closed yet (fdegir, 14:32:45)

  7. LF Lab Reconfiguration Status (fdegir, 14:33:48)
    1. the lab reconfig works for Foreman, and there were some updates made for Fuel. Fuel still needs to finish a few changes and still test before we take down POD1 (trozet, 14:34:06)
    2. szliard_ is working on it from the FUel side (trozet, 14:34:25)
    3. fuel verification/adjustments are needed in order to be able to maintain/support Arno release for both Foreman and Fuel (fdegir, 14:35:03)

  8. AoB (fdegir, 14:35:55)


Meeting ended at 14:36:56 UTC (full logs).

Action items

  1. uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab
  2. chigang to try on a POD to apply new naming scheme to a slave.
  3. uli-k to contact silent committers and encourage them to start working.


Action items, by person

  1. trozet
    1. uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab
  2. UNASSIGNED
    1. chigang to try on a POD to apply new naming scheme to a slave.
    2. uli-k to contact silent committers and encourage them to start working.


People present (lines said)

  1. fdegir (93)
  2. meimei (41)
  3. trozet (7)
  4. aricg (5)
  5. collabot (3)
  6. dneary (2)


Generated by MeetBot 0.1.4.