#opnfv-meeting: Octopus and Releng Weekly Meeting

Meeting started by fdegir at 14:00:24 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 14:00:32)
    1. David Duffey (dduffey, 14:00:57)
    2. chenshuai (chenshuai, 14:01:00)
    3. Fatih Degirmenci (fdegir, 14:01:14)
    4. Jun Li (MatthewL2, 14:01:25)
    5. Mofassir (Mofassir, 14:02:14)
    6. meimei (meimei1, 14:02:20)
    7. Peter Bandzi (pbandzi, 14:02:24)
    8. Tim Rozet (trozet, 14:02:25)

  2. Agenda Bashing (fdegir, 14:02:34)
    1. Morgan Richomme (morgan_orange, 14:02:40)
    2. Meeting Structure Update (fdegir, 14:02:49)
    3. Octopus: Action Item Review / Lab Compliancy / B-Release Work (fdegir, 14:02:58)
    4. Releng: Lab Reconfiguration Status / Brahmaputra Support (fdegir, 14:03:10)
    5. AoB (fdegir, 14:03:14)

  3. Meeting Structure Update (fdegir, 14:03:27)
    1. Releng Team has decided to use same meeting slot as Octopus (fdegir, 14:03:52)
    2. And this has been agreed with uli-k as well (fdegir, 14:04:02)
    3. So we will have both Octopus and Releng meetings at this time until we see the need to change (fdegir, 14:04:26)

  4. Octopus Action Item Review (fdegir, 14:04:54)
    1. There are 3 action items from last week (fdegir, 14:05:11)
    2. uli-k trozet: report back once ChrisPriceAB clarifies the need of doing Brahmaputra release on LF Lab (fdegir, 14:05:42)
    3. ACTION: uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab (fdegir, 14:06:52)
    4. kaipue(HaoRan Li) (kaipule, 14:08:53)
    5. chigang to try on a POD to apply new naming scheme to a slave (fdegir, 14:08:59)
    6. ACTION: meimei1 to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1 (fdegir, 14:11:34)
    7. uli-k to contact silent committers and encourage them to start working. (fdegir, 14:12:25)
    8. ACTION: uli-k to contact silent committers and encourage them to start working. (fdegir, 14:12:57)
    9. chigang (chigang, 14:14:26)

  5. Octopus Lab Compliancy (fdegir, 14:15:50)
    1. meimei1 started up the topic on Etherpad (fdegir, 14:16:05)
    2. https://etherpad.opnfv.org/p/octopusR2 (fdegir, 14:16:15)
    3. The discussion has been happening there and we need to finalize it (fdegir, 14:16:29)
    4. Look for the heading: Octopus requirements on labs compliance and provide your input (fdegir, 14:16:48)
    5. We plan to talk to Pharos soon and pass our requirements to them (fdegir, 14:17:02)
    6. ACTION: meimei1 fdegir Follow-up Octopus Requirements with Pharos (fdegir, 14:18:55)

  6. Octopus B-Release Work (fdegir, 14:19:59)
    1. Octopus still needs some dependencies to be solved in order to continue working with pipelines (fdegir, 14:20:39)
    2. Such as Lab Compliancy/getting community labs up & running, LF lab reconfiguration (fdegir, 14:20:57)

  7. Releng Lab Reconfiguration Status (fdegir, 14:23:22)
    1. Fuel fixes were put in. A common clean that should work between installers was added as well. We tested Foreman to make sure it was working, but for some reason it's nodes cannot ping on the public interface (trozet, 14:24:47)
    2. pbandzi is looking into it (trozet, 14:24:56)
    3. moreover I requested more public IP from LF in order to have more Virtual env on POD1 (pbandzi, 14:25:30)
    4. 1 more Fuel fix is required, that is the installation of prerequisites: libvirt & qemu, before Fuel deployment job is launched (szilard_, 14:27:35)
    5. The summary of Lab Reconfiguration is (fdegir, 14:28:42)
    6. There is still some work left to do for Foreman and Fuel (fdegir, 14:28:56)
    7. Public IPs for POD1 will probably be fixed by next week given that most of the LF people are not available (fdegir, 14:29:21)
    8. lf-POD2 will be used for virtual deployment? (meimei1, 14:30:41)
    9. why not put 2 lf-pods into a pool, and the baremetal deployment will choose one pod randomly to implement (meimei1, 14:30:42)
    10. we can utilize other labs for virtual deployment (meimei1, 14:31:14)
    11. We severly need hardware resources (fdegir, 14:31:42)
    12. And sorting out the ther labs will probably take long time since Pharos is still in the process of clarifying the compliance (fdegir, 14:32:20)
    13. We have been requesting additional build/virt deployment resources for months (fdegir, 14:32:38)
    14. and the easiest way is to reconfigure LF Lab (fdegir, 14:32:50)
    15. According to decision (fdegir, 14:32:56)
    16. Servers from LF POD1 will be converted to standalone slaves (fdegir, 14:33:10)
    17. 2 servers for build, 2 for virt deploys, 2 for virt deploys + other project work (fdegir, 14:33:25)
    18. LF POD2 will be used for bare-metal deployment (fdegir, 14:33:36)
    19. Once the LF Lab reconfiguration work is done, we will increase the CI coverage by running virt deployments for patchset verification (fdegir, 14:35:28)

  8. Releng Brahmaputra Support (fdegir, 14:38:13)
    1. Some items to support Brahmaputra is put on Etherpad (fdegir, 14:38:30)
    2. The items are grouped as below (fdegir, 14:38:46)
    3. 1. Lab Infrastructure (fdegir, 14:38:52)
    4. 2. Test Result Handling (fdegir, 14:39:09)
    5. 3. Improvements in CI/Automation/Toolchain/Guidelines (fdegir, 14:39:17)
    6. 4. Release Process (fdegir, 14:39:23)
    7. https://etherpad.opnfv.org/p/releng (fdegir, 14:39:30)
    8. As it is written there, the items listed on Etherpad is not priority ordered (fdegir, 14:40:09)
    9. Please go ahead and put your comments/thoughts latest Wednesday (fdegir, 14:40:26)
    10. By Wednesday, Releng backlog will be created based on what is there on the Etherpad (fdegir, 14:40:45)
    11. Some of the items such as test reporting api and lab reconfig are already in progress (fdegir, 14:41:24)

  9. AoB (fdegir, 14:42:49)
    1. chenshuai asked the question if we will have something to analyze test results (fdegir, 14:45:57)
    2. morgan_orange answered that the first step is to collect the results into an homogeneous format (fdegir, 14:46:18)
    3. and then analytics will follow (fdegir, 14:46:31)
    4. there is a reflexion onstorage (already started through the API) / dashboard (discussed during summit) and analytics (fdegir, 14:46:43)
    5. test dashboard based on stored results planned for B release (morgan_orange, 14:46:46)
    6. Analytics has lower priority then the result collection and the dashboard (fdegir, 14:47:35)
    7. Analytics might not be available for Brahmaputra (fdegir, 14:47:49)


Meeting ended at 14:50:05 UTC (full logs).

Action items

  1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  2. meimei1 to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1
  3. uli-k to contact silent committers and encourage them to start working.
  4. meimei1 fdegir Follow-up Octopus Requirements with Pharos


Action items, by person

  1. ChrisPriceAB
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab
  2. fdegir
    1. meimei1 fdegir Follow-up Octopus Requirements with Pharos
  3. meimei1
    1. meimei1 to apply naming scheme for Huawei slaves: huawei-build-[1-4], huawei-deploy-1
    2. meimei1 fdegir Follow-up Octopus Requirements with Pharos
  4. trozet
    1. uli-k trozet ChrisPriceAB: clarify the need of doing Brahmaputra release on LF Lab


People present (lines said)

  1. fdegir (138)
  2. meimei1 (35)
  3. morgan_orange (9)
  4. pbandzi (8)
  5. MatthewL2 (6)
  6. trozet (6)
  7. chenshuai (5)
  8. chigang (4)
  9. collabot (4)
  10. dneary (3)
  11. ChrisPriceAB (3)
  12. szilard_ (2)
  13. kaipule (2)
  14. dduffey (1)
  15. aricg (1)
  16. Mofassir (1)


Generated by MeetBot 0.1.4.