#opnfv-meeting: BGS/Genesis Weekly Meeting

Meeting started by trozet at 15:00:46 UTC (full logs).

Meeting summary

    1. Jonas Bjurel ([1]JonasB, 15:01:05)
    2. Uli Kleber (uli-k, 15:01:15)
    3. chenshuai (chenshuai, 15:01:26)
    4. Dan Radez (radez, 15:01:37)
    5. David Duffey (dduffey, 15:01:40)
    6. arnaud morin (arnaud_orange, 15:01:45)
    7. Fatih Degirmenci (fdegir, 15:01:51)
    8. Randy Levensalor (RandyLevensalor, 15:01:54)

  1. Arno SR1 status (trozet, 15:02:17)
    1. hongbo tian (hongbotian, 15:02:22)
    2. David_Orange (David_Orange, 15:02:50)
    3. Any status updates from Fuel/Foreman for SR1? (trozet, 15:02:56)
    4. is still on track for SR1, plan is to release it through the stable/arno branch. We're constantly cherry-picking from master ([1]JonasB, 15:03:26)
    5. daniel Smith (lmcdasm, 15:03:38)
    6. Foreman is the same. Need to cherry pick from master to stable/arno (trozet, 15:03:48)
    7. Fuel/Foreman need to have release-notes updated with Fixes for SR1 (trozet, 15:04:19)
    8. https://wiki.opnfv.org/functest_release_1 (morgan_orange, 15:06:12)
    9. functest currently being fixed to verify SR1 stability (trozet, 15:06:59)
    10. https://wiki.opnfv.org/functest_release_1 (trozet, 15:07:06)
    11. ACTION: trozet, [1]JonasB: drafts of release notes for SR1, updated install instructions, etc ready in 2 weeks (trozet, 15:10:07)

  2. Genesis - JIRA Requirements (trozet, 15:11:30)
    1. any updates on new requirements or current ones that were added in JIRA? (trozet, 15:12:22)
    2. I have a couple of requirements that I was thinking about adding. Wanted to see what people thought int his meeting first (trozet, 15:13:01)
    3. We currently have most openstack services in HA, including neutron-dhcp-agent. However we create neutron networks, we dont actually do multiple dhcp servers per tenant in HA. Is that something we shoudl add a requirement for? (trozet, 15:14:03)
    4. +1 ([1]JonasB, 15:14:59)
    5. ACTION: trozet will add requirement for multiple dhcp servers in HA per tenant for review (trozet, 15:15:21)
    6. another requirement proposal: For helium, we used neutron L3 agent to do forwarding. However in Lithium, ODL introduced L3 forwarding and also distributed virtual routing (DVR). Should we add a requirement to do L3 inside of the SDN controller, and if so, use DVR? (trozet, 15:16:09)
    7. : I would like to remove the requirement on hitless software upgrade, that is the task of Escalator, if they deliver we will have hitless upgrade, if not we will not have it. ([1]JonasB, 15:17:03)
    8. [1]JonasB: proposes removing Genesis-15. (trozet, 15:19:06)
    9. <chenshuai> do installers need to support deployment offline? (trozet, 15:19:42)
    10. I don't see a current requirement in JIRA. chenshuai: can you please add one (trozet, 15:20:17)
    11. ACTION: chenshuai: propose JIRA requirement to require offline deployment option (trozet, 15:20:36)
    12. I would also like to remove genesis-41. An ONOS project should take care that requirement (ask Genesis to integrate it) it should not be a Genesis Jira issue. ([1]JonasB, 15:21:52)
    13. Genesis team please review Genesis-15 and provide feedback to [1]JonasB comment in the JIRA issue (trozet, 15:22:03)
    14. https://etherpad.opnfv.org/p/artifact_handling ([1]JonasB, 15:27:48)
    15. ACTION: chenshuai to email Genesis team with ONOS requirement information and start the discussion for Genesis-41 (trozet, 15:28:11)
    16. General integrating with genesis guidelines: mail to start hte discussion (with certain key info), then creation of JIRA issue, then voting by Genesis team, followed updating git rep (trozet, 15:30:23)
    17. ACTION: trozet come up with a wiki draft of these guidelines to follow (trozet, 15:30:47)
    18. ACTION: trozet to create requirement for SDN Controller L3 forwarding (instead of neutron). Will also include comments about distributed virtual routing (DVR) (trozet, 15:31:55)
    19. any other JIRA requirements to bring up? (trozet, 15:32:15)
    20. All committers to review and comments on the Jira requests ([1]JonasB, 15:32:51)
    21. ACTION: trozet will create some gerrit reviews for 5 or so JIRA reqs to get the ball rolling (trozet, 15:34:55)
    22. ACTION: chenshuai please propose a req for required openstack version (trozet, 15:38:03)
    23. ACTION: trozet add GENESIS-7 to vote in gerrit (trozet, 15:39:49)

  3. AOB (trozet, 15:40:45)
    1. [1]JonasB: asks what is the procedure for repo changes with regards to B-release (trozet, 15:46:16)
    2. he current repo is temporary and will be moved to "genesis" master after SR1. Only common directory will be kept in current genesis repo (everything else removed). stable/arno will remain untouched (trozet, 15:47:07)
    3. SR1 release and future SRs to take place on stable/arno branch. This branch will remain untouched when we migrate genesis_req to genesis master (trozet, 15:56:07)
    4. any other items to be discussed? (trozet, 15:56:33)


Meeting ended at 15:58:22 UTC (full logs).

Action items

  1. trozet, [1]JonasB: drafts of release notes for SR1, updated install instructions, etc ready in 2 weeks
  2. trozet will add requirement for multiple dhcp servers in HA per tenant for review
  3. chenshuai: propose JIRA requirement to require offline deployment option
  4. chenshuai to email Genesis team with ONOS requirement information and start the discussion for Genesis-41
  5. trozet come up with a wiki draft of these guidelines to follow
  6. trozet to create requirement for SDN Controller L3 forwarding (instead of neutron). Will also include comments about distributed virtual routing (DVR)
  7. trozet will create some gerrit reviews for 5 or so JIRA reqs to get the ball rolling
  8. chenshuai please propose a req for required openstack version
  9. trozet add GENESIS-7 to vote in gerrit


Action items, by person

  1. chenshuai
    1. chenshuai: propose JIRA requirement to require offline deployment option
    2. chenshuai to email Genesis team with ONOS requirement information and start the discussion for Genesis-41
    3. chenshuai please propose a req for required openstack version
  2. trozet
    1. trozet, [1]JonasB: drafts of release notes for SR1, updated install instructions, etc ready in 2 weeks
    2. trozet will add requirement for multiple dhcp servers in HA per tenant for review
    3. trozet come up with a wiki draft of these guidelines to follow
    4. trozet to create requirement for SDN Controller L3 forwarding (instead of neutron). Will also include comments about distributed virtual routing (DVR)
    5. trozet will create some gerrit reviews for 5 or so JIRA reqs to get the ball rolling
    6. trozet add GENESIS-7 to vote in gerrit


People present (lines said)

  1. trozet (83)
  2. [1]JonasB (43)
  3. uli-k (17)
  4. chenshuai (14)
  5. fdegir (9)
  6. morgan_orange (7)
  7. radez (4)
  8. collabot (4)
  9. RandyLevensalor (3)
  10. lmcdasm (3)
  11. dduffey (1)
  12. hongbotian (1)
  13. arnaud_orange (1)
  14. David_Orange (1)


Generated by MeetBot 0.1.4.