#opnfv-meeting: Brahmaputra weekly project meeting

Meeting started by ChrisPriceAB at 15:02:55 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:03:18)
    1. Uli Kleber (Octopus) (uli-k, 15:03:26)
    2. Chris Price (ChrisPriceAB, 15:03:26)
    3. Ana Cunha (Yardstick) (anac1, 15:03:27)
    4. Tim Rozet (Apex) (trozet, 15:03:38)
    5. Kevin Luehrs (LSOAPI) (KLuehrs, 15:03:53)
    6. chenshuai (Compass4nfv) (chenshuai1, 15:03:53)
    7. Fatih Degirmenci (Releng) (fdegir, 15:03:55)
    8. Mark Beierl (StorPerf) (mbeierl, 15:04:01)
    9. rprakash (rprakash, 15:04:16)
    10. Stuart Mackie (OpenContrail Virtual Networking) (StuartMackie, 15:04:28)
    11. Bryan Sullivan (bryan_att, 15:04:45)

  2. Agenda Bashing (debrascott, 15:05:00)
    1. https://wiki.opnfv.org/releases/brahmaputra/minutes (debrascott, 15:05:07)
    2. Bin Hu (IPv6) (bin_, 15:05:30)
    3. Maryam Tahhan (maryamtahhan, 15:05:40)
    4. Ashlee Young (onosfw) (ashyoung, 15:06:15)
    5. Frank Brockners (frankbrockners, 15:06:39)

  3. Milestone C process retrospective (debrascott, 15:06:41)
    1. n0ano (n0ano, 15:06:53)
    2. Vikram Dham (QTIP) (VikramDham, 15:06:57)
    3. Ryota Mibu (Doctor) (r-mibu, 15:07:17)
    4. Morgan Richomme (Functest) (morgan_orange, 15:07:37)
    5. Larry Lamers (ljlamers, 15:07:57)
    6. https://wiki.opnfv.org/releases/brahmaputra/minutes (debrascott, 15:08:10)
    7. ACTION: Debra make link to Brahmaputra release very visible from front of WIKI (debrascott, 15:09:12)
    8. https://wiki.opnfv.org/releases/brahmaputra/release_plan (frankbrockners, 15:09:27)
    9. process a little difficult to get into for new projects but otherwise went well (debrascott, 15:10:22)

  4. Jira issues (debrascott, 15:12:45)
    1. for Milestone D we do not expect this amount of reporting efforts (ildikov, 15:12:47)
    2. Milestone E is where we would need to have this checkpoint again (ildikov, 15:13:03)
    3. using Sprint functionality- need to create a board first then drag tasks into the board (debrascott, 15:14:59)
    4. need administrator rights to create a board (debrascott, 15:15:49)
    5. look under projects tab, if you have administration rights you’ll see an “administer” tab (debrascott, 15:16:29)
    6. project leads should have administrative rights (debrascott, 15:17:35)
    7. project leads can then delegate additional administrators (debrascott, 15:18:35)
    8. under administration tab is a “permissions” tab where delegates can be added (debrascott, 15:20:30)
    9. under Projects -> Your project name (mbeierl, 15:21:32)
    10. Will be "Overview" and "Administration" (mbeierl, 15:21:48)
    11. ACTION: Debra add administration tasks to list of Jira training to be created (debrascott, 15:24:00)
    12. ACTION: Mark Beierl to check with Aric on how to make administrator group visible to users (debrascott, 15:27:25)
    13. Under "Roles" there is a table of "Project Roles | Users | Groups" with rows "Administrators, Developers, Users" Click in the cell at the intersection of "Administrators+Users" and you can enter the name of additional project administrators that you want to create/start/stop sprints (mbeierl, 15:29:27)
    14. I incorrectly identified this as "permissions", it is actually the "roles" page (mbeierl, 15:30:09)
    15. Do we need to ever remove people from Jira? A: no because that also removes all their cases (debrascott, 15:32:27)
    16. you can deactivate users in Jira if necessary (debrascott, 15:33:03)

  5. future topics, key to staying on track toward next milestone (debrascott, 15:33:52)
    1. Frank brings up project interdependencies, make sure they get closed before Milestone D (debrascott, 15:35:51)
    2. ACTION: Debra to create a dependency graph (debrascott, 15:38:05)
    3. good to track dependencies but we should avoid adding additional gates (RayNugent_, 15:38:31)
    4. Ryota asks how to manage test projects dependencies which may require additonal configuration provisions versus what is required for test? (debrascott, 15:50:08)
    5. https://wiki.opnfv.org/testing/ (morgan_orange, 15:51:24)
    6. Morgan clarifies that feature projects will need to provide additional things for configuration of tests and because of this there are additional milestones needed for test projects. (debrascott, 15:52:07)
    7. test projects will not write feature project tests, they will help you with it (debrascott, 15:52:57)


Meeting ended at 16:01:45 UTC (full logs).

Action items

  1. Debra make link to Brahmaputra release very visible from front of WIKI
  2. Debra add administration tasks to list of Jira training to be created
  3. Mark Beierl to check with Aric on how to make administrator group visible to users
  4. Debra to create a dependency graph


Action items, by person

  1. debra
    1. Debra make link to Brahmaputra release very visible from front of WIKI
    2. Debra add administration tasks to list of Jira training to be created
    3. Debra to create a dependency graph


People present (lines said)

  1. debrascott (25)
  2. morgan_orange (14)
  3. frankbrockners (12)
  4. ChrisPriceAB (9)
  5. collabot (8)
  6. anac1 (7)
  7. mbeierl (5)
  8. ildikov (2)
  9. KLuehrs (2)
  10. maryamtahhan (2)
  11. chenshuai1 (1)
  12. n0ano (1)
  13. ashyoung (1)
  14. fdegir (1)
  15. StuartMackie (1)
  16. trozet (1)
  17. VikramDham (1)
  18. r-mibu (1)
  19. ljlamers (1)
  20. bin_ (1)
  21. uli-k (1)
  22. RayNugent_ (1)
  23. rprakash (1)
  24. billyoma (1)
  25. bryan_att (1)
  26. debra (0)
  27. rpaik (0)


Generated by MeetBot 0.1.4.