#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:00:29 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:00:32)
    1. Dirk Kutscher (dku, 15:00:36)
    2. Chris Price (ChrisPriceAB, 15:00:39)
    3. Frank Brockners (frankbrockners, 15:00:46)
    4. Bin Hu (bin_, 15:00:50)
    5. Julien (Julien-zte, 15:01:06)
    6. Tapio Tallgren (ttallgren, 15:01:07)
    7. Edgar StPierre (edgarstp, 15:01:16)
    8. Uli Kleber (uli-k_, 15:01:17)
    9. Gerald Kunzmann (GeraldK, 15:02:03)
    10. Parviz Yegani (Parviz, 15:02:11)

  2. approval of previous minutes of meeting (ChrisPriceAB, 15:02:21)
    1. Morgan Richomme (morgan_orange, 15:02:23)
    2. no comments received, previous minutes approved (ChrisPriceAB, 15:02:31)

  3. Agenda Bashing (ChrisPriceAB, 15:02:39)
    1. https://wiki.opnfv.org/wiki/tsc current agenda (ChrisPriceAB, 15:02:51)
    2. postponing the policy document update as Brian is not able to join the call. (ChrisPriceAB, 15:04:14)

  4. Brahmaputra status update (ChrisPriceAB, 15:04:32)
    1. Currently we have 24 scenario's planned. Of those we have 15 scenario's installing successfully (ChrisPriceAB, 15:05:36)
    2. some scenario's have not yet been deployed, some are pending solutions to known issues. (ChrisPriceAB, 15:06:09)
    3. it may be necessary to delay the release to include the pending functionality. (ChrisPriceAB, 15:06:45)
    4. Trevor Cooper (trevor_intel, 15:07:56)
    5. Of the test projects, YardStick has some pending issues, functest also has some pending issues. (ChrisPriceAB, 15:08:41)
    6. GeraldK asks about other pending issues including vPing. (ChrisPriceAB, 15:09:13)
    7. morgan_orange provides an update that functest is working on some scenario's although work is ongoing to stabilise functest for all scenario's (ChrisPriceAB, 15:10:48)
    8. vIMS is not possible unless it is proven that vPing works on the deployment. Some progress is being made on vIMS to secure it's stability. (ChrisPriceAB, 15:11:56)
    9. Dave Neary (dneary, 15:12:11)
    10. morgan adds that we do not yet have a scenario that is able to be run according to the release requirement of four successful runs. (ChrisPriceAB, 15:12:53)
    11. Compass provides the closest set of scenario's that approach release readiness. (ChrisPriceAB, 15:13:43)
    12. rnugent asks what level of confidence there is that three weeks will provide the needed stabilisy. (ChrisPriceAB, 15:14:09)
    13. debra responds that a three week delay would make her 80% confident that we would make the release. (ChrisPriceAB, 15:14:44)
    14. GeraldK adds that we are currently three weeks late on meeting milestone E requirements and that a three week delay would help bring stability. (ChrisPriceAB, 15:15:32)
    15. uli-k_ adds that we should look to reducing content for Brahmaputra to achieve our dates. (ChrisPriceAB, 15:16:08)
    16. The teams report that we do not have a release candidate today that fulfills our release requirements. (ChrisPriceAB, 15:18:27)
    17. we also do not have code freeze on many cases (rpaik, 15:19:47)
    18. morgan_orange adds that there was also delay in testing projects for some of the milestone D items (rpaik, 15:22:52)
    19. ChrisPriceAB is asking testing teams about their view/confidence towards stability given a 3 weeks delay for Brahmaputra (GeraldK, 15:25:02)
    20. morgan_orange: vIMS is a bit more complex; we still get surprises every day; for internal test cases they are quite confident (GeraldK, 15:26:19)
    21. morgan_orange: we should REALLY freeze end of this week (GeraldK, 15:27:42)
    22. rpaik just to mention that CI labs were supposed to be ready beginning of January to perform the first tests, they were only available beginning of January (morgan_orange, 15:29:28)
    23. uli-k: we need to make sure that everybody understands what code freeze means and what is still allowed after the code freeze (GeraldK, 15:29:42)
    24. GeraldK states that we need to have clear activities, plans and targets in place for the time between now and a target release date. (ChrisPriceAB, 15:33:30)
    25. ffrankbrockners outlines this would involve knowing the steps clearly, and having concise plans in place. The challenge frank outlines is that we may not know enough to establish accurate milestones. (ChrisPriceAB, 15:34:14)
    26. https://wiki.opnfv.org/releases/stablebranch stable branch policy - the rules for our code freeze (uli-k_, 15:34:32)
    27. frankbrockners states another approach would be to work toward a target of scenario's and base the release date on achieving those targets (ChrisPriceAB, 15:35:10)
    28. GeraldK suggests still defining gate/schedule even if we take a “content-based” approach (rpaik, 15:39:22)
    29. dneary suggests reducing scenarios to avoid scope creep (rpaik, 15:40:12)
    30. frankbrockners discussed creating a schedule (need reasonable milestones) with a new target release date (rpaik, 15:49:54)
    31. community learned in the past few weeks that testing required more time than anticipated (rpaik, 15:51:44)
    32. uli-k suggests setting up a separate meeting this week to discuss the new schedule (rpaik, 15:53:10)
    33. Trevor Cooper voting for Brian Skerry (trevor_intel1, 15:55:44)
    34. VOTE: Voted on "Does the TSC agree that it is necessary to move the target release out from February 2nd?" Results are, 0: 1, +1: 11 (ChrisPriceAB, 15:56:30)
    35. proxy for Parviz (rpaik, 15:56:31)
    36. Chinese new year is on February 8th with vacation from our Chinese participants. (ChrisPriceAB, 15:57:01)
    37. https://wiki.opnfv.org/releases/stablebranch stable branch policy - the rules for our code freeze (uli-k_, 15:58:00)
    38. VOTE: Voted on "Does the TSC agree to code freeze by the end of this week?" Results are, +1: 1 (ChrisPriceAB, 16:00:02)
    39. cancelling vote due to lack of clarity on the meaning of code freeze. (ChrisPriceAB, 16:00:17)
    40. ACTION: chrispriceab to send a definition of code freeze for review and eventual voting on the mailiing lists. (ChrisPriceAB, 16:01:27)


Meeting ended at 16:02:06 UTC (full logs).

Action items

  1. chrispriceab to send a definition of code freeze for review and eventual voting on the mailiing lists.


Action items, by person

  1. ChrisPriceAB
    1. chrispriceab to send a definition of code freeze for review and eventual voting on the mailiing lists.


People present (lines said)

  1. ChrisPriceAB (41)
  2. collabot (15)
  3. rpaik (11)
  4. GeraldK (8)
  5. uli-k_ (5)
  6. morgan_orange (5)
  7. tnadeau_ (5)
  8. dneary (3)
  9. ttallgren (3)
  10. frankbrockners (2)
  11. dku (2)
  12. fdegir (2)
  13. anac1 (2)
  14. Julien-zte (2)
  15. trevor_intel1 (2)
  16. edgarstp (2)
  17. bin_ (1)
  18. Parviz (1)
  19. ildikov (1)
  20. trevor_intel (1)


Generated by MeetBot 0.1.4.