#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:59:20 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 14:59:25)
    1. Chris Price (ChrisPriceAB, 14:59:35)
    2. Frank Brockners (frankbrockners, 15:00:09)
    3. Edgar StPierre (edgarstp, 15:00:13)
    4. Debra Scott irc only (debrascott, 15:00:20)
    5. Brian Skerry (bjskerry, 15:00:24)
    6. Tapio Tallgren (ttallgren, 15:01:18)

  2. Approval of previosu minutes of meeting (ChrisPriceAB, 15:01:24)
    1. Dirk Kutscher (dku, 15:01:40)
    2. https://wiki.opnfv.org/wiki/tsc#january_26_2016 previous meeting minutes (ChrisPriceAB, 15:01:47)
    3. Uli Kleber (uli-k_, 15:01:52)
    4. no comments received approved (ChrisPriceAB, 15:01:54)
    5. Gerald Kunzmann (GeraldK, 15:01:58)

  3. Agenda Bashing (ChrisPriceAB, 15:02:01)
    1. https://wiki.opnfv.org/wiki/tsc#february_2_2016 current agenda (ChrisPriceAB, 15:02:07)
    2. Mike Lynch (mlynch, 15:02:08)
    3. no additions to the Agenda (ChrisPriceAB, 15:03:13)

  4. License scan update - Scott Nicholas (ChrisPriceAB, 15:03:26)
    1. The team is looking at the license from code freeze on Friday. (ChrisPriceAB, 15:03:44)
    2. Scott will reach out to teams with specific questions that arise. (ChrisPriceAB, 15:03:56)
    3. Bryan Sullivan (bryan_att, 15:03:57)
    4. Scott & Ray thank the community for addressing the issues found quickly (ChrisPriceAB, 15:04:17)
    5. for some files it is practially impossible to include license information. workaround: put a license file into the folder (GeraldK, 15:05:28)
    6. some area where focus continues and reach-out will occur include; understanding license disclosures on files that are not yet clear, binary files are an example where a file in the directory describing the license will be an applicable workaround. (ChrisPriceAB, 15:05:48)
    7. In some cases files include license identifiers that are not our projects identifier. (ChrisPriceAB, 15:06:21)
    8. Scott outlines that it is preferable to do our work upstream and deriving our work from those sources. (ChrisPriceAB, 15:07:27)
    9. there are small number of projects that use non-Apache v 2.0 licenses and will receive a questionnaire on 3rd party dependency for review with the legal committee (rpaik, 15:08:32)
    10. Scott asks the community to be aware that he and Ray may be reaching out to the community, please pay attention to those requests. (ChrisPriceAB, 15:08:35)
    11. Julien (Julien-z_, 15:08:57)
    12. Trevor Cooper (trevor_intel, 15:08:59)
    13. Questionnaire will help determine developer or project dependency (rpaik, 15:10:38)
    14. Bryan asks if it is OK to remove files prior to the release if they are not used for the purposes of release. (ChrisPriceAB, 15:12:56)
    15. Scott responds that if it is not needed it should likely be considered a bug. (ChrisPriceAB, 15:13:49)
    16. uli-k asks if the RST files for our documentation should have a license file (ChrisPriceAB, 15:14:16)
    17. rpaik answers that the creative commu=ons license should be used. (ChrisPriceAB, 15:14:28)
    18. https://wiki.opnfv.org/developer/contribution_guidelines?s[]=license license for documentation (rpaik, 15:15:15)
    19. ACTION: opnfvdocs to work with the projects to ensure we have the right licensing in our documents. (ChrisPriceAB, 15:15:41)
    20. the text is: This work is licensed under a Creative Commons Attribution 4.0 International License. http://creativecommons.org/licenses/by/4.0 (rpaik, 15:16:55)
    21. ACTION: opnfvdocs to add an example on the use of creative commons on the contribution_guidelines wiki (ChrisPriceAB, 15:17:07)
    22. Scott warns that if a file has an incorrect license it can be viewed as a bug, but one needs to be sure they have the rights to change the license of the file prior to making any adjustments. (ChrisPriceAB, 15:18:20)
    23. http://creativecommons.org/licenses/by/4.0/legalcode ? (Julien-z_, 15:18:35)

  5. Brahmaputra status update - Debra (ChrisPriceAB, 15:19:41)
    1. Troublshooting is ongoing after code freeze. (ChrisPriceAB, 15:20:05)
    2. some scenario's have begun to stabilize, others remain unstable. (ChrisPriceAB, 15:20:32)
    3. ONOS and ODL L2 are stabilizing but require more work to establish a stable trend. (ChrisPriceAB, 15:20:47)
    4. Yardstick is still troubleshooting ODL deployment with ssh and ping use cases. (ChrisPriceAB, 15:21:13)
    5. Overall a significant amount of troubleshooting is still remaining. (ChrisPriceAB, 15:22:02)
    6. https://etherpad.opnfv.org/p/steps_to_brahmaputra (frankbrockners, 15:22:40)
    7. a proposed amended schedule is available on the WiKi. (ChrisPriceAB, 15:22:55)
    8. the propsal includes a scenario freeze date on the 26th of February, including 8 additional days to release. (ChrisPriceAB, 15:23:32)
    9. morgan_orange adds that the community infrastrcture has not been made fully stable. (ChrisPriceAB, 15:24:03)
    10. morgan_orange adds that compass and joid scenario's are trending toward stability (ChrisPriceAB, 15:24:49)
    11. morgan_orange adds the number of scenario's for Fuel and Apex provide challenges to achieve stability. (ChrisPriceAB, 15:25:16)
    12. morgan_orange adds that the three main scenario's across installers are stabilisiing although for the additional scenario's more runs are needed to stabilise. (ChrisPriceAB, 15:28:56)
    13. https://build.opnfv.org/ci/view/OPNFV%20Platform%20CI%20-%20Alternative%20View/ current stable runs (ChrisPriceAB, 15:29:49)
    14. Apex is working with a different CI solution and it is difficult for the teams to track them on CI (ChrisPriceAB, 15:30:27)
    15. morgan_orange states that having all teams using the same CI solutions makes it easier to track them and predict what is occuring (ChrisPriceAB, 15:31:13)
    16. https://etherpad.opnfv.org/p/steps_to_brahmaputra (Morgan_, 15:38:08)
    17. community may have more confidence in setting the release date in about a week’s time (rpaik, 16:04:09)
    18. AGREED: The TSC agree's to postpone the setting of the release date until next TSC meeting when more information will be available. (ChrisPriceAB, 16:05:56)


Meeting ended at 16:06:21 UTC (full logs).

Action items

  1. opnfvdocs to work with the projects to ensure we have the right licensing in our documents.
  2. opnfvdocs to add an example on the use of creative commons on the contribution_guidelines wiki


People present (lines said)

  1. ChrisPriceAB (44)
  2. rpaik (8)
  3. GeraldK (7)
  4. collabot (6)
  5. frankbrockners (4)
  6. dneary (4)
  7. debrascott (3)
  8. jose_lausuch (3)
  9. Morgan_ (2)
  10. anac1 (2)
  11. Julien-z_ (2)
  12. dku (1)
  13. uli-k_ (1)
  14. trevor_intel (1)
  15. ttallgren (1)
  16. edgarstp (1)
  17. bryan_att (1)
  18. ildikov (1)
  19. bjskerry (1)
  20. mlynch (1)
  21. uli-k (0)


Generated by MeetBot 0.1.4.