#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:00:03 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 15:00:12)
    1. Chris Price (ChrisPriceAB, 15:00:19)
    2. Dirk Kutscher (dku, 15:00:39)
    3. Juha Oravainen (proxy for Tapio Tallgren) (JuhaOravainen, 15:00:59)
    4. Morgan Richomme (IRC) (morgan_orange, 15:01:21)
    5. Uli (uli-k_, 15:01:29)
    6. Parviz Yegani (Parviz, 15:01:48)
    7. Brian Skerry (bjskerry, 15:01:48)
    8. Narinder Gupta (narindergupta, 15:02:18)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 15:02:42)
    1. https://wiki.opnfv.org/wiki/tsc#february_16_2016 previous TSC minutes (ChrisPriceAB, 15:02:48)
    2. no feedback was received minutes approved. (ChrisPriceAB, 15:03:08)

  3. Agenda Bashing (ChrisPriceAB, 15:03:18)
    1. Gerald Kunzmann (GeraldK, 15:03:18)
    2. bryan sullivan (bryan_att, 15:03:19)
    3. Frank Brockners (frankbrockners, 15:03:29)
    4. https://wiki.opnfv.org/wiki/tsc#february_23_2016 current agenda for today (ChrisPriceAB, 15:03:39)
    5. rpaik raises the need to discuss release artifacts and release pages (ChrisPriceAB, 15:05:11)
    6. geraldk would like to discus projects that did not make the release. (ChrisPriceAB, 15:05:26)
    7. these topics will be captured in the Brahmaputra discussion (ChrisPriceAB, 15:06:13)
    8. Julien (Julien-zte, 15:06:21)

  4. Brahmaputra release update (ChrisPriceAB, 15:06:24)
    1. https://wiki.opnfv.org/releases/brahmaputra/daily_status (debrascott, 15:06:40)
    2. the following scenario's are ready for release: apex/odl_l2 - compass/odl_l2 - compass/onos - compass-nosdn - fuel/nosdn - fuel/old_l2 - fuel/onos (ChrisPriceAB, 15:07:09)
    3. projects that do not yet have a stable scenario include: NFVOVS, KVM4NFV, SFC, BGP-VPN, Doctor (ChrisPriceAB, 15:08:15)
    4. ebrjohn Brady Johnson, SFC (ebrjohn, 15:08:15)
    5. Jonas Bjurel ([1]JonasB, 15:08:46)
    6. Joid deploy has achieved stability for odl_l2 and nosdn (ChrisPriceAB, 15:09:24)
    7. stability runs are ongoing in preparation for release on Thursday (ChrisPriceAB, 15:09:40)
    8. dneary (dneary, 15:09:49)
    9. ghall ( proxy Tom Nadeau ) (ghall, 15:10:10)
    10. trevor_intel (trevor_intel_, 15:10:34)
    11. Doctor is being deployed on apex/odl_l2 (ChrisPriceAB, 15:12:14)
    12. as of et there have not been 4 successful runs verifying the doctor functionality. (ChrisPriceAB, 15:12:33)
    13. discussion that scenarios like Apex/ONOS and Apex/ODL-L3 are deploying successfully but have known limitations (rpaik, 15:22:39)
    14. concensus that these scenarios could be released with issues documented (rpaik, 15:24:28)
    15. http://artifacts.opnfv.org/opnfvdocs/review/10487/configguide/configoptions.html#opnfv-scenario-s scenario matrix patch (ChrisPriceAB, 15:30:32)
    16. AGREED: the TSC agree that scenario's which have known limitations can be released with the limitations documented for Thursday. The scenario's need to be stable and reproducable. (ChrisPriceAB, 15:46:38)
    17. ACTION: ChrisPriceAB and opnfvdocs team to work with the deploy and test teams to clarify and fully document the state of each scenario according to the above agreement. (ChrisPriceAB, 15:53:39)
    18. ACTION: debra, aricg and the octopus team to ensure the release tagging process is well understood for the project leads. Tagging must be done by Wednesday for all projects. (ChrisPriceAB, 15:59:10)

  5. Brahmaputra release and artifact handling (ChrisPriceAB, 15:59:53)
    1. https://www.opnfv.org/software/download current software downloads page (rpaik, 16:00:06)
    2. updates will be made to the software downloads page (ChrisPriceAB, 16:00:13)
    3. on the main dowwnloads page there will be links to each deploy tool (ChrisPriceAB, 16:01:24)
    4. the link will take users to the download page including documentations for each deploy tool. (ChrisPriceAB, 16:01:42)
    5. https://wiki.opnfv.org/releases/brahmaputra/releasedocs docs wiki (rpaik, 16:01:51)
    6. the main downloads page will also contain direct links the composite docs and a link to the release documentation page which will contain all project documentation. (ChrisPriceAB, 16:02:35)

  6. AoB Brahmaputra (ChrisPriceAB, 16:04:02)
    1. Heather asks what terminology we would want to use for our release iterations. (ChrisPriceAB, 16:04:39)
    2. frankbrockers indicates "release additions" would be a good convention (ChrisPriceAB, 16:05:49)
    3. Feature Release? (RayNugent_, 16:12:36)

  7. C Release planning and discussion. (ChrisPriceAB, 16:12:50)
    1. ACTION: rpaik to start a mailing list coversation on the C-release naming (rpaik, 16:15:51)
    2. https://etherpad.opnfv.org/p/c-release-brainstorming (fdegir, 16:16:49)
    3. https://etherpad.opnfv.org/p/c-release-brainstorming c release brainstorming etherpad (ChrisPriceAB, 16:17:13)
    4. agree with Daniel, I suggest to reduce the test cases which cost too much resources including CI hardware resources (Julien-zte, 16:20:32)
    5. debrascott notes back-end resource issues (e.g. for testing, documentation, CI, etc.) (rpaik, 16:20:37)
    6. currently there are 23 scenarios, but only fewer can be released in B (Julien-zte, 16:22:58)
    7. dan outlines that pharos and reosurce management is a key area to improve for C-Release (ChrisPriceAB, 16:32:26)
    8. discussion on resource issues for Pharos, install teams, etc. (rpaik, 16:32:51)
    9. Debra identifies that we need to identify how many new projects will be involved and what impact this will have on integration, test & infra (ChrisPriceAB, 16:34:37)
    10. Debra suggest trade-off between scope and more resources. the challenge is that there are several types of installers which will cost each project team more resources to be integrated (Julien-zte, 16:36:30)
    11. https://etherpad.opnfv.org/p/Q1'2016_Hackfest ([1]JonasB, 16:39:53)
    12. +1 on Dan's idea that we identify content early on so we can do reasonable resource mapping and communicate to installers and test what the workload will be. (RayNugent_, 16:40:08)
    13. radez adds that shifting requirements late in the Brahmaputra release cycle was also a challenge (rpaik, 16:41:54)
    14. inparticular, scheduling a requirements freeze of some sort early on in the release cycle (radez, 16:42:39)
    15. dneary agrees with DanSmithEricsson that the community is setup to provide adequate support (rpaik, 16:45:07)
    16. dneary agrees with DanSmithEricsson that the community is not set up to provide adequate support across multiple versions of upstream projects (dneary, 16:52:39)
    17. +1 with ildikov for reference platform (Julien-zte, 17:01:21)


Meeting ended at 17:02:42 UTC (full logs).

Action items

  1. ChrisPriceAB and opnfvdocs team to work with the deploy and test teams to clarify and fully document the state of each scenario according to the above agreement.
  2. debra, aricg and the octopus team to ensure the release tagging process is well understood for the project leads. Tagging must be done by Wednesday for all projects.
  3. rpaik to start a mailing list coversation on the C-release naming


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB and opnfvdocs team to work with the deploy and test teams to clarify and fully document the state of each scenario according to the above agreement.
  2. rpaik
    1. rpaik to start a mailing list coversation on the C-release naming


People present (lines said)

  1. ChrisPriceAB (39)
  2. rpaik (11)
  3. DanSmithEricsson (9)
  4. dneary (7)
  5. [1]JonasB (7)
  6. Julien-zte (5)
  7. collabot` (4)
  8. debrascott (4)
  9. bryan_att (3)
  10. ildikov (3)
  11. RayNugent_ (3)
  12. GeraldK (2)
  13. ashyoung_ (2)
  14. fdegir (2)
  15. radez (1)
  16. narindergupta (1)
  17. bjskerry (1)
  18. morgan_orange (1)
  19. frankbrockners (1)
  20. ghall (1)
  21. uli-k_ (1)
  22. trevor_intel_ (1)
  23. JuhaOravainen (1)
  24. Parviz (1)
  25. ebrjohn (1)
  26. dku (1)
  27. jose_lausuch (1)


Generated by MeetBot 0.1.4.