#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 15:00:04 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 15:00:11)
    1. Chris Price (ChrisPriceAB, 15:00:25)
    2. Gerald Kunzmann (GeraldK, 15:01:07)
    3. Carlos Goncalves (cgoncalves, 15:01:15)
    4. Uli Kleber (uli-k_, 15:01:18)
    5. Tapio Tallgren (TapioT, 15:01:25)
    6. Edgar StPierre (edgarstp, 15:01:30)

  2. approval of previous minutes of meeting (ChrisPriceAB, 15:03:07)
    1. https://wiki.opnfv.org/wiki/tsc#february_23_2016 the minutes of the previous meeting (ChrisPriceAB, 15:03:19)
    2. no comments received on the minutes approved. (ChrisPriceAB, 15:03:30)

  3. Agenda Bashing (ChrisPriceAB, 15:03:38)
    1. https://wiki.opnfv.org/wiki/tsc#march_1_2016 todays agenda (ChrisPriceAB, 15:03:58)
    2. Morgan Richomme (morgan_orange, 15:04:14)
    3. uli-k outlines that we should discuss how to handle the release additions (ChrisPriceAB, 15:05:41)

  4. Brahmaputra release recap/update (ChrisPriceAB, 15:06:35)
    1. Dave Neary (dneary, 15:06:57)
    2. Debra outlines that the teams are focused on troubleshooting scenario's that were not in a completely "release ready" state for Brahmaputra (ChrisPriceAB, 15:07:19)
    3. Trevor Cooper for Brian Skerry (trevor_intel1, 15:07:22)
    4. we are starting to understand that some of the limitations may not be solved in the B release timeframe and may be documented limitations. (ChrisPriceAB, 15:07:44)
    5. Brahmaputra stable handling discussion: on post brahmaputra stable handling (ChrisPriceAB, 15:08:41)
    6. morgan_orange outlines the need to establish a methodology for handling C release activities in parallel with B-stable handling. (ChrisPriceAB, 15:09:20)
    7. the current assumption is that we will work only on Master and stable/brahaputra and tag the releases as they are ready on stable/brahmaputra. (ChrisPriceAB, 15:10:19)
    8. https://wiki.opnfv.org/releases/stablebranch current stable branch handling (ChrisPriceAB, 15:10:54)
    9. Julien (Julien-zte, 15:12:16)
    10. uli-k_ outlines that we would not do "stable release" but only stabilize scenario's. (ChrisPriceAB, 15:12:24)
    11. Bin Hu (for Bryan Sullivan) (bin_, 15:19:25)
    12. discussion if all bug fixes still require same level of testing (e.g. 4 successful runs) (rpaik, 15:21:10)
    13. morgan_orange outlines that changes to stable are unlikely to not be completely isolated. (ChrisPriceAB, 15:22:10)
    14. morgan also adds that our CI is there to ensure we can validate changes across the release (ChrisPriceAB, 15:22:53)
    15. can we limit the scenarios(or won't add more) to enter into Brahmaputra, so we can fix the limited bugs and focus on C. (Julien-zte, 15:23:18)
    16. miss the deadline won't be released in current version (Julien-zte, 15:23:59)
    17. the intention is not absolutely not add new scenario's or features to Brahmaputra. (ChrisPriceAB, 15:24:47)
    18. the focus as of now is to stabilize the not yet release ready scenario's (ChrisPriceAB, 15:25:15)
    19. we should ensure we secure resources for stable handling of stable/brahmaputra once the scenario's are in a stable state and other resources are assigned to C release. (ChrisPriceAB, 15:27:06)
    20. ACTION: octopus, releng to work with the design teams to establish a resource plan for stable handling port Brahmaputra 2.0 (ChrisPriceAB, 15:30:37)
    21. ACTION: octopus, releng to document stable branch handling and labeling for stable/brahmaputra on the release wiki (ChrisPriceAB, 15:31:17)
    22. http://lists.opnfv.org/pipermail/opnfv-project-leads/2016-March/000363.html (fdegir, 15:31:58)
    23. The communications team information on the web launch of Brahmaputra (ChrisPriceAB, 15:33:30)
    24. https://www.opnfv.org/brahmaputra Brahmaputra landing page (rpaik, 15:34:06)
    25. https://www.opnfv.org/news-faq/press-release/2016/02/opnfv-delivers-second-release-open-source-network-functions Brahmaputra press release (rpaik, 15:34:22)
    26. https://www.opnfv.org/software/download Brahmaputra downloads page (rpaik, 15:34:40)
    27. https://www.opnfv.org/news-faq/blog/2016/03/navigating-brahmaputra Chris Price's blog post (rpaik, 15:34:47)
    28. https://www.opnfv.org/software/download Brahmaputra downloads page (rpaik, 15:35:16)
    29. https://www.opnfv.org/news-faq/blog/2016/03/navigating-brahmaputra Chris Price's blog post (rpaik, 15:35:29)
    30. http://ctt.ec/ap8T4 for re-tweet (rpaik, 15:35:40)
    31. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-March/008535.html email from Heather (rpaik, 15:35:53)

  5. Release C Planning (ChrisPriceAB, 15:36:39)
    1. https://wiki.opnfv.org/releases/releaseplanning immediate topics to address for C release (ChrisPriceAB, 15:36:59)
    2. the dates in the wiki are one month delayed from our target (ChrisPriceAB, 15:40:01)
    3. uli-k_ outlines our milestones need to identify and support the inter project dependencies. (ChrisPriceAB, 15:40:34)
    4. it may be worth staging the milestones for specific components of the release. (ChrisPriceAB, 15:41:28)
    5. ildikov outlines the need to focus on the integration and testing of the platform capabilities (ChrisPriceAB, 15:42:57)
    6. edgar states that ew need to be very clear on the fixed dates that projects need to be able to achieve. (ChrisPriceAB, 15:47:03)
    7. ACTION: ChrisPriceAB to start a discussion on the mailing list to iterate on the wiki page (rpaik, 15:48:37)
    8. AGREED: the TSC agrees that we try to establish our milestone plan for the C release with the intention of opening the C-Release next Tuesday for project participation. (ChrisPriceAB, 15:49:53)

  6. C release naming update (ChrisPriceAB, 15:50:49)
    1. rpaik is collecting name nominations at this time. This opportunity will close tomorrow. (ChrisPriceAB, 15:51:26)
    2. rpaik will open a poll on march 3rd that will remain open for a week. (ChrisPriceAB, 15:51:43)
    3. ildikov asks if we have guidelines on the names for the releases (simple names etc) (ChrisPriceAB, 15:52:29)
    4. there is no wish to impose restrictions on the naming of our releases. (ChrisPriceAB, 15:55:18)

  7. AoB (ChrisPriceAB, 15:55:26)
    1. Statement from LSO: (1) Brahmaputra release is focused on the data center and not on providing services to the network or customer CPEs. The LSOAPI project is specifically about providing business services to service provider customers on the network, so project objectives do not align with Brahmaputra. (uli-k_, 15:56:47)
    2. We should try to avoid such perception for the C-Release (uli-k_, 15:59:52)


Meeting ended at 16:00:48 UTC (full logs).

Action items

  1. octopus, releng to work with the design teams to establish a resource plan for stable handling port Brahmaputra 2.0
  2. octopus, releng to document stable branch handling and labeling for stable/brahmaputra on the release wiki
  3. ChrisPriceAB to start a discussion on the mailing list to iterate on the wiki page


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB to start a discussion on the mailing list to iterate on the wiki page
  2. UNASSIGNED
    1. octopus, releng to work with the design teams to establish a resource plan for stable handling port Brahmaputra 2.0
    2. octopus, releng to document stable branch handling and labeling for stable/brahmaputra on the release wiki


People present (lines said)

  1. ChrisPriceAB (41)
  2. rpaik (14)
  3. dneary (4)
  4. collabot` (4)
  5. Julien-zte (3)
  6. fdegir (3)
  7. uli-k_ (3)
  8. cgoncalves (2)
  9. ildikov (2)
  10. GeraldK (1)
  11. TapioT (1)
  12. jose_lausuch (1)
  13. morgan_orange (1)
  14. bin_ (1)
  15. edgarstp (1)
  16. trevor_intel1 (1)


Generated by MeetBot 0.1.4.