#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:33 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 13:59:39)
    1. Chris Price (ChrisPriceAB, 13:59:44)
    2. Uli Kleber (uli-k_, 13:59:46)
    3. Gerald Kunzmann (GeraldK, 13:59:46)
    4. Jonas Arndt (JonasArndt, 14:00:15)
    5. Frank Brockners (frankbrockners, 14:01:00)
    6. Brian Skerry (bjskerry, 14:02:55)
    7. Edgar StPierre (edgarstp, 14:04:03)
    8. Tapio Tallgren (ttallgren, 14:04:08)

  2. Approval of previous minutes (ChrisPriceAB, 14:05:02)
    1. https://wiki.opnfv.org/wiki/tsc#march_8_2016 previous meeting minutes (ChrisPriceAB, 14:05:08)
    2. minutes approved (ChrisPriceAB, 14:05:13)

  3. Agenda Bashing (ChrisPriceAB, 14:05:18)
    1. https://wiki.opnfv.org/wiki/tsc#march_15_2016 current agenda (ChrisPriceAB, 14:05:33)
    2. Tim Irnich (timirnich, 14:05:52)
    3. chris proposes some agenda shuffling, to do the creation reviews first, followed by the IETF update and then follow the rest of the agenda (ChrisPriceAB, 14:06:55)
    4. Dirk Kutscher (dku, 14:07:01)
    5. proposal to timebox both project creation reviews (GeraldK, 14:07:22)

  4. Project creation review - OpenSAF (ChrisPriceAB, 14:07:24)
    1. https://wiki.opnfv.org/opensaf opensaf project proposal (ChrisPriceAB, 14:07:53)
    2. Bryan Sullivan (bryan_att, 14:08:36)
    3. dneary (dneary, 14:08:49)
    4. Julien (Julien-zte, 14:09:02)
    5. Ryota Mibu (proxy Dirk) (r-mibu_, 14:09:17)
    6. Jonas outlines the history of the opensaf project (ChrisPriceAB, 14:09:30)
    7. has been focused on implementing the SAF specification (ChrisPriceAB, 14:09:43)
    8. has more recently turned to investingating and implementing requirements for virtual environemtns (ChrisPriceAB, 14:10:14)
    9. the opensaf project focus is to help applications achieve 5x9 availbility (ChrisPriceAB, 14:11:02)
    10. edgar asks if opensaf supports other environments other than carrier/telco communities (ChrisPriceAB, 14:11:53)
    11. JOnas answers that the focus is on carrier networking, however the project also addresses military applications as well (ChrisPriceAB, 14:12:25)
    12. edgar assk if opensaf would exclusively address OPNFV environments (ChrisPriceAB, 14:13:00)
    13. jonas answers that they will continue to support existing users while working with OPNFV for virtual environments (ChrisPriceAB, 14:13:33)
    14. bryan assk is OpenSAF will exist as a foundation outisde of OPNFV. (ChrisPriceAB, 14:14:10)
    15. Jonas answers that the upstream foundation will dissolve (ChrisPriceAB, 14:14:56)
    16. Jonas describes that the license will switch from LGPL to Apache after the April release (ChrisPriceAB, 14:16:29)
    17. frankbrockners asks how the license will be changed. (ChrisPriceAB, 14:17:12)
    18. Jonas answered that the OpenSAF foundation is the sole owner of the copywright and has the right o change the license. (ChrisPriceAB, 14:17:54)
    19. I would think legal concerns need to be addressed by Linux Foundation lawyers and opinion communicated clearly back to us. (edgarstp, 14:21:28)
    20. A key question is to the governance of the foundation, and whether the agreement of the contributors survives the foundation. We have not had a chance to review the governance. (bryan_att, 14:22:36)
    21. Chris, we need to also provide our legal opinion so need time for our legal staff to review this as well. (bryan_att, 14:23:28)
    22. ACTION: rpaik to discuss licensing question with the LF legal team (rpaik, 14:23:44)
    23. The primary concern I have is whether OPNFV is designed to support "owning" platform code rather than integrating it. If the code base remains in some upstream community, then integrating the code in OPNFV is similar to other projects. (bryan_att, 14:25:08)
    24. ACTION: dneary to start the discussion on the mailing list on hosting code development project in OPNFV (rpaik, 14:25:41)
    25. The thread on the appropriateness has already occurred. (bryan_att, 14:25:48)
    26. ACTION: rpaik to get a statement from the LinuxFoundation legal team on the license issue identified. (ChrisPriceAB, 14:26:37)
    27. review postponed until next week (ChrisPriceAB, 14:26:49)

  5. Project creation review NFV readiness (ChrisPriceAB, 14:27:06)
    1. https://wiki.opnfv.org/project_proposals/nfvreadyness project proposal (ChrisPriceAB, 14:27:21)
    2. There has been substantial discussion on that point, and even if we did integrate this project in OPNFV the license issue, including provenance of the code prior to relicensing, and the obligations to anyone other than the OpenSAF Foundation, would be key remaining concerns if the code was "owned" by OPNFV. (bryan_att, 14:27:22)
    3. Georg outlines the intention of this project is to work with upstream communities to evaluate NFV use cases in the context of cloud networking. (ChrisPriceAB, 14:28:19)
    4. We also need copies/links to the OpenSAF governance documents so we can do a proper legal review ("we" meaning AT&T legal staff) (bryan_att, 14:29:14)
    5. the project intends to focus on requirements and deployment validation and will perform coding activities in the context of the existing upstream communities. (ChrisPriceAB, 14:29:18)
    6. the project will ensure the work of the project fits into the openstack environment. (ChrisPriceAB, 14:31:18)
    7. the proposal has been on the community review meeting on two occasions with good discussion and feedback. (ChrisPriceAB, 14:32:00)
    8. dnaery asks if there is any reason the project cannot exist in other projects (ChrisPriceAB, 14:32:24)
    9. Georg answers that the first phase of the project is on use cases analysis, not focused on existing project scopes. (ChrisPriceAB, 14:33:00)
    10. Georg also answers that this project may propose new solutions to some use cases that deviates from other projects (ChrisPriceAB, 14:33:40)
    11. GeraldK asks if the wide scope of the project makes it unclear on what the project might actually do in OPNFV. (ChrisPriceAB, 14:34:39)
    12. Georg outlines the goal is to look at future needs and opportunities. (ChrisPriceAB, 14:35:46)
    13. dneary asks where the limits are for the project, for the TSC to approve an understandable scope. (ChrisPriceAB, 14:37:07)
    14. prakash answers that the projects intends to look at networking requirements in a variety of use cases. (ChrisPriceAB, 14:37:48)
    15. dneary do you mean to focus the scope to gap analysis between opnfv and openstack neutron and collect requirements for neutron? (Julien-zte, 14:46:52)
    16. the TSC feeds back that name change would be helpful to better define the project. (ChrisPriceAB, 14:47:07)
    17. ACTION: georg to propose on the TSC mailng list (ChrisPriceAB, 14:47:19)
    18. I miss the final decisions for the network issue. (Julien-zte, 14:48:10)
    19. dneary requests that the vote be postponed until the name and scope have been discussed further. (ChrisPriceAB, 14:49:06)

  6. IETF 95 - Hackfest (ChrisPriceAB, 14:49:23)
    1. Charles Eckel gives an oveview of IETF and their new focus on code via Hackathons (rpaik, 14:50:43)
    2. Charles outlines the mission of the IETF to be more involved with OpenSource communities (ChrisPriceAB, 14:50:48)
    3. Charles has been running Hack-Fest activities at the IETF to bring developers and standards engineers together (ChrisPriceAB, 14:51:27)
    4. Charles invites the OPNFV community to join the Hackathon at IETF in Buenes Aires (ChrisPriceAB, 14:51:50)
    5. the hackathon is free for community members to attend. (ChrisPriceAB, 14:52:15)
    6. OPNFV is also sponsoring Bit’sNBites at the upcoming IETF (rpaik, 14:52:22)
    7. http://www.ietf.org/hackathon/ (GeraldK, 14:55:01)
    8. in addition there will be hackathons at the IETF in Berlin in July (ChrisPriceAB, 14:56:54)

  7. Marketing update - Brandon (ChrisPriceAB, 14:58:20)
    1. Brandon outlines there is OPNFV content at the ONS that can be found on the web site (ChrisPriceAB, 14:58:49)
    2. the Plugfest site is now available on the web as well including registration (ChrisPriceAB, 14:59:05)
    3. CFP for the OPNFV Summit in Berlin is open and urges the community get proposals in for the event. (ChrisPriceAB, 14:59:30)
    4. http://www.meetup.com/pro/opnfv/ OPNFV Meetup page (rpaik, 14:59:48)
    5. there was recently an OPNFV meet-up in Shanghai (ChrisPriceAB, 14:59:56)
    6. an account has been made where OPNFV members can create local meet-up's for their community for OPNFV. (ChrisPriceAB, 15:00:18)
    7. the meet-up tool is available to all our community members (ChrisPriceAB, 15:00:34)
    8. If you have interest or questions in IETF hackathon, contant Charles Eckel eckelcu@cisco.com (rpaik, 15:01:19)


Meeting ended at 15:01:48 UTC (full logs).

Action items

  1. rpaik to discuss licensing question with the LF legal team
  2. dneary to start the discussion on the mailing list on hosting code development project in OPNFV
  3. rpaik to get a statement from the LinuxFoundation legal team on the license issue identified.
  4. georg to propose on the TSC mailng list


Action items, by person

  1. dneary
    1. dneary to start the discussion on the mailing list on hosting code development project in OPNFV
  2. rpaik
    1. rpaik to discuss licensing question with the LF legal team
    2. rpaik to get a statement from the LinuxFoundation legal team on the license issue identified.


People present (lines said)

  1. ChrisPriceAB (65)
  2. dneary (10)
  3. TomNadeau (9)
  4. bryan_att (9)
  5. rpaik (9)
  6. GeraldK (8)
  7. collabot` (5)
  8. uli-k_ (4)
  9. Julien-zte (3)
  10. edgarstp (3)
  11. B_Smith_ (2)
  12. dku (1)
  13. r-mibu_ (1)
  14. frankbrockners (1)
  15. timirnich (1)
  16. ttallgren (1)
  17. JonasArndt (1)
  18. bjskerry (1)


Generated by MeetBot 0.1.4.