#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:01:17 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 14:01:25)
    1. Chris Price (ChrisPriceAB, 14:01:30)
    2. Julien (Julien-zte, 14:01:36)
    3. Jonas Arndt (JonasArndt, 14:01:44)
    4. Gerald Kunzmann (DOCOMO) (GeraldK, 14:01:45)
    5. Uli Kleber (uli-k, 14:01:47)
    6. Dirk Kutscher (dku, 14:01:54)
    7. Bryan Sullivan (bryan_att, 14:02:11)
    8. Mark Beierl - proxy for Edgar StPierre (mbeierl, 14:02:33)
    9. Dave Neary (dneary, 14:02:40)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:02:59)
    1. Frank Brockners (frankbrockners, 14:03:03)
    2. https://wiki.opnfv.org/display/meetings/TSC#TSC-April12,2016 previous minutes (ChrisPriceAB, 14:03:10)
    3. no comments received minutes approved. (ChrisPriceAB, 14:03:22)

  3. Agenda Bashing (ChrisPriceAB, 14:03:27)
    1. https://wiki.opnfv.org/display/meetings/TSC current agenda (ChrisPriceAB, 14:03:43)
    2. no topics added (ChrisPriceAB, 14:04:49)
    3. Brian Skerry (bjskerry, 14:05:14)

  4. Board meeting report out (ChrisPriceAB, 14:05:35)
    1. rprakash (rprakash, 14:07:18)
    2. chris outlines the content of the board call according to the e-mail provided by anthony (ChrisPriceAB, 14:09:35)
    3. Prodeep provides and update on discussions at the board around our technical goverenance and area for potential improvement. (ChrisPriceAB, 14:10:08)
    4. Tapio Tallgren (TapioT, 14:10:40)
    5. https://wiki.opnfv.org/download/attachments/2925933/OPNFV%20technical%20governance%20proposal%20April2016.pdf?version=2&modificationDate=1461072621038&api=v2 slides outlining areas for discussion and potential improvement (ChrisPriceAB, 14:10:46)
    6. Prodip outlines some of the areas where OPNFV is unique in the industry and areas where OPNFV may be suited to take a leadership role across some areas of NFV. (ChrisPriceAB, 14:12:09)
    7. He proposes the question of if we are doing as much as we could, or should, and is our structure helping us achieve those goals. (ChrisPriceAB, 14:12:50)
    8. Prodip also outlines a desire to have a merit based approach to OPNFV and if we are doing as much as we can to reward and promote those who are contributing strongly to our community. (ChrisPriceAB, 14:13:57)
    9. Prodip also states that the TSC and community has outperfomed many peoples expectations and the rational for change is to promote improvements in the community rather than question if our community is functional as it stands. (ChrisPriceAB, 14:14:59)
    10. Prodip shows a slide that outlines some feedback received on our community structure as it is structured. (ChrisPriceAB, 14:16:01)
    11. Prodip asks for feedback form the TSC and community on the topics raised and if we can improve our technical structure and governance. (ChrisPriceAB, 14:18:20)
    12. the intention is to gather feedback from the community and identify if any improvements can be made according to the needs of our constituency. (ChrisPriceAB, 14:19:00)
    13. Bryan asks what process has been used for gathering feedback, Prodip responds that the feedback has been provided independantly. Thus the intention to get a broader set of feedback on these topics. (ChrisPriceAB, 14:19:55)
    14. Bryan asks if industry leadership can be better defined. Prodip outlines the breadth of activities in MANO and Forwarding etc where the Board believes OPNFV can play a role in resolving/coordinating industry activities of this nature. OPNFV may be able to be better structured to broker these types of discussions. (ChrisPriceAB, 14:21:57)
    15. Prodip notes that NFV industry leadership is desired to broker architectural discussions within OPNFV (rpaik, 14:22:31)
    16. Bryan also asks about the issues with the meritocratic nature of OPNFV. The answer is that many open source communities have elected committee's rather than elected committee's which may include a transitional phase or establishment as elected committee's. (ChrisPriceAB, 14:23:55)
    17. Margaret also added that having merit-based TSC could also attract more developers (rpaik, 14:26:16)
    18. Bryan adds that even if we move toward a meritocratic structure there needs to be a clear plan and migration activity toward such a structure. (ChrisPriceAB, 14:26:56)
    19. The presentation will also be sent out to mailing lists (rpaik, 14:30:01)
    20. will also continue the conversations in future calls (rpaik, 14:30:29)

  5. brahmaputra.3.0 update (ChrisPriceAB, 14:30:34)
    1. B.3.0 is on track for labelling at the end of this month. (ChrisPriceAB, 14:31:07)
    2. scenario freeze is due this week accroding to the timeplan. (ChrisPriceAB, 14:31:21)
    3. Frankbrockners asks if there’s a plan for another dot release in May. ChrisPriceAB notes that it looks like most scenarios will make the 3.0 release but can have nother conversation next week (rpaik, 14:33:01)

  6. Colorado planning and activities (ChrisPriceAB, 14:33:04)
    1. Milestone discussions continue in the community capturing the feedback from Brahmaputra (ChrisPriceAB, 14:33:54)
    2. the intention is to have more granular milestones that better capture the development flow toward the release. (ChrisPriceAB, 14:34:14)
    3. scenario discussions and planning is another key topic of discussion across the community in some seperate meetings focused on those items (ChrisPriceAB, 14:34:44)
    4. the community has agreed to roll the scenario and release planning project discussions back into the weekly release meetings (ChrisPriceAB, 14:35:13)
    5. scernario's and scenario owners have been captured on the wiki (ChrisPriceAB, 14:35:48)
    6. *draft* view of scenario inventory: https://wiki.opnfv.org/display/SWREL/Colorado+scenario+inventory+and+dependencies (frankbrockners, 14:36:03)
    7. we are behind on some of our early milestones although catching up and bringing our activities into alignment for Colorado overall. (ChrisPriceAB, 14:36:55)
    8. GeraldK asks if there is an updated timeline available, dmcbride answers that we are close to producing an updated schedule. (ChrisPriceAB, 14:38:11)
    9. There was also a discussion on release candence/interval amongst Board members in Beijing (as there was a lot of stress on the community to meet the 6-month cadence) (rpaik, 14:40:36)
    10. Brian adds that the cadence in his view is not the issue, our processes and activities should maybe be evaluated to limit the effort of addressing the release activity. (ChrisPriceAB, 14:41:55)
    11. dneary adds that he thinks the value of the community is not in the releases we produce (ChrisPriceAB, 14:42:29)
    12. Margaret encourages the technical community to provide feedback/recommendation to the Board on release cadence (rpaik, 14:45:31)
    13. ACTION: ChrisPriceAB will start a discussion on the mailing reg. release cadence (rpaik, 14:48:50)
    14. process discussion can take place during dmcbride’s weekly Colorado releace meetings (rpaik, 14:49:30)
    15. ACTION: dneary to start a email conversation on whether we do releases (rpaik, 14:50:17)

  7. Upcoming Events and planning (ChrisPriceAB, 14:50:32)
    1. https://wiki.opnfv.org/display/EVNT list of technical community events (rpaik, 14:50:48)
    2. an e-mail will be sent out to the community outlining our OPNFV rleated activities at OpenStack (ChrisPriceAB, 14:51:58)
    3. there will be a Telco track on Wed-Thu during OpenStack Summit next week (rpaik, 14:52:15)
    4. Highlights include, booth crawl Monday night at the OPNFV booth, Tuersday night "stack city" includes OPNFV as a premier sponsor and a sponsored location on the street., (ChrisPriceAB, 14:53:02)
    5. The plugfest is planned for the second week or May. (ChrisPriceAB, 14:53:36)
    6. OPNFV Summit in Berlin is being planned, our design summit planning will kick off next week. (ChrisPriceAB, 14:54:02)
    7. rpaik will update the H2, 2016 events page shortly. (ChrisPriceAB, 14:54:21)
    8. OPNFV Summit code for member companies: OPNFVMEM16 (rpaik, 14:55:36)
    9. looking for volunteers to help program the Design Summit in Berlin (rpaik, 14:56:41)

  8. Community metrics (ChrisPriceAB, 14:56:57)
    1. dneary outlines the community metrics initiative should be driven by a set of outcomes and wanted answers/questions that can help define the metrics we would propose. (ChrisPriceAB, 14:58:03)
    2. http://lists.opnfv.org/pipermail/opnfv-tsc/2016-April/002494.html Dave’s discussion on the topic (rpaik, 14:59:22)
    3. There is an interest from openstack to capture NFV metrics which we could leverage to achieve our own goals. (ChrisPriceAB, 14:59:25)
    4. ACTION: dneary to see if it is possible to set up a meeting with the openstack community next week at the summit (ChrisPriceAB, 15:01:30)


Meeting ended at 15:01:38 UTC (full logs).

Action items

  1. ChrisPriceAB will start a discussion on the mailing reg. release cadence
  2. dneary to start a email conversation on whether we do releases
  3. dneary to see if it is possible to set up a meeting with the openstack community next week at the summit


Action items, by person

  1. ChrisPriceAB
    1. ChrisPriceAB will start a discussion on the mailing reg. release cadence
  2. dneary
    1. dneary to start a email conversation on whether we do releases
    2. dneary to see if it is possible to set up a meeting with the openstack community next week at the summit


People present (lines said)

  1. ChrisPriceAB (59)
  2. rpaik (16)
  3. bryan_att (13)
  4. dneary (8)
  5. collabot (5)
  6. frankbrockners (3)
  7. GeraldK (2)
  8. dku (1)
  9. rprakash (1)
  10. Julien-zte (1)
  11. TapioT (1)
  12. JonasArndt (1)
  13. uli-k (1)
  14. bjskerry (1)
  15. mbeierl (1)


Generated by MeetBot 0.1.4.