#opnfv-meeting: test weekly meeting April 14th

Meeting started by morgan_orange at 14:00:50 UTC (full logs).

Meeting summary

    1. Jose Lausuch (jose_lausuch, 14:01:08)
    2. Ana Cunha (anac1, 14:01:20)
    3. Jack Morgan (jmorgan1, 14:01:45)
    4. Trevor Cooper (trevor_intel1, 14:02:12)
    5. Yaoguang Wang (YaoguangWang, 14:02:13)

  1. Test Release Criteria (jose_lausuch, 14:02:52)
    1. https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria (jose_lausuch, 14:03:05)
    2. 6 Test projects for Colorado (morgan_orange, 14:07:01)
    3. Functest, Yardstick, Storperf, bottlenecks, cperf, vsperf (morgan_orange, 14:07:27)
    4. Morgan explains what we have done for Functest, the other projects can fill the columns in a different manner according to their needs (jose_lausuch, 14:10:22)
    5. Functest needs input from some feature projects to align with integration support --> template will be provided for test projects in order to provide information about tools/framework and useful information (jose_lausuch, 14:12:37)
    6. Functest suggestion: our long tests (Rally, TEmpest full suite, vIMS) not to be part of the release criteria (and the daily) since it will take too much CI time & resources (jose_lausuch, 14:14:17)
    7. expectations are: 2 ci pods / installer (jose_lausuch, 14:25:02)
    8. number of scenarios still unknown (jose_lausuch, 14:25:20)
    9. functest to reduce the CI time to 1h (jose_lausuch, 14:25:50)
    10. jmorgan1 points out that we should know (document) how much resources we are going to need once we stablish the release criteria and run the decided test cases daily on CI (jose_lausuch, 14:26:40)
    11. for example: subset of tests from vsperf project to be integrated in yardstick, and run daily on CI PODs. The long duration tests will be still run and delivered in Colorado, but they will be the responsible for those tests to be run on non-CI PODs (jose_lausuch, 14:34:26)
    12. vsperf will be run within yardstick (1h) and as standalone (like in Brahmaputra) (morgan_orange, 14:38:06)
    13. yardstick ~ 1h for daily job (morgan_orange, 14:38:21)
    14. https://wiki.opnfv.org/display/SWREL/Colorado+Testing+-+Discussion+and+Proposals (trevor_intel1, 14:38:27)
    15. ACTION: YaoguangWang mbeierl dfarrell07 anac1 complete the tables for CI resources (morgan_orange, 14:42:13)
    16. Allocation of PODs for CI are here https://wiki.opnfv.org/display/INF/Pharos+Labs (trevor_intel1, 14:43:17)
    17. https://wiki.opnfv.org/display/SWREL/Colorado+Testing+-+Discussion+and+Proposals#ColoradoTesting-DiscussionandProposals-MatrixofTestprojectsversusPharoslabs (jose_lausuch, 14:43:36)


Meeting ended at 15:08:12 UTC (full logs).

Action items

  1. YaoguangWang mbeierl dfarrell07 anac1 complete the tables for CI resources


Action items, by person

  1. anac1
    1. YaoguangWang mbeierl dfarrell07 anac1 complete the tables for CI resources
  2. YaoguangWang
    1. YaoguangWang mbeierl dfarrell07 anac1 complete the tables for CI resources


People present (lines said)

  1. jose_lausuch (15)
  2. morgan_orange (8)
  3. collabot` (4)
  4. trevor_intel1 (3)
  5. jmorgan1 (2)
  6. anac1 (1)
  7. YaoguangWang (1)
  8. trevor_intel (0)


Generated by MeetBot 0.1.4.