#opnfv-meeting: OPNFV TSC

Meeting started by rpaik at 06:00:15 UTC (full logs).

Meeting summary

    1. Ashiq Khan (Ashiq_Khan, 06:01:06)
    2. Gergely Csatari (csatari, 06:01:17)
    3. Chris Price (ChrisPriceAB, 06:01:29)

  1. Roll Call (ChrisPriceAB, 06:02:15)
    1. Chris Price (ChrisPriceAB, 06:02:20)
    2. Tapio Tallgren (ttallgren, 06:02:31)

  2. Approval of the previous minutes of meeting (ChrisPriceAB, 06:02:52)
    1. Edgar StPierre (edgarstp, 06:02:52)
    2. Bryan Sullivan (bryan_att, 06:03:03)
    3. Ashiq Khan (Ashiq_Khan, 06:03:06)
    4. https://wiki.opnfv.org/display/meetings/TSC#TSC-June14,2016 previous minutes of meeting (ChrisPriceAB, 06:03:20)
    5. Frank Brockners (frankbrockners, 06:03:28)
    6. no comments received minutes approved (ChrisPriceAB, 06:03:32)
    7. Stuart Mackie (StuartMackie, 06:03:40)

  3. Agenda Bashing (ChrisPriceAB, 06:03:41)
    1. Jonas Arndt (JonasArndt, 06:03:47)
    2. https://global.gotomeeting.com/join/798898261 (csatari, 06:04:11)

  4. Update on the TSC Charter to reflect the OPNFV Code of Conduct (ChrisPriceAB, 06:05:01)
    1. rpaik outlines the code of conduct updated proposed to the board have been approved. (ChrisPriceAB, 06:05:22)
    2. https://wiki.opnfv.org/download/attachments/2925933/TSC%20Charter%20May%2031-2016%20v2.pdf?version=1&modificationDate=1466094997000&api=v2 (ChrisPriceAB, 06:05:35)
    3. AGREED: rpaik will update the www.opnfv.org page accodingly (ChrisPriceAB, 06:05:47)

  5. Report out from the Design Summit (ChrisPriceAB, 06:06:02)
    1. Uli Kleber (ulik, 06:06:21)
    2. rpaik outlines that our design summit included over 300 people on day 1. (ChrisPriceAB, 06:06:36)
    3. today there will be a number of colocated events during the day with other communities (ChrisPriceAB, 06:06:58)
    4. Julien (Julien-zte, 06:07:07)

  6. Q3 hackfest planning (ChrisPriceAB, 06:09:31)
    1. rpaik now that the second plugfest date has been determined in december our planning for hackfests is coalescing to a needed decision around our Q3 event (ChrisPriceAB, 06:10:09)
    2. two good options are the LinuxCon north america or OpenDaylight summit (ChrisPriceAB, 06:10:34)
    3. rpaik indicates LinuxCon would be a good option for the hackfest, where we would potentially run a meetup at the OpenDaylight summit (ChrisPriceAB, 06:11:13)
    4. Trevor Cooper (trevor_intel_, 06:12:23)
    5. bjskerry notes that LinxuCon NA is about a month before the scheduled Colorado release date (rpaik, 06:13:47)
    6. AGREED: the TSC agrees to pursue the Q3 hackfest at LinuxCon Toronto. (ChrisPriceAB, 06:14:17)

  7. Colorado planning and activities (ChrisPriceAB, 06:14:35)
    1. dmcbride has been working with the infrastructure team at the summit to work thorugh release considerations. (ChrisPriceAB, 06:15:17)
    2. the team has identified challenges related to support of the armband project however in general infra is looking good for Colorado. (ChrisPriceAB, 06:16:14)
    3. An ARM POD will be established during August to support ArmBand. (ChrisPriceAB, 06:17:32)

  8. MANO working group discussion (ChrisPriceAB, 06:17:44)
    1. ChrisPriceAB notes that the MANO working group could be looking at things like common interfaces (rpaik, 06:19:38)
    2. the working group can also work on cross coordination (rpaik, 06:20:09)
    3. prakash outlines the discussion around MANO in relation to the project focusing on the integration of Open-O. (ChrisPriceAB, 06:21:50)
    4. prakash reflects on the challenge of achieving standards compliance across interfaces in open source projects. (ChrisPriceAB, 06:22:41)
    5. AGREED: the TSC agrees that the establishment of a MANO working group is a good idea and supports it. (ChrisPriceAB, 06:24:16)
    6. disccussion that existing working groups (e.g. security, infra, testing) in OPNFV do not have formal charters (rpaik, 06:26:39)
    7. dneary (dneary, 06:27:49)
    8. ACTION: prakash to raise the working group for discussion on the TWS and a time shall be set for the calls. (ChrisPriceAB, 06:29:02)

  9. Joint TSC Board meeting preparation (ChrisPriceAB, 06:29:16)
    1. dmcbride has prepared material for the meeting. (ChrisPriceAB, 06:30:43)
    2. ACTION: dmcbride to distribute the material and TSC members to comment. (ChrisPriceAB, 06:31:09)
    3. uli-k outlines the SPC joint session is being discussed, the SPC goals will be shared openly now prior to the call. (ChrisPriceAB, 06:32:54)
    4. ACTION: rpaik to complete the Bitergia roadmap slides with dneary and also send out to the TSC mailing list (rpaik, 06:33:28)
    5. the SPC has an interest to form a working group to address long term planning and community themes (ChrisPriceAB, 06:34:37)
    6. to be discussed further at the Board/TSC f2f (ChrisPriceAB, 06:34:51)

  10. TSC Governance discussion for the joint Board-TSC meeting (ChrisPriceAB, 06:35:23)
    1. ChrisPriceAB discusses feedback on the TSC composition (e.g. improve the meritocratic nature of the TSC) (rpaik, 06:37:56)
    2. TSC constitution discussion includes maintain the current setup (with committer at large); migrate to an elected TSC; migrate to a fullt merit-based TSC (rpaik, 06:39:33)
    3. frankbrockners notes that there maybe a potentential tradeoff that we need to consider when Platinum members do not automatically get a TSC seat (rpaik, 06:48:06)
    4. dneary asked whether this discussion was the board asking the TSC to change, the TSC asking the board to recommend a structure change, or the TSC informing the board of how we decide to change (dneary, 06:48:25)
    5. ChrisPriceAB says it could be any of the three, right now the board has flagged the concern that the TSC (and project) is perceived as pay-to-play (dneary, 06:49:05)
    6. dneary asked what "suits our needs" means, and what were the trade-offs which would prevent us going to a fully elected-from-community TSC (dneary, 06:49:49)
    7. Several replies - a TSC seat is one of the carrots we "sell" when getting Platinum members to pay; it has been useful to have designates to ensure that there is a communication channel from the community (TSC and projects) into the members (dneary, 06:51:19)
    8. ulik asks how it would work in practice - who would vote/choose TSC members? (dneary, 06:51:50)
    9. Is there a concern about TSC size? The main issue is achieving quorum. (dneary, 06:55:54)
    10. If we have elected membership delegates, we should ensure other membership classes are represented. (dneary, 06:57:18)
    11. The by-laws allow the TSC to have committers elected to the TSC (dneary, 06:58:04)
    12. if we can get a breakout room, we could have further discussions prior to the Board meeting (rpaik, 07:00:00)


Meeting ended at 07:00:13 UTC (full logs).

Action items

  1. prakash to raise the working group for discussion on the TWS and a time shall be set for the calls.
  2. dmcbride to distribute the material and TSC members to comment.
  3. rpaik to complete the Bitergia roadmap slides with dneary and also send out to the TSC mailing list


Action items, by person

  1. dneary
    1. rpaik to complete the Bitergia roadmap slides with dneary and also send out to the TSC mailing list
  2. rpaik
    1. rpaik to complete the Bitergia roadmap slides with dneary and also send out to the TSC mailing list
  3. UNASSIGNED
    1. prakash to raise the working group for discussion on the TWS and a time shall be set for the calls.
    2. dmcbride to distribute the material and TSC members to comment.


People present (lines said)

  1. ChrisPriceAB (36)
  2. dneary (18)
  3. bryan_att (17)
  4. rpaik (13)
  5. collabot (5)
  6. csatari (3)
  7. ttallgren (2)
  8. ulik (2)
  9. Ashiq_Khan (2)
  10. frankbrockners (1)
  11. trevor_intel_ (1)
  12. Julien-zte (1)
  13. StuartMackie (1)
  14. edgarstp (1)
  15. JonasArndt (1)


Generated by MeetBot 0.1.4.