#opnfv-meeting: OPNFV TSC Meeting

Meeting started by ChrisPriceAB at 13:59:34 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 13:59:40)
    1. dneary (dneary, 13:59:47)
    2. Chris Price (ChrisPriceAB, 13:59:55)
    3. Cecilia Corbi (Ceciliacorbi, 14:00:20)
    4. Juha Oravainen (proxy for Tapio Tallgren) (juhao, 14:00:26)
    5. Julien (Julien-zte, 14:00:29)
    6. Uli Kleiber (on the phone) (ChrisPriceAB, 14:00:32)
    7. Jack Morgan (proxy for Brian Skerry) (jmorgan1, 14:00:40)
    8. Frank Brockners (frankbrockners, 14:01:13)
    9. Mark Gray (mdgray_, 14:01:56)
    10. rprakash (rprakash, 14:02:06)

  2. Previous meeting minutes (ChrisPriceAB, 14:02:07)
    1. to be postponed until next TSC call. (ChrisPriceAB, 14:02:28)
    2. Stuart Mackie (StuartMackie, 14:02:34)

  3. Agenda Bashing (ChrisPriceAB, 14:02:36)
    1. https://wiki.opnfv.org/display/meetings/TSC current agenda (ChrisPriceAB, 14:02:46)
    2. uli-k would like to add the topic of the OpenStack operators NFV working group. (ChrisPriceAB, 14:04:57)
    3. GeraldK would like to raise the Colorado test freeze date as a topic to discuss (ChrisPriceAB, 14:05:28)
    4. Gerald Kunzmann (GeraldK, 14:05:29)

  4. OPNFV CI development/evolution (ChrisPriceAB, 14:06:45)
    1. https://wiki.opnfv.org/display/INF/CI+Evolution plans to update our methodology for CI (ChrisPriceAB, 14:07:08)
    2. https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-HowtheThingsFitTogether (fdegir, 14:07:14)
    3. https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-HowtheThingsFitTogether a diagram of reference for Fatih's discussion. (ChrisPriceAB, 14:07:48)
    4. fdegir outlines the challenge of scale when handling multiple scenarios and multiple labs in our CI pipeline. Our activities continue to grow release over release and some adjustment is needed in CI to accomodate that growth. (ChrisPriceAB, 14:08:54)
    5. Mark Beierl (Proxy for Edgar Stpierre) (mbeierl, 14:09:11)
    6. fdegir outlines the challenge of resource allocation and the opportunities we have to validate scenario's on virtual environments prior to utilising bare metal labs (ChrisPriceAB, 14:09:55)
    7. Bryan Sullivan (bryan_att, 14:10:03)
    8. fdegir outlines the challenges we have with test case stability, troubleshooting, and system stability with our current methodology. Indicating a staged approach to validation of scenario's can aid in identifying where faults may occur. (ChrisPriceAB, 14:11:23)
    9. the main purpose of these changes is to increase the speed with which the CI system can provide feedback to designers on their work. (ChrisPriceAB, 14:12:04)
    10. Carlos Goncalves (cgoncalves, 14:14:39)
    11. it's different for a developer to set the scenarios affected and installers (Julien-zte, 14:17:10)
    12. fdegir outlines that it should be possible that a committer can request to deploy or not to deploy the scenario based on the commit message. (ChrisPriceAB, 14:17:22)
    13. GeraldK outlines the challenges involved in delaying some test cases for one week after a patch is pushed (ChrisPriceAB, 14:19:17)
    14. fdegir and geraldk both think pushing significant changes on our development environment during the least months of Colorado could be risky, and that the majority of impacting changes should be done earl in the D-River cycle. (ChrisPriceAB, 14:22:11)
    15. the current target is to get commit gating in place during Colorado (ChrisPriceAB, 14:22:26)
    16. uli-k asks that the commit message changes be well communicated to the community (ChrisPriceAB, 14:23:23)
    17. uli-k and fdegir forsee little to no risk to Colorado by introducing the commit gating process and commit messaging (ChrisPriceAB, 14:24:14)
    18. The current plan by the infra team is to implement phase 1 (commit gating) prior to the Colorado release, and the further scenario staging and testing processes after the Colorado release. (ChrisPriceAB, 14:26:16)
    19. julien outlines the potential challenge of resource scheduling with this approach. (ChrisPriceAB, 14:28:36)

  5. Committer at large (CAL) elections to the TSC (ChrisPriceAB, 14:30:06)
    1. GeraldK asks about the use of the term committer at large in the context of the joining the TSC. (ChrisPriceAB, 14:32:44)
    2. in the discussion on whom should be able to run for a TSC position, there seems to be agreement among TSC members that the nominee's be restricted to committers. (ChrisPriceAB, 14:39:00)
    3. One potential concern is that committer status might not be a good proxy for activity - there are committers who are not active, and potentially very active non-committers (dneary, 14:43:31)
    4. frankbrockners states that it's theoretical, that an active contributor can easily becoime a committer (dneary, 14:44:00)
    5. but would the committer removal process that care of that, dneary ? (mbeierl, 14:44:10)
    6. at this time there is no concensus on whom would vote for the nominees (ChrisPriceAB, 14:45:45)
    7. ACTION: rpaik to poll for more information (ChrisPriceAB, 14:45:58)
    8. discussion on how many at large members we would want to have on our TSC. (ChrisPriceAB, 14:48:14)
    9. an option is to set a percentage of elected members as opposed to a given number. dneary adds that the committer at large member number should not be coupled to the number of platinum member seats. (ChrisPriceAB, 14:49:14)
    10. frankbrockners proposes 5 community members be added for the coming term. (ChrisPriceAB, 14:50:12)
    11. frankbrockners suggested that we can evaluate this, including seats, long every year. (Julien-zte, 14:51:19)
    12. Proxy for Edgar Stpierre (mbeierl, 14:51:55)
    13. VOTE: Voted on "Does the TSC agree to include 5 committer TSC seats for the 2016/2017 term?" Results are, 0: 2, +1: 10 (ChrisPriceAB, 14:52:14)
    14. proxy for Brian Skerry (jmorgan1, 14:52:24)
    15. Proxy for Edgar Stpierre (mbeierl, 14:53:33)
    16. proxy for Brian Skerry (jmorgan1, 14:53:47)
    17. VOTE: Voted on "Does the TSC agree to start the committer election process on the 8th of August?" Results are, 0: 3, +1: 10 (ChrisPriceAB, 14:53:53)

  6. Colorado planning and activities (ChrisPriceAB, 14:54:29)
    1. dcmcbride outlines that the feature freeze milestone was last friday, david has been in contact with the PTL's around status for this milestone (ChrisPriceAB, 14:55:04)
    2. the compass team is pending a merge for the installer freeze, this is being followed up regularly by david (ChrisPriceAB, 14:55:46)
    3. a number of projects that had expressed intent to participate in Colorado will not longer participate. (ChrisPriceAB, 14:56:50)
    4. These projects have withdrawn from Colorado; escalator, resource scheduler and policy test (ChrisPriceAB, 14:57:19)
    5. dmcbride outlines that some process should be put in place to better track projects participation and status (ChrisPriceAB, 14:58:03)
    6. geralk outlines some concerns with the test freeze date of this thursday as there are some test case development activities that may not make the date. (ChrisPriceAB, 14:58:52)
    7. dmcbride outlines the freeze date is for implementation it is not gating on test case success. (ChrisPriceAB, 14:59:26)
    8. ACTION: dmcbride to follow up on the colorado call (ChrisPriceAB, 15:00:38)


Meeting ended at 15:00:43 UTC (full logs).

Action items

  1. rpaik to poll for more information
  2. dmcbride to follow up on the colorado call


People present (lines said)

  1. ChrisPriceAB (53)
  2. dneary (15)
  3. collabot` (14)
  4. bryan_att (12)
  5. Julien-zte (10)
  6. jmorgan1 (10)
  7. mbeierl (9)
  8. fdegir (7)
  9. GeraldK (5)
  10. mdgray_ (5)
  11. cgoncalves (4)
  12. persia (4)
  13. juhao (3)
  14. frankbrockners (3)
  15. StuartMackie (3)
  16. uli-k_ (2)
  17. Ceciliacorbi (2)
  18. rprakash (1)


Generated by MeetBot 0.1.4.