#opnfv-meeting: Test and Performance Weekly Meeting

Meeting started by mbeierl at 13:58:58 UTC (full logs).

Meeting summary

  1. Roll Call (mbeierl, 13:59:09)
    1. Al Morton (acm, 13:59:25)
    2. Mark Beierl (mbeierl, 13:59:46)
    3. Mingjiang (Mingjiang5, 14:00:16)
    4. Yujun Zhang (yujunz, 14:01:00)
    5. David McBride (dmcbride, 14:01:20)
    6. kubi (kubi001, 14:01:25)
    7. https://global.gotomeeting.com/join/305553637 (mbeierl, 14:02:46)
    8. https://www.gotomeet.me/DavidMcBride (dmcbride, 14:06:27)
    9. https://global.gotomeeting.com/join/853047565 (Mingjiang5, 14:08:01)
    10. Maryam Tahhan (mtahhan, 14:08:43)

  2. agenda (acm, 14:09:52)
    1. ACTION: mark send time change e-mail (acm, 14:11:16)
    2. defer Alan Sardella' test paper to a future meeting (dfarrell07, 14:11:30)
    3. ACTION: mark send new GTM URL for future meetings while Trevor out (acm, 14:11:52)

  3. Yardstick test Scenarios (acm, 14:12:38)
    1. Yardstick talks about proposals for how we trigger tests from scenarios (dfarrell07, 14:14:24)
    2. Proposal would kick off more specific tests per-scenario (dfarrell07, 14:15:13)
    3. Info about how to change yardstick yaml config to do this new way of kicking off smaller sets of tests (dfarrell07, 14:17:02)
    4. this organization adds constraints on the test files (yaml) (acm, 14:19:31)
    5. planned for Colorado, work in progress. (acm, 14:20:00)
    6. examples of constraints include which installer is being run (dfarrell07, 14:20:19)
    7. Dave points out that we're past some relevant milestones for C, maybe should do in D (dfarrell07, 14:20:34)
    8. Dave, we are past the infra milestone for Colorado, consider for release D (acm, 14:20:42)
    9. Feedback that proposal is helpful, some +1s that it may be more approprate for D (dfarrell07, 14:21:41)
    10. Dave points out that we're in the stabilization phase, past infra update milestone, so changing infra this late in release is concern (dfarrell07, 14:22:51)
    11. Maryam, is this not more relevant to the test milestone? (acm, 14:23:00)
    12. Maryam points out that the milestone Dave was referencing is more about hardware infra, not tests (dfarrell07, 14:23:42)
    13. Dave, I take the point Kubi, change can take place in one week, not a big change (acm, 14:23:49)
    14. Mark, who takes responsibility to modify current test cases? (acm, 14:24:34)
    15. Kubi points out that existing tests are mostly generic, not specific to pods, so these constraint changes wouldn't touch them (dfarrell07, 14:25:05)
    16. Mingjiang5: Constraints are not implemented as part of this change (mbeierl, 14:27:54)
    17. Maryam, will commit gate be able to detect if this fails? (acm, 14:27:56)
    18. question from yujunz: are we going to leave constraint implementation to next release and implement only the convertion part? Since constraint is not defined yet and something is unpredictable (mbeierl, 14:29:05)
    19. This change should be limited to what yujunz cam complete in the next week (dmcbride, 14:29:24)
    20. Should not require any effort from project teams for release C (dmcbride, 14:29:50)
    21. #info This change should be limited to what Mingjiang5 cam complete in the next week (dmcbride, 14:30:47)
    22. Kubi answers Meryam that team wants to enhance commit gate to run real tests in virtual pod (dfarrell07, 14:32:02)
    23. Mark clarifies that question is "is there code level test for constraints, to see if they work before merge" (dfarrell07, 14:32:33)
    24. we should action Mingjiang5 to provide status at this meeting until change is completed (dmcbride, 14:32:49)
    25. Mark clarifies: is there a test on the constaint code, before it will be merged? (acm, 14:33:08)
    26. Yardstick Gerrit changes undergo unit tests, implication is that this would be covered (dfarrell07, 14:33:33)
    27. Kubi, yes we will test it , of course (acm, 14:33:52)
    28. Summery seems to be that this should go ahead, as long as it doesn't take a long time (week), doesn't require big changes from test projects, and status reported here until complete (dfarrell07, 14:34:45)
    29. Testing white paper topic deferred until next week (dfarrell07, 14:35:42)

  4. Time of meeting (dfarrell07, 14:35:48)
    1. Do we want to keep this time and add one? Move slot? (dfarrell07, 14:35:58)
    2. Kubi points out that there's a Asia/Eu testing meeting on Wed (dfarrell07, 14:36:50)
    3. Bi-weekly Wed 830UTC is the Asia/Eu meeting Kubi was talking about, it's on the wiki but apparently not many were actually attending (dfarrell07, 14:38:19)
    4. Do we want to restart that meeting? Yardstick gives +1, asks for feedback from others (dfarrell07, 14:38:45)
    5. suggestion from dfarrell07: have 1 meeting a month that is APAC friendly (mbeierl, 14:42:08)
    6. that is, to change the time for that one meeting (mbeierl, 14:42:27)
    7. would that be helpful for APAC members? (mbeierl, 14:42:49)
    8. Al Morton (acm, 14:42:53)
    9. dfarrell07 (Eastern Time) says he can suck it up and do one meeting a month at 4:30AM (dfarrell07, 14:43:07)
    10. dfarrell07 asks if there are people in APAC for which this would be helpful (dfarrell07, 14:43:17)
    11. meeting continues to be plagued with audio issues :( (dfarrell07, 14:43:44)
    12. dfarrell07 asks if there is anyone who wants a time change? (mbeierl, 14:45:35)
    13. ACTION: Mark to ask about meeting times in the summary e-mail (acm, 14:46:14)
    14. ACTION: mbeierl to send email to group asking if an APAC-friendly timezone meeting would be helpful, since of course the people here can make this time work (dfarrell07, 14:46:32)

  5. AoB? (mbeierl, 14:47:03)
    1. yujunz asks "Where can I find the table of meeting host?", mbeierl will add it to wiki (dfarrell07, 14:48:01)
    2. ACTION: mbeierl to add meeting chair/minutes info to wiki (dfarrell07, 14:48:34)


Meeting ended at 14:50:04 UTC (full logs).

Action items

  1. mark send time change e-mail
  2. mark send new GTM URL for future meetings while Trevor out
  3. Mark to ask about meeting times in the summary e-mail
  4. mbeierl to send email to group asking if an APAC-friendly timezone meeting would be helpful, since of course the people here can make this time work
  5. mbeierl to add meeting chair/minutes info to wiki


Action items, by person

  1. mbeierl
    1. mbeierl to send email to group asking if an APAC-friendly timezone meeting would be helpful, since of course the people here can make this time work
    2. mbeierl to add meeting chair/minutes info to wiki
  2. UNASSIGNED
    1. mark send time change e-mail
    2. mark send new GTM URL for future meetings while Trevor out
    3. Mark to ask about meeting times in the summary e-mail


People present (lines said)

  1. dfarrell07 (42)
  2. mbeierl (38)
  3. acm (21)
  4. dmcbride (16)
  5. yujunz (11)
  6. collabot (7)
  7. kubi001 (6)
  8. Mingjiang5 (4)
  9. mtahhan (3)
  10. steveg (2)
  11. makullbe (1)


Generated by MeetBot 0.1.4.