#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 14:00:30 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 14:00:33)
    1. Chris Price (ChrisPriceAB, 14:00:40)
    2. Uli Kleber (uli-k, 14:01:27)
    3. Jonas Arndt (JonasArndt, 14:01:37)
    4. Juha Oravainen (proxy for Tapio Tallgren) (juhao, 14:01:42)
    5. Brian skerry (bjskerry, 14:01:49)
    6. Bryan Sullivan (bryan_att, 14:01:57)
    7. Dave Neary (dneary, 14:02:11)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:03:09)
    1. rpaik has received some feedback regarding the agenda regarding a comment on Dovetail at the hackfest. Postponing to AoB for approval. (ChrisPriceAB, 14:03:46)

  3. Agenda Bashing (ChrisPriceAB, 14:04:05)
    1. Dirk Kutscher (dku, 14:04:15)
    2. https://wiki.opnfv.org/display/meetings/TSC current agenda (ChrisPriceAB, 14:04:21)
    3. no additional items mentioed (ChrisPriceAB, 14:05:20)

  4. approval of meeting minutes (ChrisPriceAB, 14:05:38)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-July19,2016 previous minutes (ChrisPriceAB, 14:06:06)
    2. AGREED: minutes approved from last week (ChrisPriceAB, 14:06:14)

  5. CII Badging update for OPNFV (ChrisPriceAB, 14:06:33)
    1. https://bestpractices.coreinfrastructure.org/projects/164 (Sona, 14:06:36)
    2. #link https://bestpractices.coreinfrastructure.org/projects/164 link to the badge program information page for OPNFV (ChrisPriceAB, 14:07:22)
    3. Sona raises and issue around using MD5 for security that would need to be addressed for OPNFV to achieve it's security goals (ChrisPriceAB, 14:08:08)
    4. a number of these issues have been located in releng and work is ongoing to resolve these items. (ChrisPriceAB, 14:08:34)
    5. Julien (Julien-zte, 14:10:02)
    6. aricg will take the Jira ticket on this issue (rpaik, 14:12:15)
    7. https://jira.opnfv.org/browse/SECURITY-39 related JIra ticket for the broken algorithms (ChrisPriceAB, 14:12:44)
    8. https://jira.opnfv.org/browse/SECURITY-39 (Sona, 14:12:59)
    9. dneary asks what one might use aside from MD5 to sign files, Sona answers sha2 would be a better option (ChrisPriceAB, 14:15:22)
    10. Sona also notes that OpenStack recently got the CII badging and should encourage other upstream communities to do the same (rpaik, 14:17:56)
    11. ACTION: dmcbride and Sona to discuss resolving the issues with MD5 based cryptographic algorithms in Colorado time frame. (ChrisPriceAB, 14:23:43)

  6. Community TSC Member election (ChrisPriceAB, 14:24:00)
    1. https://wiki.opnfv.org/display/DEV/Community+Election+Procedure#CommunityElectionProcedure-CommunityTSCmemberelection(proposalpendingapproval) (ChrisPriceAB, 14:24:51)
    2. the list of committers as of August 1st will be used for the election (rpaik, 14:29:37)
    3. proxy for Brian Skerry (rpaik, 14:32:42)
    4. VOTE: Voted on "Does the TSC approve the TSC election procedures as outlined on https://wiki.opnfv.org/display/DEV/Community+Election+Procedure ?" Results are, +1: 9 (ChrisPriceAB, 14:32:52)
    5. AGREED: the TSC agrees to run the elctions according to https://wiki.opnfv.org/display/DEV/Community+Election+Procedure (ChrisPriceAB, 14:33:04)

  7. Colorado planning and activities (ChrisPriceAB, 14:34:28)
    1. https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects Colorado release, project reporting page (ChrisPriceAB, 14:35:24)
    2. dmcbride has been working with our information sources to provide an evaluation of our projects participating in Colorado to evaluate risk levels for Colorado. (ChrisPriceAB, 14:36:20)
    3. missing milestones and lack of reporting provide input to being a high risk project. (ChrisPriceAB, 14:36:38)
    4. some project are still not reporting status to the project reporting page for the Colorado release. (ChrisPriceAB, 14:37:10)
    5. dmcbride outlines that Jira is not being handled consistently according to the basic handling we had identified for issues. Some work may be beneficial to reiterate this in D-Release. (ChrisPriceAB, 14:38:01)
    6. dmcbride also highlights the need to use cmmon versions and tags in Jira in order that we are able to track items in the release (ChrisPriceAB, 14:38:32)
    7. https://wiki.opnfv.org/display/SWREL/Colorado+Scenario+Status Colorado scenario status reporting page (ChrisPriceAB, 14:39:01)
    8. dmcbride outlines that there is limited reporting occuring on the scenario status reporting page leading into Colorado. (ChrisPriceAB, 14:39:32)
    9. geraldk asks if the projects are aware of their classification. dmcbride answers that he has reached out to high risk projects to begin working to resolve the risk. (ChrisPriceAB, 14:40:33)
    10. geraldk asks what would be the next steps if projects are not able to recover their status. (ChrisPriceAB, 14:40:58)
    11. ChrisPriceAB suggests adding color coding/issues information on the Colorado release status page (rpaik, 14:46:12)

  8. Discussion around adoption of Phase 1 of CI evolution for Colorado (ChrisPriceAB, 14:46:14)
    1. https://wiki.opnfv.org/display/INF/CI+Evolution ci evolution wiki page (ChrisPriceAB, 14:46:37)
    2. trozet notes that he's concerned about Jenkins job structure change in Phase I that may have an impact on the Colorado release (rpaik, 14:49:23)
    3. trozet added that APEX has a different job structure vs. other installer projects (rpaik, 14:52:34)
    4. notes from last Infra WG meeting, https://wiki.opnfv.org/display/INF/Infra+Working+Group (jmorgan1, 14:57:46)
    5. The TSC does not object to allowing Apex to defer alignment of job structures as long as we secure that the we can achieve phases 3 and 4 of the CI evolution in the D release. (ChrisPriceAB, 14:58:00)

  9. OPNFV meetup on Thursday of the ODL design summit (ChrisPriceAB, 14:59:58)
    1. rpaik outlines that the ODL team invited us to a meeting to discuss Carbon release and needs from OPNFV. (ChrisPriceAB, 15:00:24)
    2. the offer was made to OPNFV and rpaik acepted and will send further information shortly. (ChrisPriceAB, 15:00:45)


Meeting ended at 15:02:03 UTC (full logs).

Action items

  1. dmcbride and Sona to discuss resolving the issues with MD5 based cryptographic algorithms in Colorado time frame.


Action items, by person

  1. Sona
    1. dmcbride and Sona to discuss resolving the issues with MD5 based cryptographic algorithms in Colorado time frame.


People present (lines said)

  1. ChrisPriceAB (51)
  2. collabot (13)
  3. rpaik (11)
  4. dneary (5)
  5. bryan_att (3)
  6. dku (2)
  7. juhao (2)
  8. Sona (2)
  9. Julien-zte (2)
  10. uli-k (2)
  11. JonasArndt (1)
  12. bjskerry (1)
  13. GeraldK (1)
  14. jmorgan1 (1)


Generated by MeetBot 0.1.4.