#opnfv-meeting: testperf

Meeting started by dfarrell07 at 14:02:44 UTC (full logs).

Meeting summary

    1. https://etherpad.opnfv.org/p/testperf-meeting-2016-08-04 (yujunz, 14:03:01)
    2. thanks to yujunz and Qtip for putting together an agenda, and generally being well-prepared to chair meeting :) (dfarrell07, 14:05:23)

  1. action items followup (yujunz, 14:05:56)
    1. Julien (Julien-zte, 14:06:01)
    2. kubi (kubi001, 14:06:16)
    3. yujunz (yujunz, 14:06:22)
    4. Maryam Tahhan (mtahhan, 14:06:23)
    5. Daniel Farrell (dfarrell07, 14:06:27)
    6. AP @mbeierl to create a wiki on OPNFV testing and Gerrit hooks options (yujunz, 14:06:43)
    7. AP @kubi001 to send out information on how to store data in the community Influx DB. (yujunz, 14:07:26)
    8. https://wiki.opnfv.org/display/yardstick/How+to+store+other+project%27s+test+results+in+InfluxDB (kubi001, 14:07:30)
    9. kubi001 has made progress on storing data in DB #action, see link above, welcomes comments, can do discussion at next meeting (dfarrell07, 14:08:15)
    10. everyone should go review that wiki and ask kubi001 questions (dfarrell07, 14:08:39)
    11. wiki uses storeperf/yardstick example (dfarrell07, 14:09:20)
    12. yujunz asks about endpoints for sending data, kubi001 will add/update (dfarrell07, 14:09:47)

  2. APAC friendly timeslot conlusion (yujunz, 14:10:38)
    1. dfarrell07 asks if anyone has spoken up on list about this being helpful for them, someone from APAC timezone that wouldn't make meeting, or has trouble, but would with this slot (dfarrell07, 14:13:47)
    2. dfarrell07 is happy to have APAC-friendly meeting, just wanted to address that point of "who needs it?" from initial discussions (dfarrell07, 14:14:18)
    3. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2016/opnfv-meeting.2016-07-21-14.10.html (yujunz, 14:14:41)
    4. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-meeting/2016/opnfv-meeting.2016-07-21-14.10.html (yujunz, 14:14:45)
    5. We still need to pick exact date/time (dfarrell07, 14:16:28)
    6. Ideally, we would make these changes over email, so people who are not here can give input (dfarrell07, 14:16:49)
    7. Requests from others about making sure we update the wiki and send cal invite for the changes (dfarrell07, 14:17:10)

  3. Release milestones for test projects (yujunz, 14:18:22)
    1. ACTION: yujunz to drive email discussion about date/time of meeting (dfarrell07, 14:18:23)
    2. dfarrell07 talks about CPerf's questions about taking part in C release or not (dfarrell07, 14:21:12)
    3. CPerf folks have experience with ODL's releases, where test projects float above releases and tightly coupled projects do the overhead of milestones to get synced for release (dfarrell07, 14:21:53)
    4. since test projects don't have this need to say, lay down the same software in similar ways) like installers), we should be able to float above releases and change test code for them, vs cherry-picking between branches (dfarrell07, 14:22:41)
    5. that would cause less overhead, if this syncing via milestones is really unecessary (dfarrell07, 14:23:10)
    6. may also be good middle ground to make milestones more relevant for test ppl (dfarrell07, 14:23:26)
    7. dmcbride points out that this would happen for D release, we're well past C plannin (dfarrell07, 14:24:08)
    8. discussion between dfarrell07 and dmcbride about project mgmt in ODL and OPNFV, status of ODL, future for OPNFV (dfarrell07, 14:27:57)
    9. dmcbride reports TSC has been talking about this too, no one-size-all (dfarrell07, 14:28:13)
    10. dmcbride asks if anyone has a recommendation for milestones, project plan (dfarrell07, 14:30:37)
    11. Al, who have been involved in multi test projects, def thinks we should track progress (like via JIRA) and have goals and such, but they don't need to be related to milestones/releases (dfarrell07, 14:32:27)
    12. dmcbride says could focus on making sure test projects are carefully updating status of tasks on JIRA, use JIRA to make/see progress (dfarrell07, 14:32:57)
    13. maybe JIRA status sync meetings at this meeting or project-specific meetings (dfarrell07, 14:33:17)
    14. ODL Int/Test walks through Trello each meeting, as well as general topics, could do with JIRA (dfarrell07, 14:33:43)
    15. dmcbride will bring this up with TSC for D release, to not use milestones for test projects, use JIRA and weekly status checks (dfarrell07, 14:34:48)

  4. open discussion (yujunz, 14:35:21)
    1. https://etherpad.opnfv.org/p/qtip-overview (yujunz, 14:35:54)
    2. yujunz asks for input from test/perf group about status of their projects, relationship betwen qtip and other projects (dfarrell07, 14:36:42)
    3. yujunz asks test ppl to review that pad^^ (dfarrell07, 14:36:57)
    4. next meeting will be chaired by CPerf and minutes by VSperf (yujunz, 14:38:38)


Meeting ended at 14:39:42 UTC (full logs).

Action items

  1. yujunz to drive email discussion about date/time of meeting


Action items, by person

  1. yujunz
    1. yujunz to drive email discussion about date/time of meeting


People present (lines said)

  1. dfarrell07 (36)
  2. yujunz (20)
  3. collabot (6)
  4. Julien-zte (4)
  5. mtahhan (2)
  6. kubi001 (2)
  7. qwebirc52617 (1)
  8. dmcbride (1)
  9. ljlamers_ (1)
  10. mbeierl (0)


Generated by MeetBot 0.1.4.