#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:24 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 13:59:30)
    1. Chris Price (ChrisPriceAB, 13:59:35)
    2. Uli Kleber (ulik, 13:59:38)
    3. Jonas Arndt (JonasArndt, 13:59:40)
    4. Ceciliacorbi (Ceciliacorbi, 13:59:47)
    5. Dave Neary (dneary, 14:00:12)
    6. Gerald Kunzmann (GeraldK, 14:01:21)
    7. Brian Skerry (bjskerry, 14:01:24)
    8. Bryan Sullivan (bryan_att, 14:01:33)
    9. Dirk Kutscher (dku, 14:01:55)
    10. Edgar StPierre (edgarstp, 14:02:05)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:02:11)
    1. Frank Brockners (frankbrockners, 14:02:16)
    2. https://wiki.opnfv.org/display/meetings/TSC#TSC-August2,2016 previous minutes as recorded (ChrisPriceAB, 14:02:19)
    3. After one minor correction the minutes are approved. (ChrisPriceAB, 14:02:48)

  3. Agenda Bashing (ChrisPriceAB, 14:02:52)
    1. https://wiki.opnfv.org/display/meetings/TSC todays agenda (ChrisPriceAB, 14:03:08)
    2. rprakash (rprakash, 14:03:33)
    3. no further topics proposed to the agenda (ChrisPriceAB, 14:04:25)

  4. OPNFV Board meeting recap (ChrisPriceAB, 14:04:40)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/011907.html board meeting update e-mail (ChrisPriceAB, 14:04:59)
    2. ChrisPriceAB noted that he discussed reporting status for the Colorado release during the board meeting (rpaik, 14:06:27)
    3. Adding 5 Committer-at-Large TSC members were approved by the Board (rpaik, 14:07:15)
    4. Julien (Julien-zte, 14:07:29)
    5. Tapio Tallgren (tallgren, 14:07:41)
    6. Borard resolutions affecting Bylaws will be published going forward (rpaik, 14:09:15)
    7. The title of Board President will change to Vice Chairperson (rpaik, 14:09:48)

  5. Committer-at-Large elections to the TSC (ChrisPriceAB, 14:10:45)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/011798.html Community TSC election announcement (rpaik, 14:11:32)
    2. https://wiki.opnfv.org/display/DEV/Community+Election+Procedure community election procedure (ChrisPriceAB, 14:12:08)
    3. ChrisPriceAB discusses proposed procedures when more than 2 members are elected from same member companies and alternates (rpaik, 14:14:46)
    4. https://www.opnfv.org/developers/technical-project-governance/tsc-charter TSC Charter (Section 4) (rpaik, 14:16:41)
    5. AGREED: the TSC agrees that any company needs to ensure it does not have more than two TSC representatives in which ever way that company feels is best. We will not enforce a rule on how this should be handled. (ChrisPriceAB, 14:20:49)
    6. AGREED: the TSC agrees that they do not want to enforce rules around who should be delegates, however in the event that there are three members of any company on a TSC call only two of the votes would count. (ChrisPriceAB, 14:22:51)
    7. ACTION: chrispriceab to update the commnity elections procedure wiki (ChrisPriceAB, 14:24:20)
    8. AGREED: the TSC agrees that the list established during the elections is valid only for those elections and should not be used for future roles. (ChrisPriceAB, 14:28:39)
    9. rpaik reminds the comunity either nominate themselves or send in nominations (ChrisPriceAB, 14:29:24)

  6. TSC meeting schedule (ChrisPriceAB, 14:29:29)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/011840.html email discussion on TSC calls (rpaik, 14:29:50)
    2. AGREED: the TSC agrees to postpone this discussion until the new TSC members are active. (ChrisPriceAB, 14:31:27)

  7. Colorado planning and activities (ChrisPriceAB, 14:31:39)
    1. dmcbride reminds the community that the documentation milestone is coming up next week. (ChrisPriceAB, 14:32:09)
    2. the stable branch mielstone is also coming up which has resulted in community discussion (ChrisPriceAB, 14:32:25)
    3. dmcbride outlines activity to improve the activity around the stable branch milestone, including strong communication, and establishing a window for cutting stable which would start on MS9 and would last a week. (ChrisPriceAB, 14:33:40)
    4. dmcbride raises concerns that some projects may be forking upstream projects, which is not necessarily an issue. (ChrisPriceAB, 14:34:48)
    5. some projects are not as aware as others on how to effectively upstream patches anc code form their project work. (ChrisPriceAB, 14:35:21)
    6. dmcbride has been working with these projects to ensure that we are able to get our code upstream and work with upstream communities. (ChrisPriceAB, 14:35:52)
    7. dmcbride outlines a need to work with and educate projects on how this can best be done. (ChrisPriceAB, 14:36:20)
    8. https://wiki.opnfv.org/display/octopus/Finalizing+OPNFV+Releases the process for finalising the Colorado release. (ChrisPriceAB, 14:36:49)

  8. Opera project creation review (ChrisPriceAB, 14:37:47)
    1. https://wiki.opnfv.org/display/PROJ/OPNFV-OPEN-O opera project proposal (ChrisPriceAB, 14:37:54)
    2. the Opera project will focus in the short term on the integration of open-o NFVO, a VNFM based on Juju, and an OpenStack based VIM (ChrisPriceAB, 14:39:48)
    3. TOSCA and HEAT are the primary target interfaces models for this integration (ChrisPriceAB, 14:40:23)
    4. Opera will start with a vCPE use case to establish the work (ChrisPriceAB, 14:41:43)
    5. Opera intends to work closely with other projects defining interfaces and capabilities and intends to participate actively in the MANO working group (ChrisPriceAB, 14:42:11)
    6. Opera intends to participate in the D-Release (ChrisPriceAB, 14:42:38)
    7. dneary asks which VNFD and NSD will be used in the first iteration of the project. (ChrisPriceAB, 14:43:13)
    8. Yingjun answers that they intend to use TOSCA, and a TOSCA parser to translate to other models (including any needed translations for selected components) (ChrisPriceAB, 14:43:59)
    9. dneary asks if the Parser project in OPNFV will be used as the parser in question. (ChrisPriceAB, 14:44:25)
    10. this does not seem to be the case as different source implementations seem to be selected for this purpose (ChrisPriceAB, 14:45:15)
    11. frankbrockners asks if there will be additional scenarios included based on JOID to accommodate opera? (ChrisPriceAB, 14:47:01)
    12. aria is another open source project to deal with tosca template (Julien-zte, 14:48:34)
    13. Yingju responds that the L3VPN based scenario's would be preferred. (ChrisPriceAB, 14:48:36)
    14. http://ariatosca.org/ (Julien-zte, 14:48:37)
    15. prakash responds that the team is not sure about which scenario's they would be using, nor if the existing installation toolchains are sufficient (ChrisPriceAB, 14:49:55)
    16. frankbrockners brought up a great point. New projects should clearly specify which scenarios they intend to work with, and whether they intend to create a new scenario. (dmcbride, 14:51:56)
    17. there are technical investigations required to determine how this project will interact with the installer projects and scenario's. This is unknown at this time. (ChrisPriceAB, 14:52:04)
    18. repo name will be changed to "opera" (all lower case) (rpaik, 14:56:19)
    19. proxy for Brian Skerry (rpaik, 15:00:36)
    20. VOTE: Voted on "Does the TSC agree to create the opera project as an incubation project in OPNFV?" Results are, +1: 11 (ChrisPriceAB, 15:00:37)


Meeting ended at 15:01:05 UTC (full logs).

Action items

  1. chrispriceab to update the commnity elections procedure wiki


Action items, by person

  1. ChrisPriceAB
    1. chrispriceab to update the commnity elections procedure wiki


People present (lines said)

  1. ChrisPriceAB (49)
  2. rpaik (12)
  3. collabot (8)
  4. dneary (4)
  5. Julien-zte (4)
  6. dku (2)
  7. frankbrockners (2)
  8. bryan_att (2)
  9. edgarstp (2)
  10. JonasArndt (2)
  11. tallgren (2)
  12. ulik (2)
  13. dmcbride (1)
  14. GeraldK (1)
  15. rprakash (1)
  16. Ceciliacorbi (1)
  17. bjskerry (1)


Generated by MeetBot 0.1.4.