#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:00:05 UTC (full logs).

Meeting summary

  1. roll call (ChrisPriceAB, 13:00:16)
    1. Chris Price (ChrisPriceAB, 13:00:22)
    2. Uli Kleber (ulik, 13:00:35)
    3. Stuart Mackie (StuartMackie, 13:00:43)
    4. rprakash (rprakash, 13:01:01)
    5. Edgar StPierre (edgarstp, 13:01:08)
    6. Tapio Tallgren (tallgren, 13:02:17)
    7. Ashiq Khan (Ashiq_, 13:02:23)

  2. Approval of previous meeting minutes (ChrisPriceAB, 13:02:27)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-August16,2016 previous minutes of meeting (ChrisPriceAB, 13:02:34)
    2. no comments, minutes approved. (ChrisPriceAB, 13:02:41)

  3. Agenda Bashing (ChrisPriceAB, 13:02:45)
    1. https://wiki.opnfv.org/display/meetings/TSC current agenda (ChrisPriceAB, 13:03:03)
    2. Dirk Kutscher (dku, 13:03:07)
    3. Jonas Arndt (JonasArndt, 13:03:40)
    4. no new topics (ChrisPriceAB, 13:04:22)

  4. Technical community elections (ChrisPriceAB, 13:04:34)
    1. rpaik outlines that committer elections to the TSC voting has started. (ChrisPriceAB, 13:04:53)
    2. e-mails were sent on the weekend and will remain open until September 2nd (ChrisPriceAB, 13:05:13)

  5. CII Badging update (ChrisPriceAB, 13:07:06)
    1. https://wiki.opnfv.org/display/security/Security+Home security home wiki page with the CII badge (rpaik, 13:07:49)
    2. https://bestpractices.coreinfrastructure.org/projects/164 OPNFV badge page (rpaik, 13:08:35)
    3. sona explains that the recent work on the security badge program has concluded and OPNFV has been awarded the security badge (ChrisPriceAB, 13:08:43)
    4. more work is required to improve our processes and maintain the badge for OPNFV (ChrisPriceAB, 13:09:47)
    5. feedback on the process, or questions concerned should be handled as Jira tickets on the security project (ChrisPriceAB, 13:09:47)
    6. Narinder Gupta (narinder, 13:11:12)
    7. https://etherpad.opnfv.org/p/sec-audit (lhinds, 13:12:00)
    8. https://etherpad.opnfv.org/p/sec-audit security audit planning etherpad (ChrisPriceAB, 13:12:58)
    9. the security team plans to work with each of the projects to do a security audit of the projects in OPNFV and provide recommendations to the projects on how to improve. (ChrisPriceAB, 13:14:25)
    10. the intention is to start a security review on the Colorado release (ChrisPriceAB, 13:16:16)
    11. this activity will extend the badge program into each individual project to provide feedback (ChrisPriceAB, 13:16:48)
    12. lhinds asks projects to read the etherpad and provide feedback (ChrisPriceAB, 13:17:12)
    13. https://github.com/lukehinds/anteater (lhinds, 13:17:57)
    14. https://wiki.opnfv.org/display/SWREL/Colorado?preview=/2926065/6823197/colorado%20r7.pdf (lhinds, 13:19:21)
    15. discussion on introducing "security audit" as one of the release milestones (rpaik, 13:20:46)

  6. Project health metrics (ChrisPriceAB, 13:21:23)
    1. on the TSC meeting, June 28th, Tapio & Bryan volunteered to work on establishing metrics for projects to help identify active or struggling projects in OPNFV (ChrisPriceAB, 13:23:26)
    2. the intention of the work is to find metrics that we would use to measure the activity around projects in order that we are able to work with projects that might be struggling and find best practices from projects that are functioning well. (ChrisPriceAB, 13:24:21)

  7. Project lifecycle review and process development (ChrisPriceAB, 13:30:02)
    1. ACTION: rpaik to start a wiki page for project health (rpaik, 13:30:03)
    2. post Colorado we will have a number of projects that have participated in multiple releases (rpaik, 13:31:39)
    3. Julien (Julien-zte, 13:31:50)
    4. there is a need to start a discussion on criteria for projects to go beyond incubation (rpaik, 13:32:24)
    5. Dave Neary (here but not on IRC since :05) (dneary, 13:32:34)
    6. https://www.opnfv.org/developers/technical-project-governance/project-lifecycle OPNFV project lifecycle (rpaik, 13:32:50)
    7. Prakash suggests different criteria are important for different types of projects (dneary, 13:33:58)
    8. chrispriceab explains that according to our charter some projects, following Colorado, may want to go through a promotion review from incubation to mature (ChrisPriceAB, 13:34:07)
    9. Dave Neary asks what the purpose of graduation is - have projects been held back by being in incubation? (dneary, 13:34:26)
    10. ulik and prakash outline that there are many types of projects and we should consider these differences as we consider the reviews (ChrisPriceAB, 13:34:43)
    11. Chris Price says it is community recognition of projects that are doing well, and also communicates project maturity to people outside OPNFV (dneary, 13:35:17)
    12. Discussion whether thinking about creation review is a good use of time since no projects have requested it. Chris says we should be prepared to have some consistent criteria when the requests come (dneary, 13:39:01)
    13. Chris says we can expect first GR requests post Colorado. (dneary, 13:39:23)
    14. No immediate action items - "someone" should start a wiki page for GR criteria before the Colorado release. (dneary, 13:40:20)

  8. Colorado planning and activities (ChrisPriceAB, 13:40:26)
    1. dmcbride outlines that we have completed stable branch creation for Colorado. (ChrisPriceAB, 13:40:49)
    2. dmcbride thanks the PTL's for working with the release project to achieve the milestone (ChrisPriceAB, 13:41:11)
    3. the infra team is creating jenkins jobs for colorado branch, check gerrit for further information (ChrisPriceAB, 13:42:14)
    4. dmcbride outlines the next milestone is test completion during mid september. Following that a Jira cleanup will be done prior to release. (ChrisPriceAB, 13:45:49)
    5. ACTION: dmcbride to establish Colorado 2.0 and 3.0 milestones and plans. (ChrisPriceAB, 13:46:20)
    6. dmcbride will also start D-release activities (rpaik, 13:48:34)

  9. AoB (ChrisPriceAB, 13:48:36)
    1. future events (ChrisPriceAB, 13:50:11)
    2. the meet-up at the ODL summit will be for a full day. (ChrisPriceAB, 13:50:48)
    3. https://wiki.opnfv.org/display/EVNT/Meetup+at+OpenDaylight+Developer+Design+Forum ODL Summit meetup (rpaik, 13:51:06)
    4. in the morning we will discuss d-release and carbon planning in the morning (ChrisPriceAB, 13:51:10)
    5. uli-k asks about D release naming. rpaik answers that he is superstitious and is reluctant to start the process early (ChrisPriceAB, 13:53:01)
    6. ACTION: rpaik to start the d-release naming procedure. (ChrisPriceAB, 13:54:42)
    7. the guideline is for rivers which are based in the euro-african region. (ChrisPriceAB, 13:55:27)


Meeting ended at 13:56:12 UTC (full logs).

Action items

  1. rpaik to start a wiki page for project health
  2. dmcbride to establish Colorado 2.0 and 3.0 milestones and plans.
  3. rpaik to start the d-release naming procedure.


Action items, by person

  1. rpaik
    1. rpaik to start a wiki page for project health
    2. rpaik to start the d-release naming procedure.


People present (lines said)

  1. ChrisPriceAB (45)
  2. rpaik (11)
  3. dneary (10)
  4. jmorgan1 (7)
  5. collabot (5)
  6. Julien-zte (3)
  7. rprakash (3)
  8. lhinds (3)
  9. fdegir (2)
  10. ulik (2)
  11. dku (1)
  12. narinder (1)
  13. leifmadsen (1)
  14. tallgren (1)
  15. StuartMackie (1)
  16. edgarstp (1)
  17. JonasArndt (1)
  18. Ashiq_ (1)


Generated by MeetBot 0.1.4.