#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:02:12 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 15:02:18)
    1. Uli Kleber (uli-k, 15:02:28)
    2. Fatih Degirmenci (fdegir, 15:02:37)
    3. Aric Gardner (aricg, 15:02:39)
    4. Jack Morgan (jmorgan1, 15:02:44)
    5. Trevor Bramwell (bramwelt, 15:02:46)

  2. Agenda (fdegir, 15:03:32)
    1. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:03:36)
    2. Release related topics have been moved up in the list (fdegir, 15:03:42)

  3. How to help Docs project with builds (fdegir, 15:04:14)
    1. During release meeting, there were questions regarding the need of having daily doc builds (fdegir, 15:04:59)
    2. this issue was raised by bryan_att (dmcbride, 15:06:06)
    3. Currently the documentation is generated whenever a documentation patch is submitted to master or corresponding branch (fdegir, 15:07:28)
    4. See the example below (fdegir, 15:07:59)
    5. https://gerrit.opnfv.org/gerrit/#/c/19583/ (fdegir, 15:08:01)
    6. The links to generated documents are posted back to Gerrit Change as comments (fdegir, 15:08:47)
    7. Bryan Sullivan (bryan_att, 15:09:01)
    8. bryan_att is in contact with Docs project and will follow it up with the project (fdegir, 15:13:26)

  4. Documenting which scenario runs in which lab, pod (fdegir, 15:15:11)
    1. The purpose of this activity is that the TSC asked documenting which scenarios are running on which infrastructure (fdegir, 15:16:03)
    2. In order to support David and the community as a whole to make it easier to track infra scenario relation (fdegir, 15:16:26)
    3. https://wiki.opnfv.org/display/INF/Scenario+Infrastructure (fdegir, 15:16:35)
    4. http://hastebin.com/soyonemoma.bash (fdegir, 15:19:21)
    5. Julien (Julien-zte, 15:21:32)
    6. it is possible to specify the pod name in the rest api query: http://testresults.opnfv.org/test/api/v1/results?case=vping_userdata&scenario=os-nosdn-nofeature-ha&pod_name=lf-pod1 (jose_lausuch, 15:24:46)
    7. As jose_lausuch says above, you can query for arm-pods as well (fdegir, 15:25:16)
    8. http://testresults.opnfv.org/test/api/v1/results?case=vping_userdata&pod_name=arm-pod1 (fdegir, 15:25:19)
    9. ACTION: jmorgan1 to drive the topic (fdegir, 15:30:59)

  5. Force change ID by setting the "Require Change-Id in commit message" (fdegir, 15:32:00)
    1. cpu and ipv6 for the pod capabilities (Julien-zte, 15:32:13)
    2. aricg will apply this change and monitor the situation for the side effects (fdegir, 15:33:21)

  6. Upcoming Intel lab maintenance (fdegir, 15:34:12)
    1. Intel lab will have maintenance this weekend which might slow/block things (fdegir, 15:34:50)
    2. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/012286.html (fdegir, 15:36:03)
    3. ACTION: fdegir to talk to DanSmithEricsson and aricg for additional build servers (fdegir, 15:37:13)

  7. Open questions Pharos Validator design (fdegir, 15:37:33)
    1. https://wiki.opnfv.org/display/INF/Pharos+Validator+Design (fdegir, 15:39:14)

  8. Infra JIRA Project Workflow (fdegir, 15:40:50)
    1. There is a request to switch the workflow to default (fdegir, 15:41:14)
    2. The question is what the Infra JIRA workflow should be? (fdegir, 15:41:32)
    3. This has a lower priority for the timebeing (fdegir, 15:43:34)
    4. The conclusion is to stay with the default workflow until we have chance to discuss this (fdegir, 15:44:41)
    5. The dashboard should also be touched on this discussion; what to use for lab booking/tracking? (fdegir, 15:46:05)

  9. How to utilize donated PODs in LF Lab (fdegir, 15:46:35)
    1. Intel donated 18 machines to OPNFV (fdegir, 15:47:56)
    2. 6 machines are reserved for LaaS (fdegir, 15:49:13)
    3. 12 machines are used for creating 2 PODs that are located in LF Lab (fdegir, 15:49:40)
    4. 1 of the PODs is suggested to be used for 3rd Party CI work (fdegir, 15:50:49)
    5. LF POD4 is currently idling and it can be allocated to validator work (fdegir, 15:57:15)
    6. https://wiki.opnfv.org/display/pharos/Lflab+Hosting#LflabHosting-POD4 (bramwelt, 15:59:14)
    7. Another option could be using this pod for dynamic pod allocation (fdegir, 16:03:08)
    8. Or this POD can be allocated to an installer (fdegir, 16:03:24)
    9. ACTION: DanSmithEricsson to have a proposal for dynamic POD allocation (fdegir, 16:06:11)


Meeting ended at 16:06:44 UTC (full logs).

Action items

  1. jmorgan1 to drive the topic
  2. fdegir to talk to DanSmithEricsson and aricg for additional build servers
  3. DanSmithEricsson to have a proposal for dynamic POD allocation


Action items, by person

  1. aricg
    1. fdegir to talk to DanSmithEricsson and aricg for additional build servers
  2. fdegir
    1. fdegir to talk to DanSmithEricsson and aricg for additional build servers
  3. jmorgan1
    1. jmorgan1 to drive the topic


People present (lines said)

  1. fdegir (48)
  2. collabot (5)
  3. jmorgan1 (5)
  4. aricg (3)
  5. Julien-zte (3)
  6. bramwelt (2)
  7. ChrisPriceAB (1)
  8. leifmadsen (1)
  9. bryan_att (1)
  10. uli-k (1)
  11. jose_lausuch (1)
  12. dmcbride (1)


Generated by MeetBot 0.1.4.