#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:38 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 13:59:42)
    1. Chris Price (ChrisPriceAB, 13:59:47)
    2. Dave Neary (dneary, 13:59:47)
    3. hongbo (hongbo1, 13:59:53)
    4. Edgar StPierre (edgarstp, 14:00:00)
    5. Morgan Richomme (morgan_orange, 14:00:04)
    6. Frank Brockners (frankbrockners, 14:00:05)
    7. Rossella Sblendido (rossella_s, 14:00:16)
    8. Jack Morgan (jmorgan1, 14:00:17)
    9. Brian Skerry (bjskerry, 14:01:22)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:01:46)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-August30,2016 previous minutes (ChrisPriceAB, 14:01:52)
    2. Fatih Degirmenci (fdegir, 14:02:02)
    3. No comments received minutes approved. (ChrisPriceAB, 14:02:05)

  3. Agenda Bashing (ChrisPriceAB, 14:02:33)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-September6,2016 todays agenda (ChrisPriceAB, 14:02:38)
    2. Ash Young (for Uli) (ashyoung, 14:03:22)
    3. rprakash (rprakash, 14:03:27)
    4. Bryan Sullivan (bryan_att, 14:04:12)
    5. Stuart Mackie (StuartMackie, 14:04:18)
    6. Bin Hu (bin_, 14:04:48)
    7. Steven Wright (Steven_, 14:04:49)
    8. http://lists.opnfv.org/pipermail/opnfv-tsc/2016-September/002860.html (frankbrockners, 14:05:08)
    9. Julien (Julien-zte, 14:05:12)
    10. there was a request for the TSC to discuss config files for Doctor, we will address that in the Colorado section (ChrisPriceAB, 14:05:21)
    11. Tapio Tallgren (tallgren, 14:05:23)
    12. Carlos Goncalves (for Dirk K.) (cgoncalves, 14:05:23)

  4. Introduction/welcome for new TSC members (ChrisPriceAB, 14:06:08)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012438.html email on CAL TSC members (rpaik, 14:06:58)
    2. the five new TSC members were voted in and started today (ChrisPriceAB, 14:07:01)

  5. License scan update (ChrisPriceAB, 14:08:08)
    1. Scott and Ray have been sending questions to OPNFV projects where our license scan has turned up issues. (ChrisPriceAB, 14:08:36)
    2. if you have not received questions from them no issues have been identified. (ChrisPriceAB, 14:09:06)
    3. Scott addresses the TSC, outlining he is not acting as a legal council but to discuss process with us. (ChrisPriceAB, 14:09:29)
    4. Scott notes that there's room for improvement in including license information at the file-level ( not just on directories) (rpaik, 14:11:57)
    5. Scott Nicholas notes that license files should have a .txt extension (rpaik, 14:14:55)
    6. https://wiki.opnfv.org/display/DEV/Contribution+Guidelines licence references on the contributor guidelines wiki (ChrisPriceAB, 14:15:02)
    7. Scott also noted that projects should also avoid using private repo's (e.g. personal GitHub) (rpaik, 14:16:45)

  6. Confluence/wiki tracking on Bitergia (ChrisPriceAB, 14:23:31)
    1. raik updates the TSC on work to track community activity on bitergia. (ChrisPriceAB, 14:24:07)
    2. rpaik asks if we can spend 3K out of the TSC initiatives to fill the need on bitergia (ChrisPriceAB, 14:24:42)
    3. Julien asks if we should track more things as there is already a lot on the dashboard. (ChrisPriceAB, 14:26:29)
    4. rpaik the wiki tracking has been a pending point to be done for a long time (ChrisPriceAB, 14:27:02)
    5. VOTE: Voted on "Does the TSC agree to spend 3K USD on adding wiki tracking to bitergia from the TSC initiatives budget?" Results are, 0: 1, +1: 14 (ChrisPriceAB, 14:29:13)
    6. AGREED: the TSC agree to update bitergia (ChrisPriceAB, 14:29:24)

  7. September OPNFV Board meeting (ChrisPriceAB, 14:29:28)
    1. https://wiki.opnfv.org/download/attachments/2925933/TSC%20update%20to%20the%20board%20September%202016.pptx?version=1&modificationDate=1473169988020&api=v2 current draft material for the board meeting (ChrisPriceAB, 14:29:48)

  8. Technical community elections (ChrisPriceAB, 14:33:04)
    1. Committer Board (Announcement: Sep. 6/Nomination Sep 13 - 23/Election Sep 26 - 30/Result: Oct. 3) (ChrisPriceAB, 14:33:46)
    2. TSC Chair (Announcement: Sep. 12/Nomination Sep 19 - 30/Election Oct. 3 - 7/Result: Oct. 10) (ChrisPriceAB, 14:34:23)

  9. OPNFV intern program update (ChrisPriceAB, 14:34:52)
    1. https://wiki.opnfv.org/display/DEV/First+year+internship+program+observations learning from the intern program (rpaik, 14:35:09)
    2. rpaik states he is happy with the interns we have had and the work they have been doing for the project. (ChrisPriceAB, 14:36:12)
    3. interns have even helped out with answering inquiries on the opnfv-users support page. (ChrisPriceAB, 14:36:34)
    4. rpaik states that mentors have also stated they have been happy with the process. (ChrisPriceAB, 14:37:03)
    5. rpaik also states that while a "part time" option for intenship was available it was not used by the community or potential interns (ChrisPriceAB, 14:37:33)
    6. rpaik asks if there would be concerns with removing the "part time intern" program. (ChrisPriceAB, 14:38:01)
    7. rpaik also states that most interns have been run during the summer (ChrisPriceAB, 14:39:17)

  10. Colorado planning and activities (ChrisPriceAB, 14:42:39)
    1. dmcbride outlines that the planned release date for Colorado 1.0 is September 22nd and it is coming very close now. (ChrisPriceAB, 14:43:17)
    2. the functest dashboard shows a very small number of green scenario's compared to the number being tracked. (ChrisPriceAB, 14:43:35)
    3. the scenario status wiki is also showing 6/7 scenario's that are not showing release ready at this stage. (ChrisPriceAB, 14:44:02)
    4. dmcbride also describes that while we are improving on Jira status there are still untracked issues. (ChrisPriceAB, 14:44:37)
    5. frankbrockners outlines that while tests are failing on some scenario's it maye be only one use case that is failing. These scenario's can release with documented limitations capturing the issues. (ChrisPriceAB, 14:48:31)
    6. ACTION: dmcbride to report back to the TSC next week with scenario release status for Colorado 1.0 (ChrisPriceAB, 14:51:30)

  11. Common OPNFV configurations (ChrisPriceAB, 14:51:48)
    1. http://lists.opnfv.org/pipermail/opnfv-tsc/2016-September/002860.html (cgoncalves, 14:52:02)
    2. cgonclaves describes that the doctor project requires certain platform configurations to function. (ChrisPriceAB, 14:52:42)
    3. it has found to not be possible to be done in the Colorado project across all installers (ChrisPriceAB, 14:53:18)
    4. for some projects the feature set is intended to be compatible across all scenarios not intended to define a scenario of their own. (ChrisPriceAB, 14:53:51)
    5. this establishes a need for a common set of behaviours that allow features to be deployed on all scenarios (ChrisPriceAB, 14:54:51)
    6. julien-zte outlines that we should be able to articulate common capabilities for the installers to provide in any releasel (ChrisPriceAB, 14:56:45)
    7. info julien-zte indicates genesis should be a vehicle to achieve common configurations across installers. (ChrisPriceAB, 14:57:35)
    8. jmorgan1 adds that while this is not possible to achieve in Colorado, we should be looking at defining our needs for this heading into the D release. (ChrisPriceAB, 14:58:12)
    9. frankbrockners adds that there was limited participation in genesis to harmonize these items and as such genesis stood down from Colorado. (ChrisPriceAB, 14:59:01)
    10. jmorgan1 adds that the infra WG and pharos are working on this issue from the physical infra perspective that can lead to alignment on installers . (ChrisPriceAB, 15:00:32)
    11. ACTION: jmorgan1 to work with this topic and report back to the TSC regularly with progress and for guidance. (ChrisPriceAB, 15:01:01)


Meeting ended at 15:01:38 UTC (full logs).

Action items

  1. dmcbride to report back to the TSC next week with scenario release status for Colorado 1.0
  2. jmorgan1 to work with this topic and report back to the TSC regularly with progress and for guidance.


Action items, by person

  1. jmorgan1
    1. jmorgan1 to work with this topic and report back to the TSC regularly with progress and for guidance.


People present (lines said)

  1. ChrisPriceAB (67)
  2. ashyoung (15)
  3. collabot (11)
  4. jmorgan1 (11)
  5. cgoncalves (11)
  6. dneary (10)
  7. rpaik (9)
  8. morgan_orange (8)
  9. Julien-zte (7)
  10. bryan_att (5)
  11. frankbrockners (3)
  12. hongbo1 (3)
  13. rossella_s (3)
  14. tallgren (2)
  15. lylavoie (2)
  16. bjskerry (2)
  17. edgarstp (2)
  18. fdegir (2)
  19. StuartMackie (2)
  20. Steven_ (1)
  21. bin_ (1)
  22. rprakash (1)


Generated by MeetBot 0.1.4.