#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:17 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 15:00:31)
    1. Ray Paik (rpaik, 15:00:46)
    2. Lincoln Lavoie (lylavoie, 15:00:51)
    3. Jack Morgan (Pharos) (jmorgan1, 15:00:59)
    4. Yujun Zhang (yujunz-zte, 15:01:09)

  2. Agenda (fdegir, 15:01:19)
    1. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:01:27)

  3. Adding Huawei POD2 to CI PODs (fdegir, 15:01:58)
    1. How can a resource can be declared as CI Resource (fdegir, 15:03:13)
    2. https://wiki.opnfv.org/display/INF/Continuous+Integration#ContinuousIntegration-HardwareResources (fdegir, 15:03:15)
    3. Intel POD8 is not connected to Jenkins at the moment (fdegir, 15:08:59)
    4. Julien (Julien-zte, 15:09:45)
    5. Because of this, Compass requests addition of Huawei POD2 as CI POD (fdegir, 15:09:54)
    6. ACTION: aricg and May-meimei to fix Intel POD8 Jenkins connection (fdegir, 15:10:15)
    7. Infra WG will monitor Huawei POD2 for 2 weeks and then take action (fdegir, 15:10:54)

  4. Upcoming migration of Ericsson lab (fdegir, 15:11:23)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012466.html (fdegir, 15:11:40)
    2. ACTION: fdegir and Daniel Smith to follow this up (fdegir, 15:12:36)
    3. The biggest impact will be on Fuel (fdegir, 15:13:32)
    4. The builds might be impacted as well (fdegir, 15:13:57)

  5. Discussion regarding any release blockers (fdegir, 15:16:21)
    1. frankbrockners asks if we have top 10 type of list of blockers (fdegir, 15:16:34)
    2. It is important for community to be disciplined to use JIRA to track issues with different severity/criticality (fdegir, 15:18:03)
    3. Installers PTLs might need to be contacted in order to find out if and which scenarios are under risk (fdegir, 15:21:51)
    4. What can be done in order to sort remaining issues out (fdegir, 15:22:05)
    5. ACTION: dmcbride to send mail to installer, test, infra PTLs and suggest having daily status meetings (fdegir, 15:24:57)

  6. Infra/CI status update and plans for D-release (fdegir, 15:26:05)
    1. The main concern during Colorado release was CI Evolution (fdegir, 15:27:41)
    2. The main issue for not having CI Evolution not being ready is lack of human resources (fdegir, 15:31:06)
    3. MS for Infra updates complete December 15th (fdegir, 15:33:40)
    4. The work with CI Evolution will be done on sandbox first (fdegir, 15:35:37)
    5. https://wiki.opnfv.org/display/INF/CI+Evolution (fdegir, 15:36:12)
    6. Separating builds from the rest of the chain and enabling/aligning commit gating/smoke test are the first steps towards CI Evolution (fdegir, 15:42:27)
    7. Once we have an alignment on these, work with scenario promotion can start (fdegir, 15:42:49)
    8. ACTION: fdegir Put more detailed plan for CI Evolution including any prerequisites (fdegir, 15:44:07)

  7. Tracking OPNFV contributions in OpenStack (fdegir, 15:44:35)
    1. https://wiki.opnfv.org/display/COM/Tracking+OPNFV+contributions+in+OpenStack (aricg, 15:44:38)
    2. https://wiki.opnfv.org/display/COM/Tracking+OPNFV+contributions+in+OpenStack (fdegir, 15:44:51)
    3. One question is if we are able to do this for other upstream projects? (fdegir, 15:47:41)
    4. OpenStack is first candidate to start with and try to design a mechanism which is applicable to other communities as well (fdegir, 15:48:09)
    5. ACTION: aricg to propose this in releng and then send it to tech-discuss for further discussion (fdegir, 15:49:28)
    6. ACTION: aricg to check how apex is doing this (fdegir, 15:49:49)
    7. https://wiki.opnfv.org/display/apex/Upstream+Tracking (fdegir, 15:50:26)

  8. New Lab CI Process Discussion (fdegir, 15:51:20)
    1. There is a discrepancy between wiki and pharos repo regarding labs (fdegir, 15:51:49)
    2. we are now doing gerrit replication to improve clone speeds. If your DC would like a local copy of all opnfv repos send request to helpdesk. (aricg, 15:52:41)
    3. One option could be to have all the lab information on gerrit and include generated documents on Wiki (fdegir, 15:52:45)
    4. The question is: what is the primary source for lab information (fdegir, 15:53:14)
    5. jmorgan1 says the labs will document information in Pharos repo by Colorado.3.0 (fdegir, 15:54:10)
    6. morgan1, I will help you update some of the labs from the rst files (Julien-zte, 15:55:22)
    7. jmorgan1, I will help you update some of the labs from the rst files (Julien-zte, 15:55:42)
    8. We need to have an onboarding document for new labs/pods/resources coming online (fdegir, 15:57:46)
    9. ACTION: jmorgan1 to start up a wiki page for resource onboarding (fdegir, 15:58:37)

  9. Bitergia Jenkins Dashboard (fdegir, 15:58:54)
    1. https://opnfv.biterg.io proto-type page (rpaik, 15:59:09)
    2. What information we want to display on Bitergia Dashboard when it comes to Jenkins? (fdegir, 15:59:38)
    3. Please put ideas on etherpad linked below (fdegir, 16:00:56)
    4. https://etherpad.opnfv.org/p/jenkins-bitergia-dashboard (fdegir, 16:00:58)
    5. This activity aims to collect job, scenario, slave statistics (fdegir, 16:02:11)


Meeting ended at 16:02:15 UTC (full logs).

Action items

  1. aricg and May-meimei to fix Intel POD8 Jenkins connection
  2. fdegir and Daniel Smith to follow this up
  3. dmcbride to send mail to installer, test, infra PTLs and suggest having daily status meetings
  4. fdegir Put more detailed plan for CI Evolution including any prerequisites
  5. aricg to propose this in releng and then send it to tech-discuss for further discussion
  6. aricg to check how apex is doing this
  7. jmorgan1 to start up a wiki page for resource onboarding


Action items, by person

  1. aricg
    1. aricg and May-meimei to fix Intel POD8 Jenkins connection
    2. aricg to propose this in releng and then send it to tech-discuss for further discussion
    3. aricg to check how apex is doing this
  2. fdegir
    1. fdegir and Daniel Smith to follow this up
    2. fdegir Put more detailed plan for CI Evolution including any prerequisites
  3. jmorgan1
    1. jmorgan1 to start up a wiki page for resource onboarding


People present (lines said)

  1. fdegir (55)
  2. Julien-zte (7)
  3. jmorgan1 (7)
  4. collabot (5)
  5. aricg (4)
  6. lylavoie (3)
  7. rpaik (3)
  8. yujunz-zte (1)


Generated by MeetBot 0.1.4.