#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:29 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 13:59:38)
    1. Julien (Julien-zte, 13:59:45)
    2. Chris Price (ChrisPriceAB, 13:59:46)
    3. ceciliacorbi (Ceciliacorbi, 13:59:48)
    4. Jack Morgan (Pharos) (jmorgan1, 13:59:49)
    5. hongbo (hongbo2, 13:59:50)
    6. Uli Kleber (ulik, 13:59:53)
    7. Fatih Degirmenci (fdegir, 14:00:53)
    8. Frank Brockners (frankbrockners, 14:01:17)
    9. JonasArndt (JonasArndt, 14:01:24)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:01:30)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-September6,2016 previous minutes (ChrisPriceAB, 14:01:35)
    2. Stuart Mackie (StuartMackie, 14:01:44)
    3. No comments or feedback received, minutes approved (ChrisPriceAB, 14:01:48)
    4. Trevor Cooper representing Brian Skerry (trevc, 14:01:51)

  3. Agenda Bashing (ChrisPriceAB, 14:01:52)
    1. Morgan Richomme (morgan_orange, 14:01:52)
    2. Dave Neary (dneary, 14:01:53)
    3. Edgar StPierre (edgarstp, 14:02:03)
    4. https://wiki.opnfv.org/display/meetings/TSC#TSC-September13,2016 todays agenda (ChrisPriceAB, 14:02:06)
    5. Tapio Tallgren (tallgren, 14:02:10)
    6. Rossella Sblendido (rossella_, 14:02:17)
    7. Bin Hu (bin_, 14:02:24)
    8. rprakash (rprakash, 14:02:43)
    9. no further agenda items (ChrisPriceAB, 14:03:02)
    10. frankbrockners asks about federation of Jira, may be good to couple to the "external repo's" discussion (ChrisPriceAB, 14:03:43)
    11. Dirk Kutscher (dku, 14:03:50)

  4. Update from the September OPNFV Board meeting (ChrisPriceAB, 14:04:09)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012584.html Board meeting summary (rpaik, 14:04:23)
    2. the next TSC Chair will have a chance to review/work on the 2017 Technical Community budget in Q4'16 (rpaik, 14:07:09)
    3. ACTION: rpaik to provide update on the Q4 budget (rpaik, 14:08:49)

  5. Technical community elections (ChrisPriceAB, 14:08:51)
  6. Meetup at OpenDaylight Summit (ChrisPriceAB, 14:10:39)
    1. https://wiki.opnfv.org/display/EVNT/Meetup+at+OpenDaylight+Developer+Design+Forum ODL meet-up planning page (rpaik, 14:10:50)
    2. rpaik outlines that there will be a metup at the ODL design summit on the Thursday of that week. (ChrisPriceAB, 14:11:47)
    3. the first set of topics will be around OpenDaylight carbon (ChrisPriceAB, 14:12:00)
    4. the second set of topics include compliance testing and VNF onboarding (ChrisPriceAB, 14:12:23)
    5. rpaik urges community members to add their names to the wiki as participants of the meetup (ChrisPriceAB, 14:12:48)
    6. rpaik asks if during the first hour when we meet with the ODL team whom we should invite specifically for that discussion please inform him (ChrisPriceAB, 14:13:33)
    7. bryan_att adds that having Yang design experts at the conference they would be very helpful to have onboard (ChrisPriceAB, 14:14:44)

  7. Colorado planning and activities (ChrisPriceAB, 14:16:30)
    1. dmcbride states that he has updated the D-release schedule (ChrisPriceAB, 14:17:07)
    2. #link https://wiki.opnfv.org/display/SWREL/D-Release?preview=/6827418/7767196/OPNFV%20Release%20%2522D%2522%20r2.pdf d release schedule (ChrisPriceAB, 14:17:50)
    3. dmcbride adds that there is some consensus on maintaining the stable branch cutting window that was applied in the Colorado release. (ChrisPriceAB, 14:18:54)
    4. dmcbride adds that we will use Jira gating for the D release. (ChrisPriceAB, 14:19:30)
    5. frankbrockners adds that there is discussion around the processes ongoing on the mailing lists (ChrisPriceAB, 14:21:03)
    6. ACTION: -> d-release is from now to be referred to as Danube! (ChrisPriceAB, 14:21:48)
    7. 14 scenario's are now release ready. (ChrisPriceAB, 14:22:08)
    8. a further 10 scenario's are approahcing the stability milestone (ChrisPriceAB, 14:22:25)
    9. we are approaching around 70% readiness across scenario's. (ChrisPriceAB, 14:22:41)
    10. Jira status still has some work remaining to be in a resonlved state, around 20% of the items are unresolved. (ChrisPriceAB, 14:23:49)
    11. rpaik asks if there are going to be different artifacts for different architectures ARM/x86 for instance (ChrisPriceAB, 14:24:55)
    12. jmorgan1 describes that the Pharos spec for instance will accomodate multiple architectures in the same document (ChrisPriceAB, 14:25:26)
    13. https://www.opnfv.org/software/download (fdegir, 14:26:25)
    14. bin_ confirms that ARM does build it's own ISO and this should accomdated in the release artifacts (ChrisPriceAB, 14:27:09)
    15. ACTION: rpaik to work with brandon and aric to identify how to manage the artifacts for the release. (ChrisPriceAB, 14:27:37)

  8. Project Health Metrics Discussion (ChrisPriceAB, 14:27:55)
    1. https://wiki.opnfv.org/display/PROJ/Project+Health+Metrics+Discussion wiki with metrics prposal (ChrisPriceAB, 14:28:21)
    2. https://www.opnfv.org/developers/technical-project-governance/project-lifecycle (frankbrockners, 14:31:22)
    3. ChrisPriceAB notes that the metrics could be a tool to evaluate project's activity (rpaik, 14:32:02)
    4. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012532.html mail thread on project metrics (ChrisPriceAB, 14:32:56)
    5. frankbrockners asks what problem we are trying to solve (ChrisPriceAB, 14:34:22)
    6. dneary states that we can use these metrics to help identify projects that may need community guidance and assistance to be successful (ChrisPriceAB, 14:35:06)
    7. franks adds that he would like to see the project lifecycle be used for project evaluation (ChrisPriceAB, 14:36:03)
    8. ttalgren adds that we need to start working on the project lifecycle in some way and this would be one input to that (ChrisPriceAB, 14:36:24)
    9. dneary adds that these metrics may be useful for more than just the TSC and project lifecycle (ChrisPriceAB, 14:36:55)

  9. OPNFV External repo's (ChrisPriceAB, 14:39:27)
    1. Scott Nicholas will be coming to Technical Community call early/mid October for an extended discussion on licensing (rpaik, 14:43:28)
    2. bryan_att adds: my comments were put on onto the email list. Basically we should allow "non-governed" repos as short-term holding places for what we are working on, e.g. upstream project forks, as needed. e.g. we should not restrict the use of github for this purpose - it's an essential path to getting changes upstreamed. (ChrisPriceAB, 14:46:33)
    3. brya_att adds: Every repo should have a license, and the contribution to it is governed by that license. As long as that license is compatible with OPNFV there should be no problem. (ChrisPriceAB, 14:46:45)
    4. external repo discussion should qualify (may be scott can do this) what categories of external repos are there, i.e. some repos are closely reviewed and make sure that license info is always there, others (e.g. personal githubs) handle license info potentially more loosely (frankbrockners, 14:46:46)
    5. ashlee adds that incorporating upstream repositories should ensure that any upstream code repo's should accommodate OPNFV processes and governance. (ChrisPriceAB, 14:48:06)
    6. dneary asks if OPNFV should maintain a clone of upstream repositories that we could branch off locally. (ChrisPriceAB, 14:50:28)
    7. rpaik outlines that such processes are being looked into for some projects (ChrisPriceAB, 14:51:00)
    8. rprakash (rprakash, 14:52:56)
    9. ACTION: rpaik to plan for further discussions on the tech calls and to incorporate the questions and items raised on this call. (ChrisPriceAB, 14:52:57)

  10. Mailing list discussions (ChrisPriceAB, 14:53:16)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-August/012279.html mailing list discussion (rpaik, 14:53:23)
    2. rpaik outlines that there has been some discussion around the potential creation of new mailing lists (ChrisPriceAB, 14:53:45)
    3. the tech-discuss list has become very congested and can be difficult to follow. (ChrisPriceAB, 14:54:05)
    4. rpaik outlines that the proposal includes mailing lists per working groups and some discussion on mailing lists for upstream discussion on request. (ChrisPriceAB, 14:55:05)
    5. bryan_att asks about the "upstream" component of the proposal (ChrisPriceAB, 14:55:38)
    6. rpaik outlines that these would be for active upstream communities to be able to subscribe to focused lists in our communities (ChrisPriceAB, 14:56:14)
    7. ashlee adds that having open and shareable discussion forums are verty useful and he will send an informational e-mail about this shortly. (ChrisPriceAB, 14:57:55)
    8. rpaik proposes that we get started with the working group mailing lists. (ChrisPriceAB, 15:00:35)
    9. AGREED: the TSC agrees to set up the new mailing lists as described. (ChrisPriceAB, 15:01:33)
    10. Could we bring up the "Jira federation with other upstream projects" as a topic in the next TSC - given that we missed it this time? (frankbrockners, 15:02:03)
    11. ACTION: rpaik to report back to the TSC on the list after 3 months (ChrisPriceAB, 15:02:08)
    12. ACTION: chrispriceab to add the Jira discussion to next weeks agenda (ChrisPriceAB, 15:02:22)


Meeting ended at 15:02:36 UTC (full logs).

Action items

  1. rpaik to provide update on the Q4 budget
  2. -> d-release is from now to be referred to as Danube!
  3. rpaik to work with brandon and aric to identify how to manage the artifacts for the release.
  4. rpaik to plan for further discussions on the tech calls and to incorporate the questions and items raised on this call.
  5. rpaik to report back to the TSC on the list after 3 months
  6. chrispriceab to add the Jira discussion to next weeks agenda


Action items, by person

  1. ChrisPriceAB
    1. chrispriceab to add the Jira discussion to next weeks agenda
  2. rpaik
    1. rpaik to provide update on the Q4 budget
    2. rpaik to work with brandon and aric to identify how to manage the artifacts for the release.
    3. rpaik to plan for further discussions on the tech calls and to incorporate the questions and items raised on this call.
    4. rpaik to report back to the TSC on the list after 3 months


People present (lines said)

  1. ChrisPriceAB (64)
  2. rpaik (10)
  3. fdegir (6)
  4. collabot` (4)
  5. frankbrockners (4)
  6. bryan_att (4)
  7. rprakash (3)
  8. dneary (2)
  9. tallgren (2)
  10. trevc (2)
  11. hongbo2 (2)
  12. Julien-zte (2)
  13. rossella_ (1)
  14. Ceciliacorbi (1)
  15. edgarstp (1)
  16. jmorgan1 (1)
  17. morgan_orange (1)
  18. StuartMackie (1)
  19. ulik (1)
  20. bin_ (1)
  21. dku (1)
  22. JonasArndt (1)


Generated by MeetBot 0.1.4.