#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:29 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 15:00:39)
    1. Jack Morgan (Pharos) (jmorgan1, 15:00:50)
    2. Trevor Bramwell (bramwelt, 15:01:09)
    3. Uli Kleber (ulik, 15:02:26)
    4. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:02:57)
    5. Aric Gardner (aricg, 15:03:46)

  2. Hight prio items for Colorado release (fdegir, 15:03:57)
    1. The docker issue with LF POD1 has been fixed (fdegir, 15:06:35)
    2. morgan_orange and trozet fixed the docker issue on LF POD1 jumphost (fdegir, 15:07:03)
    3. jmorgan1 asked armband to add information in to pharos documentation for colorado.1.0 (fdegir, 15:08:01)
    4. The next question is how we should store and make arm fuel isos available on opnfv.org (fdegir, 15:08:40)
    5. ACTION: aricg will check how to present armband artifacts on opnfv.org with LF Webteam and Marketing (fdegir, 15:11:05)

  3. Action Item Followup (fdegir, 15:11:46)
    1. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:12:05)
    2. Follow up the collection of scenario/POD mapping - jmorgan1 (fdegir, 15:12:27)
    3. ACTION: jmorgan1 will continue working on collection of scenario/POD mapping (fdegir, 15:12:43)
    4. Force change ID by setting the "Require Change-Id in commit message" has been implemented by aricg (fdegir, 15:13:12)
    5. Bring up additional build servers done (fdegir, 15:13:57)
    6. ACTION: fdegir install packages on lf-build2 (fdegir, 15:14:10)
    7. ACTION: jmorgan1 to check with Trevor Cooper to find out latest status regarding UCS support (fdegir, 15:15:29)
    8. ACTION: fdegir to check with frankbrockners to see who can help us with UCS in LF POD (fdegir, 15:16:16)
    9. Have a proposal regarding dynamic POD allocation (fdegir, 15:17:13)
    10. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012466.html (fdegir, 15:17:29)
    11. ACTION: Daniel Smith to send the proposal regarding dynamic POD allocation (fdegir, 15:18:06)
    12. Intel POD8 Jenkins connection has been fixed (fdegir, 15:18:36)
    13. Intel POD8 needs to be checked to see if compass jobs can be set to run on this pod (fdegir, 15:19:41)
    14. ACTION: Mei to report the status of POD8 (fdegir, 15:19:53)
    15. Ericsson lab migration has been started (fdegir, 15:20:50)
    16. fdegir will keep Infra WG up to date regarding the migraiton (fdegir, 15:21:08)
    17. Colorado release standup meetings have been setup; modn, thurday, friday (fdegir, 15:21:46)
    18. 8AM pacific (fdegir, 15:21:52)
    19. Prerequisites for CI Evolution plans have been added to Wiki and will be discussed when the topic comes (fdegir, 15:23:12)
    20. Propose mechanism to track upstream contributions using apex as example and make example available in releng repo for infra contributions (fdegir, 15:23:40)
    21. https://gerrit.opnfv.org/gerrit/#/c/21057/ (fdegir, 15:23:50)
    22. ACTION: jmorgan1 Start a new wiki page for resource onboarding (fdegir, 15:31:50)

  4. How to properly scrape html into wiki, there is a paid option (fdegir, 15:33:24)
    1. bramwelt and jmorgan1 had a discussion regarding how to present auto generated docs on Wiki (fdegir, 15:34:18)
    2. Pharos needs to standardize how to document lab information and present it on the wiki (fdegir, 15:35:19)
    3. Pharos to bring this to LF to see if the paid option can be activated (fdegir, 15:36:23)

  5. OPNV-Gerrit-bot too verbose (fdegir, 15:36:38)
    1. OPNV-Gerrit-bot will log info when there is new patchset and when it gets merged (fdegir, 15:37:21)

  6. CI Evolution (fdegir, 15:37:31)
    1. https://wiki.opnfv.org/display/INF/CI+Evolution#CIEvolution-Prerequisites (fdegir, 15:37:52)
    2. Everyone is requested to provide feedback regarding CI Evolution (fdegir, 15:43:35)
    3. Prerequisites must be fulfilled in order for us to proceed with later phases (fdegir, 15:44:26)
    4. ACTION: bramwelt to work with apex to align job structures (fdegir, 15:45:05)

  7. Infra plans and status for D-release (fdegir, 15:46:03)
    1. jmorgan1 has been looking into common configuration files to make this happen for D-release (fdegir, 15:46:42)
    2. jmorgan1 will discuss the subject of common configuration files genesis/installer projects (fdegir, 15:47:35)
    3. A prototype will be created for Intel Lab to use with pharos validator/dashboard to get some progress (fdegir, 15:48:15)
    4. Current scenario handling/naming doesn't scale well and we need to go over this again (fdegir, 15:49:39)
    5. One of the reasons for having scenarios named this way is to increase the readability on Jenkins for example (fdegir, 15:53:22)
    6. An idea could be simply numbering them and storing what a certain scenario consists of which components (fdegir, 15:53:57)
    7. Problem is not just about the naming but about handling them since we have large number of scenarios (fdegir, 15:54:35)
    8. ACTION: ulik to come up with the description of the problem with OPNFV scenario handling and propose way forward (fdegir, 15:56:38)
    9. Handling scenarios with specific needs also require discussion (fdegir, 15:59:58)
    10. Ideas are kept on Wiki and etherpad regarding Dynamic POD allocation/pooling (fdegir, 16:01:01)
    11. https://wiki.opnfv.org/display/INF/Dynamic+Allocation (jmorgan1, 16:01:09)


Meeting ended at 16:02:04 UTC (full logs).

Action items

  1. aricg will check how to present armband artifacts on opnfv.org with LF Webteam and Marketing
  2. jmorgan1 will continue working on collection of scenario/POD mapping
  3. fdegir install packages on lf-build2
  4. jmorgan1 to check with Trevor Cooper to find out latest status regarding UCS support
  5. fdegir to check with frankbrockners to see who can help us with UCS in LF POD
  6. Daniel Smith to send the proposal regarding dynamic POD allocation
  7. Mei to report the status of POD8
  8. jmorgan1 Start a new wiki page for resource onboarding
  9. bramwelt to work with apex to align job structures
  10. ulik to come up with the description of the problem with OPNFV scenario handling and propose way forward


Action items, by person

  1. aricg
    1. aricg will check how to present armband artifacts on opnfv.org with LF Webteam and Marketing
  2. bramwelt
    1. bramwelt to work with apex to align job structures
  3. fdegir
    1. fdegir install packages on lf-build2
    2. fdegir to check with frankbrockners to see who can help us with UCS in LF POD
  4. frankbrockners
    1. fdegir to check with frankbrockners to see who can help us with UCS in LF POD
  5. jmorgan1
    1. jmorgan1 will continue working on collection of scenario/POD mapping
    2. jmorgan1 to check with Trevor Cooper to find out latest status regarding UCS support
    3. jmorgan1 Start a new wiki page for resource onboarding
  6. ulik
    1. ulik to come up with the description of the problem with OPNFV scenario handling and propose way forward
  7. UNASSIGNED
    1. Daniel Smith to send the proposal regarding dynamic POD allocation
    2. Mei to report the status of POD8


People present (lines said)

  1. fdegir (68)
  2. collabot (8)
  3. bryan_att (8)
  4. jmorgan1 (5)
  5. ChrisPriceAB (3)
  6. dmcbride (2)
  7. ulik (2)
  8. frankbrockners (1)
  9. aricg (1)
  10. lhinds (1)
  11. bramwelt (1)
  12. B_Smith (1)


Generated by MeetBot 0.1.4.