#opnfv-meeting: OPNFV TSC Meeting

Meeting started by ChrisPriceAB at 14:00:33 UTC (full logs).

Meeting summary

    1. Dave Neary (dneary, 14:00:36)

  1. Roll Call (ChrisPriceAB, 14:00:37)
    1. Uli Kleber (ulik, 14:00:40)
    2. Chris Price (ChrisPriceAB, 14:00:44)
    3. rprakash (rprakash, 14:00:46)
    4. Rossella Sblendido (rossella_s, 14:00:53)
    5. Edgar StPierre (edgarstp, 14:00:54)
    6. Morgan Richomme (morgan_orange, 14:01:01)
    7. Fatih Degirmenci (fdegir, 14:01:10)
    8. Frank Brockners (frankbrockners, 14:01:16)
    9. Bin Hu (bin_, 14:01:40)
    10. Bryan Sullivan (bryan_att, 14:01:49)
    11. Tapio Tallgren (tallgren, 14:01:53)
    12. Julien (Julien-zte, 14:02:17)
    13. Brian Skerry (bjskerry, 14:02:23)
    14. David McBride (dmcbride, 14:03:07)
    15. Aric Gardner (aricg, 14:03:17)
    16. JonasArndt (JonasArndt, 14:03:23)

  2. Approval of previous minute (ChrisPriceAB, 14:03:48)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-September13,2016 previous minutes (ChrisPriceAB, 14:03:54)
    2. approved not comments (ChrisPriceAB, 14:03:59)

  3. Agenda Bashing (ChrisPriceAB, 14:04:03)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-September20,2016 todays agenda (ChrisPriceAB, 14:04:14)
    2. jack morgan (jmorgan1, 14:05:13)
    3. no further topics for todays agenda (ChrisPriceAB, 14:05:39)

  4. Technical community elections (ChrisPriceAB, 14:05:50)
    1. Committer Board elections are ongoing (Announcement: Sep. 6/Nomination: Sep 13 - 23/Election: Sep 26 - 30/Result: Oct. 3) (ChrisPriceAB, 14:06:11)
    2. TSC Chair elections (Announcement: Sep. 12/Nomination: Sep 19 - 30/Election: Oct. 3 - 7/Result: Oct. 10) (ChrisPriceAB, 14:06:32)

  5. JIRA Federation (ChrisPriceAB, 14:08:37)
    1. frankborckners outlines that there is value in having our activities visible in our upstream communities, and that we can see upstream activities relevant for us. (ChrisPriceAB, 14:09:26)
    2. frank further outlines that by using Jira federation, we would be able to relate to upstream communities using Jira. Identify blocking issues etc. (ChrisPriceAB, 14:10:08)
    3. frank proposes that we try to federate the OPNFV and FD.io Jira as a trial to see how the federation works and if it is useful. (ChrisPriceAB, 14:11:11)
    4. tapio asks frank to elaborate how federation works (ChrisPriceAB, 14:12:07)
    5. frank answers that we could essentially treat federated community projects like we do across our own projects in that we can relate and link to those items and stories. (ChrisPriceAB, 14:12:52)
    6. prakash asks the type of relationship between the Jira instances. Frank responds that it is a peer to peer relationship. (ChrisPriceAB, 14:15:00)
    7. chrispriceab asks if there is any impact on unrelated projects. Frank responds there is no impact. (ChrisPriceAB, 14:15:47)
    8. rpaik adds that when two instances are federated they do need to use the same ldap solution. (This will not be an issue for fd.io, but may be for other projects) (ChrisPriceAB, 14:16:36)
    9. Xavier Costa (NEC) (Xavier__, 14:16:51)
    10. chrispriceab asks if anyone has issue with this proposal (ChrisPriceAB, 14:17:59)
    11. AGREED: the TSC agrees to start this federation trial. (ChrisPriceAB, 14:18:12)
    12. ACTION: frankbrockners to report back to the TSC on this project. (ChrisPriceAB, 14:18:37)

  6. Non Apache-2 license for the Moon project (ChrisPriceAB, 14:18:55)
    1. https://wiki.opnfv.org/display/DEV/Licensing+in+OPNFV licensing in OPNFV (rpaik, 14:19:00)
    2. https://wiki.opnfv.org/download/attachments/2925933/inclusion_of_third-party_open_source_software_template%20v2-MOON-%20Sep13%272016.docx?version=1&modificationDate=1473972647000&api=v2 Moon survey on third party opensource (ChrisPriceAB, 14:20:44)
    3. Ruan outlines the activities in Moon. That they use identify federation across both OpenDaylight and OpenStack. (ChrisPriceAB, 14:21:29)
    4. the Moon roject has developed some code in ODL, to facilitate this which exists in the OPNFV Moon repository (ChrisPriceAB, 14:21:52)
    5. Moon has contributed this to ODL and it is under review, however the patch has not bee merged yet. (ChrisPriceAB, 14:22:20)
    6. Moon asks if it is OK to carry the fork in OPNFV for the Colorado release. This would require an exception to use Eclipse in the repository. (ChrisPriceAB, 14:22:58)
    7. rpaik also outlines that technical community input is necessary to proceed. (ChrisPriceAB, 14:24:13)
    8. dneary asks about the previous discussion around using local mirrors in OPNFV and if we need to approve these types of activities every time. (ChrisPriceAB, 14:26:00)
    9. dnaery asks how many pathes and the volume of code. (ChrisPriceAB, 14:28:16)
    10. ruan answers that there are only 10 adjusted files. (ChrisPriceAB, 14:28:26)
    11. frankbrockners answers that it is more of a legal issue than a technical concern. (ChrisPriceAB, 14:29:14)
    12. the TSC has no objections to this proposal. (ChrisPriceAB, 14:29:59)

  7. Colorado planning and activities (ChrisPriceAB, 14:30:11)
    1. https://wiki.opnfv.org/download/attachments/6819702/09162016_opnfv_jira.txt?version=1&modificationDate=1474380018016&api=v2 colorado release presentation (ChrisPriceAB, 14:30:43)
    2. dmcbride outlines that 11 scenario's are currently failing out of a total of 45. (ChrisPriceAB, 14:31:10)
    3. 18 of our scenario's are currently passing the functest release protocol. (ChrisPriceAB, 14:31:48)
    4. in addition there are 7 scenario's that require further iterations (ChrisPriceAB, 14:32:01)
    5. Currently 24-28 scenario owners have indicated they intend to release for Colorado 1.0 (ChrisPriceAB, 14:32:31)
    6. morgan_orange outlines that the result tables should be interpreted as an incremental scale that does not define stability. (ChrisPriceAB, 14:34:15)
    7. morgan_orange outlines that if the scenario score is above around 80% the system is likely to be stable however there may be a documented limitation to be considered. (ChrisPriceAB, 14:36:06)
    8. dmcbride outlines that Jira resolution looks very good with a small amount of untracked or outstanding issues yet to be closed. (ChrisPriceAB, 14:39:46)
    9. Sofia describes that while a lot of good work has been done to get docs ready there is still some inconsistency and missing documentation remaining. (ChrisPriceAB, 14:41:34)
    10. dmcbride asks if the release should be delayed due to documentation issues, or if they can be resolved in a Colorado 2.0 or 3.0 update (ChrisPriceAB, 14:42:35)
    11. frankbrockners asks what we would be releasing specifically (ChrisPriceAB, 14:43:24)
    12. https://wiki.opnfv.org/display/SWREL/Colorado+Scenario+Status (dmcbride, 14:44:08)
    13. http://artifacts.opnfv.org/opnfvdocs/review/21465/installationprocedure/index.html (sofiawallin, 14:45:12)
    14. ChriPriceAB notes his estimate is that ~30% of the scenarios do not have sufficient documentation (rpaik, 14:45:39)
    15. http://artifacts.opnfv.org/opnfvdocs/review/21465/installationprocedure/index.html the list of scenario's are provided here (ChrisPriceAB, 14:46:39)
    16. morgan_orange adds that generic scenarios are not documented as scenarios in this list which is not a surprise (ChrisPriceAB, 14:47:22)
    17. ACTION: dmcbride to provide a list of candidate scenario's for Colorado and the status of test and documentation for those scenarios. (ChrisPriceAB, 14:57:06)
    18. ACTION: rpaik to set up TSC a call on the 21st to review the state of the Colorado scenarios and status. (ChrisPriceAB, 14:59:09)

  8. AoB (ChrisPriceAB, 14:59:56)
    1. http://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-September/012668.html Open-O Meetup (rpaik, 15:00:35)
    2. There will be an open-o developer event in Seattle next Monday 16:30 - 18:30 following the OpenDaylight and fd.io events that day. (ChrisPriceAB, 15:00:52)


Meeting ended at 15:01:59 UTC (full logs).

Action items

  1. frankbrockners to report back to the TSC on this project.
  2. dmcbride to provide a list of candidate scenario's for Colorado and the status of test and documentation for those scenarios.
  3. rpaik to set up TSC a call on the 21st to review the state of the Colorado scenarios and status.


Action items, by person

  1. dmcbride
    1. dmcbride to provide a list of candidate scenario's for Colorado and the status of test and documentation for those scenarios.
  2. frankbrockners
    1. frankbrockners to report back to the TSC on this project.
  3. rpaik
    1. rpaik to set up TSC a call on the 21st to review the state of the Colorado scenarios and status.


People present (lines said)

  1. ChrisPriceAB (61)
  2. aricg (8)
  3. dmcbride (7)
  4. collabot (5)
  5. trozet (4)
  6. rpaik (4)
  7. dneary (3)
  8. fdegir (3)
  9. morgan_orange (2)
  10. bryan_att (2)
  11. tallgren (1)
  12. bjskerry (1)
  13. edgarstp (1)
  14. jmorgan1 (1)
  15. ulik (1)
  16. frankbrockners (1)
  17. Xavier__ (1)
  18. bin_ (1)
  19. sofiawallin (1)
  20. rprakash (1)
  21. Julien-zte (1)
  22. JonasArndt (1)
  23. rossella_s (1)
  24. jose_lausuch (1)


Generated by MeetBot 0.1.4.