#opnfv-meeting: OPNFV TSC

Meeting started by ChrisPriceAB at 13:59:34 UTC (full logs).

Meeting summary

  1. Roll Call (ChrisPriceAB, 13:59:39)
    1. Chris Price (ChrisPriceAB, 13:59:48)
    2. Mark Beierl (Proxy for Edgar StPierre) (mbeierl, 13:59:50)
    3. hongbo tian (hongbo, 13:59:55)
    4. Fedor Zhadaev (fzhadaev, 14:00:51)
    5. Trevor cooper (trevor_intel_, 14:00:57)
    6. Jack Morgan (jmorgan1, 14:01:14)
    7. dneary (dneary, 14:01:19)
    8. Fatih Degirmenci (fdegir, 14:01:21)
    9. Brian Skerry (bjskerry, 14:01:21)
    10. rprakash (rprakash, 14:01:22)
    11. Morgan Richomme (morgan_orange, 14:01:24)
    12. Bryan Sullivan (bryan_att, 14:01:26)
    13. Szilard Cserey (__szilard_cserey, 14:01:28)
    14. Bin Hu (bin_, 14:01:42)

  2. Approval of previous minutes of meeting (ChrisPriceAB, 14:01:56)
    1. Frank Brockners (frankbrockners, 14:02:05)
    2. Uli Kleber (ulik, 14:02:23)
    3. https://wiki.opnfv.org/display/meetings/TSC#TSC-September27,2016 previous minutes (ChrisPriceAB, 14:02:26)
    4. no comments previous minutes approved. (ChrisPriceAB, 14:02:45)

  3. Agenda Bashing (ChrisPriceAB, 14:02:55)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-October4,2016 todays agenda (ChrisPriceAB, 14:03:14)
    2. Stuart Mackie (StuartMackie, 14:05:05)
    3. no additional topics were proposed. (ChrisPriceAB, 14:05:05)

  4. Technical community elections (ChrisPriceAB, 14:05:17)
    1. TSC Chair (Announcement: Sep. 12/Nomination: Sep 19 - 30/Election: Oct. 3 - 7/Result: Oct. 10) (ChrisPriceAB, 14:06:28)
    2. elections are ongoing. (ChrisPriceAB, 14:06:34)
    3. community recognizes ChrisPriceAB for a job well done as a TSC chair over the past 2 years (rpaik, 14:07:31)

  5. Recap from the OpenDaylight Summit (ChrisPriceAB, 14:07:37)
    1. there was good discussion on Dovetail & VNF Onboarding on Thursday at the ODL Summit (rpaik, 14:09:20)
    2. chrispriceab outlines that the dovetail meeting at the opendaylight summit was spent building awareness (ChrisPriceAB, 14:09:34)
    3. http://meetbot.opnfv.org/meetings/opnfv-polestar/2016/opnfv-polestar.2016-09-29-19.37.html VNF onboarding minutes (rpaik, 14:10:05)
    4. there was also a meeting with OpenDaylight community on future releases alignment (rpaik, 14:12:30)
    5. chrispriceab describes the collaboration sessions was spent focusing on release alignment and testing collaboration between ODL and OPNFV. (ChrisPriceAB, 14:13:22)
    6. IRC log from the Polestar/MANO/models/EUAG meetup: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-polestar/2016/opnfv-polestar.2016-09-29-19.37.log.html (bryan_att, 14:13:31)

  6. Managing Private Keys in OPNFV (ChrisPriceAB, 14:13:55)
    1. lukehinds describes that there has been some discussion around the use of private keys that should result in work activities to improve our security handling in OPNFV. (ChrisPriceAB, 14:14:37)
    2. specifcally there have been multiple private keys stored in repositories for some projects which is generally not considered a best practice. (ChrisPriceAB, 14:15:10)
    3. ash further explains that the reasonaing for including these keys is to facilitate automation. (ChrisPriceAB, 14:15:46)
    4. there may be better ways of achieving automation which the security group will further investigate and describe with the community. (ChrisPriceAB, 14:16:26)
    5. some private keys may be applicable in more than just the automation functions (ChrisPriceAB, 14:17:22)
    6. ash has developed a tutorial that helps people onboard activities in secure fashion. (ChrisPriceAB, 14:18:26)
    7. ACTION: ash to post a tutorial presentation on the security team wiki (rpaik, 14:18:59)
    8. luke and ash discus making it available on the security group wiki. (ChrisPriceAB, 14:19:26)
    9. prakash asks what the relationship is to the CII badge program, luke responds that the CII indicates this should not be done. (ChrisPriceAB, 14:20:05)
    10. lhinds asks for volunteers to help drive this topic. (ChrisPriceAB, 14:21:16)
    11. the Security WG meets wednesdays at 14:00 UTC. (ChrisPriceAB, 14:21:43)
    12. jmorgan1 adds that there is some additional e-mail discussion on this topic (ChrisPriceAB, 14:22:26)
    13. ash volunteers (ChrisPriceAB, 14:23:44)

  7. Danube development and CI/CD processes discussion (ChrisPriceAB, 14:24:24)
    1. Fatih outlines that work is ongoing on the CI evolution activity (ChrisPriceAB, 14:25:06)
    2. https://wiki.opnfv.org/display/INF/CI+Evolution CI evolution wiki, plan and description (ChrisPriceAB, 14:25:18)
    3. fdegir outlines that there have been some additions to the post-merge job as part of the promotion process (ChrisPriceAB, 14:25:44)
    4. https://wiki.opnfv.org/download/attachments/6824933/JenkinsJobStructure_PostMerge.png?version=3&modificationDate=1475590881101&api=v2 (fdegir, 14:25:47)
    5. fatih describes the additional jobs on the above diagram (ChrisPriceAB, 14:26:10)
    6. fdegir notes that experiments will be done with Fuel & Apex and looking for help with other installers (rpaik, 14:27:33)
    7. https://wiki.opnfv.org/download/attachments/6824933/ci_evolution_v2.png?version=1&modificationDate=1475589234060&api=v2 (fdegir, 14:27:52)
    8. the balls in boxes are candidates and the colors are the verdicts taken by merge/daily/weekly jobs (fdegir, 14:28:14)
    9. morgan_orange outlines the importance of this work for the community to begin to leverage our resources more efficiently and do "real CI" (ChrisPriceAB, 14:28:22)
    10. fdegir describes similar framework for testing and this is being discussed with Functest/Yardstick teams (rpaik, 14:33:26)
    11. morgan_orange outlines the benefits of test promotion as a tool to facilitate smoothly onboarding test cases into the test frameworks (ChrisPriceAB, 14:37:56)
    12. the main idea is to apply basic principles for test projects as well by making sure we use the versions of test frameworks/cases that are proven to be working. (fdegir, 14:38:21)
    13. rather than always using latest versions of test fw/cases. (fdegir, 14:38:37)

  8. OPNFV October Board meeting (ChrisPriceAB, 14:39:55)
    1. https://wiki.opnfv.org/download/attachments/2925933/tsc%20board%20update%20october%206th.pdf?version=2&modificationDate=1475591656378&api=v2 latest draft (ChrisPriceAB, 14:40:17)
    2. topics to be covered during the October 6th board meeting are Colorado/Danube releases, updates from the ODL Summit, and joint Board-TSC meeting in Barcelona (rpaik, 14:43:06)
    3. ChrisPriceAB welcomes comments offline (rpaik, 14:45:18)

  9. Colorado + Danube planning and activities (ChrisPriceAB, 14:45:32)
    1. dmcbride describes that once opening Danube for participation we have over 30 projects, including new projects intending to participate in Danube. (ChrisPriceAB, 14:46:45)
    2. dmcbride outlines that release planning is ongoing for Danube and a new template will be presented for discussion on the upcoming release meeting (ChrisPriceAB, 14:47:27)
    3. https://wiki.opnfv.org/display/SWREL/Danube+Milestone+Description Danube Milestone page (rpaik, 14:47:51)
    4. ChrisPriceAB adds that new project proposals need to come forward in the next few weeks (rpaik, 14:48:45)
    5. https://wiki.opnfv.org/display/SWREL/Projects+Intending+to+Participate+in+the+Danube+Release (dmcbride, 14:48:55)
    6. https://wiki.opnfv.org/display/DEV/Project+Inclusion+in+OPNFV+Release (dmcbride, 14:49:24)

  10. OpenStack-Barcelona plans (ChrisPriceAB, 14:49:51)
    1. brandon outlines the activities upcoming on OpenStack barcelona (ChrisPriceAB, 14:50:33)
    2. Brandon notes that Doctor project will be featured during the keynote on Day 1 (rpaik, 14:50:44)
    3. OPNFV will also be featured in 7 sessions (rpaik, 14:51:56)
    4. brandon further outlines OPNFV related topics and discussion occurring during the summit. (ChrisPriceAB, 14:52:16)
    5. there will be an OPNFV booth at the summit, we will be showing demo's at the booth including the Doctor project keynote demo. (ChrisPriceAB, 14:53:00)
    6. OPNFV will also have a booth in the Expo area with demos and there will be a sign-up for booth volunteers (rpaik, 14:54:03)
    7. brandon asks for people to sign up for speanding time at the booth in support of OPNFV (ChrisPriceAB, 14:54:20)
    8. an evening event will be prepared, not yet settled (ChrisPriceAB, 14:54:32)
    9. we are planning for Domino Demo (rprakash, 14:54:55)
    10. there will also be meetings for the end-user advisory group & board (rpaik, 14:55:08)
    11. Brandon reminds us that there will be a face to face board meeting, TSC members are invitade to atend (ChrisPriceAB, 14:55:10)
    12. ACTION: rpaik and chrispriceab to set up a wiki to collect OPNFV related OpenStack summit activity. (ChrisPriceAB, 14:56:19)

  11. AoB (ChrisPriceAB, 14:56:32)
    1. frankbrockners raises concerns that the election tool e-mail is not arriving at every-ones inbox (ChrisPriceAB, 14:57:23)
    2. rpaik will ensure all TSC members are able to vote and can work directly with each member to resolve it. (ChrisPriceAB, 14:58:08)
    3. ulik adds that there is difficulty in ensuring everyone only votes once. (ChrisPriceAB, 14:59:00)


Meeting ended at 15:00:24 UTC (full logs).

Action items

  1. ash to post a tutorial presentation on the security team wiki
  2. rpaik and chrispriceab to set up a wiki to collect OPNFV related OpenStack summit activity.


Action items, by person

  1. ChrisPriceAB
    1. rpaik and chrispriceab to set up a wiki to collect OPNFV related OpenStack summit activity.
  2. rpaik
    1. rpaik and chrispriceab to set up a wiki to collect OPNFV related OpenStack summit activity.


People present (lines said)

  1. ChrisPriceAB (63)
  2. rpaik (16)
  3. fdegir (8)
  4. collabot (7)
  5. bryan_att (7)
  6. hongbo (5)
  7. dmcbride (2)
  8. rprakash (2)
  9. dneary (1)
  10. __szilard_cserey (1)
  11. fzhadaev (1)
  12. frankbrockners (1)
  13. morgan_orange (1)
  14. bin_ (1)
  15. StuartMackie (1)
  16. trevor_intel_ (1)
  17. ulik (1)
  18. bjskerry (1)
  19. mbeierl (1)
  20. jmorgan1 (1)


Generated by MeetBot 0.1.4.