#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:33 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 15:01:14)
    1. Ray Paik (rpaik, 15:01:20)
    2. Jack Morgan (jmorgan1, 15:01:24)
    3. Uli (ulik, 15:01:28)
    4. Trevor Bramwell (bramwelt, 15:01:33)
    5. Fatih Degirmenci (fdegir, 15:01:36)
    6. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:02:15)

  2. Bitergia Dashboads (fdegir, 15:03:18)
    1. Jesus is showing Jenkins Bitergia Dashboard (fdegir, 15:04:14)
    2. https://opnfv.biterg.io/app/kibana#/dashboard/JenkinsOPNFV (fdegir, 15:04:23)
    3. The idea with the Bitergia Jenkins Dashboard is to extract/collect statistics from OPNFV Jenkins (fdegir, 15:10:20)
    4. The information presented on the dashboard includes the use of community resources, jobs, scenarios, job success/failure rate and so on (fdegir, 15:11:14)
    5. The OPNFV Community is requested to take a look/browse through the dashboard and provide feedback regarding issues or additional information (fdegir, 15:11:55)

  3. Tracking upstream contributions with the KISS file (fdegir, 15:13:41)
    1. https://gerrit.opnfv.org/gerrit/#/c/21057/2/UPSTREAM (fdegir, 15:14:03)
    2. The proposal by aricg- lists contributions to upstream projects (fdegir, 15:14:39)
    3. The contributions to track include contributions to upstream repos, bugzilla, launchpad (fdegir, 15:17:35)
    4. this should be even simpler. just a file, per project if needed, that lists the projects and ids of OPNFV members that are contributing to them. Then the tracking tools can just crawl the available datasources. (bryan_att, 15:17:52)
    5. The question is if we should have cross referencing by including one of the systems or list all of them (fdegir, 15:17:55)
    6. bryan_att mentions that Stackalytics shows this type of information and if the people contributing to OpenStack is listed in the file, the contribution infromation can be extracted from Stackalytics (fdegir, 15:20:29)
    7. More granular approach is required (fdegir, 15:21:20)
    8. OPNFV works with multiple different upstream communities and it is needed to collect/present this information (fdegir, 15:21:55)
    9. ACTION: rpaik to discuss how the upstream contributions can be tracked with/for different upstream/OPNFV projects (fdegir, 15:27:34)

  4. ODL -> OPNFV, time to get things moving (fdegir, 15:28:28)
    1. http://slides.com/dfarrell07/odl-delivery-pipelines# (dfarrell07, 15:29:08)
    2. dfarrell07 talks about ODL Delivery Pipelines (fdegir, 15:29:24)
    3. http://slides.com/dfarrell07/odl-delivery-pipelines# (fdegir, 15:29:36)
    4. ODL produces artifacts and corresponding CM pieces (fdegir, 15:30:44)
    5. Artifacts include rpms, debs, and so on (fdegir, 15:30:58)
    6. ODL has been working on automating pieces of their CI/CD pipelines to reduce the human interaction (fdegir, 15:32:18)
    7. ODL Ansible playbooks and Puppet manifests are available (fdegir, 15:34:45)
    8. Docker images and Vagrant boxes are produced as well (fdegir, 15:35:22)
    9. With this, it makes 3 layers (fdegir, 15:36:10)
    10. Package layer, CM layer, Pre-configured images (fdegir, 15:36:41)
    11. Compass and Joid are in talks with ODL, focusing on ansible roles and deb packages (fdegir, 15:38:03)
    12. dfarrell07 started writing proposal for OPNFV Internship to get ODL -> OPNFV work going on (fdegir, 15:51:50)
    13. ACTION: dfarrell07 to post internship project proposal to OPNFV Wiki (fdegir, 15:52:13)
    14. https://wiki.opnfv.org/display/DEV/Intern-projects-page (fdegir, 15:52:42)

  5. OPNFV Infra F2F Session(s) during OpenStack Summit 2016 Barcelona (fdegir, 15:54:18)
    1. https://wiki.opnfv.org/display/INF/OpenStack+Summit+2016+Barcelona+-+F2F+Session+Topics (fdegir, 15:54:27)


Meeting ended at 16:01:57 UTC (full logs).

Action items

  1. rpaik to discuss how the upstream contributions can be tracked with/for different upstream/OPNFV projects
  2. dfarrell07 to post internship project proposal to OPNFV Wiki


Action items, by person

  1. dfarrell07
    1. dfarrell07 to post internship project proposal to OPNFV Wiki
  2. rpaik
    1. rpaik to discuss how the upstream contributions can be tracked with/for different upstream/OPNFV projects


People present (lines said)

  1. fdegir (37)
  2. dfarrell07 (3)
  3. collabot (3)
  4. bryan_att (2)
  5. bramwelt (1)
  6. jmorgan1 (1)
  7. rpaik (1)
  8. ulik (1)


Generated by MeetBot 0.1.4.