#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:57 UTC (full logs).

Meeting summary

  1. Roll Call (fdegir, 15:01:03)
    1. Jun Li (MatthewLi, 15:01:20)
    2. Aric Gardner (aricg, 15:01:23)
    3. Fatih Degirmenci (fdegir, 15:01:29)
    4. Jack Morgan (jmorgan1, 15:01:39)
    5. https://wiki.opnfv.org/display/INF/Infra+Working+Group#InfraWorkingGroup-Agenda (fdegir, 15:01:40)
    6. Dan Smith (DanSmithEricsson, 15:01:53)
    7. Trevor Bramwell (bramwelt, 15:02:10)
    8. Zhijiang Hu (huzhj, 15:02:11)

  2. Dynamic POD Allocation (fdegir, 15:02:19)
    1. Uli (ulik, 15:02:58)
    2. Larry Lamers (ljlamers_, 15:03:54)
    3. David McBride (dmcbride, 15:03:56)
    4. Daniel Smith is talking about possible way to do dynamic POD allocation (fdegir, 15:09:35)
    5. 2 main nodes in this are Jumphost controller and jumphost itself (fdegir, 15:10:06)
    6. OpenStack nodes are not too relevant in this as they are provisioned/installed by installers (fdegir, 15:10:30)
    7. Jumphost controller has different agents handling different tasks (fdegir, 15:11:07)
    8. booking communication agent, hw adapter agent, sw adapter agent, Jumphost boot loader, Jumphost image manager (fdegir, 15:11:37)
    9. Booking tool communicates with Jumphost controller (fdegir, 15:12:58)
    10. Slides will be posted to wiki to collect feedback further (fdegir, 15:28:11)

  3. OPNFV Scenario Handling (fdegir, 15:30:29)
    1. ulik posted slides to Wiki (fdegir, 15:30:38)
    2. https://wiki.opnfv.org/download/attachments/6823941/Scenario-Overview.pptx?api=v2 (fdegir, 15:30:47)
    3. 2 main problems with the current way of handling scenarios are (fdegir, 15:31:33)
    4. Scenario naming (fdegir, 15:31:40)
    5. Scenario consolidation (fdegir, 15:31:46)

  4. Running Dovetail tests on CI PODs (fdegir, 15:41:18)
    1. https://wiki.opnfv.org/display/INF/CI+Scenario+Naming contains the slide deck just presented (ulik, 15:42:13)
    2. CI PODs are for running for production CI and used for release purposes (fdegir, 15:42:57)
    3. ACTION: fdegir jmorgan1 to contact dovetail regarding how to handle resource needs for dovetail (fdegir, 15:45:11)

  5. Opera Infra Needs (fdegir, 15:45:29)
    1. Opera might need a scenario and supporting infra (fdegir, 15:46:14)
    2. We should have a discussion on the MANO WG re the need for scenarios for MANO testing. IMO as noted we should have no direct dependency upon any scenario. MANO components can be installed and unistalled, replaced, etc dyamically as part of test scripts or post-install scripts. (bryan_att, 15:47:01)
    3. As noted in the Models project we will be doing this for a variety of MANO stack components, both to install them (a reusable capability) and then to test them for specific features e.g. TOSCA blueprint compatibility, from onboarding, deployment, lifecycle management, etc. (bryan_att, 15:48:33)
    4. So far we have developed support for Tacker and Cloudify, and OpenBaton, ARIA+JuJu, OSM, etc all can be addressed if we have time resources. These should all run on any scenario. (bryan_att, 15:49:28)
    5. How to handle MANO can be discussed within MANO WG and MANO WG can come up with a common way of handling these (fdegir, 15:50:14)
    6. and of course, very soon (I hope) OpenECOMP! (bryan_att, 15:50:44)
    7. ACTION: yingjui send mail to MANO WG (fdegir, 15:50:44)
    8. Mailing list for MANO WG is mano-wg@lists.opnfv.org (fdegir, 15:51:34)
    9. https://lists.opnfv.org/mailman/listinfo/mano-wg (fdegir, 15:51:47)

  6. Daisy4nfv Infra Needs (fdegir, 15:52:05)
    1. Daisy4nfv can use the existing build servers (fdegir, 15:52:53)
    2. We need to discuss POD needs for Daisy4nfv (fdegir, 15:53:45)
    3. https://wiki.opnfv.org/display/INF/OpenStack+Summit+2016+Barcelona+-+F2F+Session+Topics (fdegir, 15:54:29)
    4. ACTION: fdegir to add topic for POD allocation model during OpenStack summit (fdegir, 15:54:58)

  7. Packaging discussion, rpm/deb (fdegir, 15:55:25)
    1. Community asks solution for rpm/deb (fdegir, 15:55:34)
    2. https://etherpad.openstack.org/p/OPNFV_packaging_CI (aricg, 15:55:34)
    3. There are different ways of producing packages and we might need alignment here (fdegir, 15:56:26)

  8. Co-coordinating with the community on infra updates (fdegir, 15:58:33)
    1. Mails regarding infra updates are sent to tech-discuss (fdegir, 15:58:53)
    2. How can this be improved (fdegir, 15:59:14)
    3. ACTION: aricg to create calendar view for infra updates (fdegir, 16:02:48)


Meeting ended at 16:02:50 UTC (full logs).

Action items

  1. fdegir jmorgan1 to contact dovetail regarding how to handle resource needs for dovetail
  2. yingjui send mail to MANO WG
  3. fdegir to add topic for POD allocation model during OpenStack summit
  4. aricg to create calendar view for infra updates


Action items, by person

  1. aricg
    1. aricg to create calendar view for infra updates
  2. fdegir
    1. fdegir jmorgan1 to contact dovetail regarding how to handle resource needs for dovetail
    2. fdegir to add topic for POD allocation model during OpenStack summit
  3. jmorgan1
    1. fdegir jmorgan1 to contact dovetail regarding how to handle resource needs for dovetail


People present (lines said)

  1. fdegir (43)
  2. collabot (4)
  3. bryan_att (4)
  4. aricg (2)
  5. ulik (2)
  6. ljlamers_ (2)
  7. MatthewLi (1)
  8. bramwelt (1)
  9. huzhj (1)
  10. DanSmithEricsson (1)
  11. dmcbride (1)
  12. jmorgan1 (1)


Generated by MeetBot 0.1.4.