#opnfv-meeting: INFRA Working group weekly call

Meeting started by uli-k at 15:11:50 UTC (full logs).

Meeting summary

  1. roll call (uli-k, 15:18:06)
    1. Trevor Bramwell (bramwelt, 15:18:18)
    2. Larry Lamers (ljlamers, 15:18:25)
    3. Ray Paik (rpaik, 15:18:30)
    4. Mark Beierl (mbeierl, 15:18:31)
    5. Jack Morgan (jmorgan1, 15:18:37)
    6. HelenYao_ (HelenYao_, 15:19:16)
    7. Julien (Julien-zte, 15:19:41)
    8. Lincoln Lavoie (lylavoie, 15:19:56)
    9. https://etherpad.opnfv.org/p/barcelona-infra-f2f (Julien-zte, 15:23:18)

  2. Scenario Descriptor File (uli-k, 15:24:15)
    1. https://gerrit.opnfv.org/gerrit/#/c/23725/2/config/shark.yaml (uli-k, 15:25:28)
    2. Jack introduces how the scenario files will work (uli-k, 15:27:55)
    3. People are encouraged to comment using gerrit (uli-k, 15:28:09)
    4. Bryan notes that the deployment might need to create some additional characterstics during deployment which need to be available to applications/users (uli-k, 15:32:59)
    5. uli-k notes that that should be saved at a different place. (uli-k, 15:33:17)

  3. POD descriptor file (uli-k, 15:34:00)
    1. https://gerrit.opnfv.org/gerrit/#/c/23727/ (uli-k, 15:34:27)
    2. no questions. but please go on commenting on gerrit (uli-k, 15:35:41)
    3. more examples are needed e.g. for remote management via libvirt (uli-k, 15:37:11)
    4. The intent (what should be deployed) is indicated by this file. We also need the resulting config items that were not known prior to deployment, e.g, the generated openstack admin password, somewhere in a file that is the same across deployments. A goal would be that anything which is a choice and *can* be fixed pre-deploy, is pre-defined and made (bryan_att, 15:38:30)

  4. Danube release plan (uli-k, 15:38:34)
    1. ... easily available for test runners, post-install scripts, etc to discover easily. The rest needs to be disclosed through some other file, e.g. admin-openrc in a common place e.g. /opt/opnfv (bryan_att, 15:39:15)
    2. fdegir created a start for the Danube release plan at https://wiki.opnfv.org/display/INF/Danube+Release+Plan (uli-k, 15:39:43)
    3. is "CI Evolution" going to include the gated promotion idea talked about earlier? (bryan_att, 15:40:49)
    4. ACTION: jmorgan1 and uli-k to update the release plan for Pharos and Octopus (uli-k, 15:40:59)
    5. https://git.opnfv.org/cgit/releng/tree/jjb/fuel/fuel-verify-jobs.yml (bramwelt, 15:43:38)
    6. ACTION: fdegir to document how to control the commit gating (uli-k, 15:43:47)

  5. Review Intern Project: ODL->OPNFV Integration (uli-k, 15:45:11)
    1. intern for the ODL->OPNFV integration project should be able to start next week (rpaik, 15:46:08)
    2. she will be working ~20hours/week for 6 months (rpaik, 15:46:25)

  6. PODs by Daisy4nfv installer (uli-k, 15:46:56)
    1. julien informs that the PODs are available, work is ongoing about CI integration of the PODs (uli-k, 15:49:41)
    2. ACTION: julien-zte to provide information which 2 PODs are provided (uli-k, 15:50:52)
    3. I will give the update from the team (Julien-zte, 15:50:55)

  7. action items (uli-k, 15:51:15)
    1. ZTE POD will run 2 Fuel scenarios: nosdn-ovs and kvm. (uli-k, 15:56:53)
    2. close the AI. (uli-k, 15:57:14)
    3. AI of scenario handling can be closed. (uli-k, 15:59:31)
    4. AI on scenario/POD mapping is ongoing (uli-k, 16:01:03)


Meeting ended at 16:02:05 UTC (full logs).

Action items

  1. jmorgan1 and uli-k to update the release plan for Pharos and Octopus
  2. fdegir to document how to control the commit gating
  3. julien-zte to provide information which 2 PODs are provided


Action items, by person

  1. jmorgan1
    1. jmorgan1 and uli-k to update the release plan for Pharos and Octopus
  2. Julien-zte
    1. julien-zte to provide information which 2 PODs are provided
  3. uli-k
    1. jmorgan1 and uli-k to update the release plan for Pharos and Octopus


People present (lines said)

  1. uli-k (29)
  2. bryan_att (8)
  3. ljlamers (7)
  4. Julien-zte (6)
  5. jmorgan1 (6)
  6. rpaik (5)
  7. bramwelt (4)
  8. collabot` (4)
  9. mbeierl (2)
  10. lylavoie (1)
  11. HelenYao_ (1)


Generated by MeetBot 0.1.4.