#opnfv-meeting: Weekly OPNFV TSC meeting

Meeting started by tallgren at 15:00:33 UTC (full logs).

Meeting summary

    1. Jack Morgan (jmorgan1, 15:01:32)
    2. Bin Hu (bin_, 15:01:41)
    3. Uli Kleber (uli-k, 15:01:57)
    4. Tapio Tallgren (tallgren, 15:02:04)
    5. David McBride (dmcbride, 15:02:36)
    6. Jonas Bjurel (Stand in for Fatih) ([1]JonasB, 15:02:53)
    7. Moragn Richomme (morgan_orange, 15:03:09)
    8. XavierCosta (XavierCosta, 15:03:17)
    9. Edgar StPierre (edgarstp, 15:03:24)
    10. Trevor Cooper for Brian Skerry (trevor_intel_, 15:03:41)
    11. Bryan Sullivan (bryan_att, 15:03:58)
    12. Tim Rozet (proxy for dave neary) (trozet, 15:04:07)
    13. Julien (Julien-zte, 15:04:40)

  1. Approval of previous meeting minutes (tallgren, 15:04:59)
  2. Agenda bashing (uli-k, 15:05:16)
    1. Tim Irnich (timirnich, 15:06:08)
    2. proposal to add discussion on meeting overlaps (uli-k, 15:06:14)
    3. tallgren informs (again) that Colorado 2.0 got released. (uli-k, 15:06:59)
    4. tallgren clarifies also the download page is in place now. (uli-k, 15:07:28)
    5. https://www.opnfv.org/software/download (dmcbride, 15:07:29)

  3. Goals & vision for the Danube release (uli-k, 15:07:51)
    1. morgan_orange says that he received no feedback on his presentation (dmcbride, 15:08:43)
    2. presentation is online (dmcbride, 15:08:55)
    3. morgan_orange asks how should we make a decision about "CI Evolution" project? (dmcbride, 15:09:40)
    4. https://wiki.opnfv.org/display/meetings/TSC?preview=%2F2925933%2F8684550%2FBuilding+a+TSC+vision+for+Danube.pptx (jose_lausuch, 15:09:59)
    5. https://wiki.opnfv.org/download/attachments/2925933/Building%20a%20TSC%20vision%20for%20Danube.pptx?version=1&modificationDate=1478612403000&api=v2 (uli-k, 15:09:59)
    6. https://specs.openstack.org/openstack/nova-specs/priorities/newton-priorities.html (tallgren, 15:12:17)
    7. IMO the deck also adressess multiple topics and thus may have been hard to have a succinct response to. (bryan_att, 15:13:04)
    8. morgan_orange says that having a vote will put weight behind a request to the board for resources (dmcbride, 15:13:40)
    9. e.g. re CI evolution I fully support that, but let's address that separately from the other concerns expressed in the deck. (bryan_att, 15:13:47)
    10. I think that projects that need resource should ask for them directly (bryan_att, 15:15:01)
    11. If CI evolution needs resources to be realized then let's focus on that specifically and not widen to assess priority across projects with the presumption that this would result in more resources going to "top priority" projects. I don't think that would have the intended effect or a useful one overall. (bryan_att, 15:18:45)
    12. I agree, we are producing several scenarios that represent options that end-users can pick, as part of an overall set of platform options. (bryan_att, 15:21:47)
    13. Julien-zte asks how we define our "reference platform" (dmcbride, 15:22:06)
    14. morgan_orange asserts that we have multiple reference platforms (dmcbride, 15:22:28)
    15. Thus not a single/unified platform but a flexible toolbox of tested platform components from which a platform can be created. This represents a platform, even if there isn't a single installable product produced by OPNFV. (bryan_att, 15:22:54)
    16. I'm all for setting expectations that new scenarios come with dedicated resources, including people and lab resources. (bryan_att, 15:24:02)
    17. IMO scenarios are in some cases a "necessary evil" at this point (due to simple incompatibility) and in others a choice of a sub-community (e.g. Open-O). Both cases while "valid" do not come for free; thus we need explicit resources to support them, provided by the scenario supporters. (bryan_att, 15:27:16)
    18. https://etherpad.opnfv.org/p/TestCommunityGoals (morgan_orange, 15:28:11)
    19. other groups (e.g. MANO) should also develop a list of priorities (dmcbride, 15:29:05)
    20. a wiki page in which people input their vision/priorities makes sense to me (bryan_att, 15:29:10)
    21. I just caution against codifying that vision/priority and using it in any restrictive way. We can and should address the resourcing issue separately. (bryan_att, 15:30:52)
    22. ACTION: morgan_orange send mail + create etherpad on Danube, E, ..priorities to the community (morgan_orange, 15:32:23)
    23. jmorgan1 suggests that every WG should create a list of priorities, then those lists can be integrated into a master list (dmcbride, 15:33:00)
    24. morgan_orange that looks like the result of some assessment of the collected vision/priorities. So it's at least a couple of steps down the road (collect input, assess input, create vision/priority statement, agree upon that statement, publish it) (bryan_att, 15:34:36)
    25. AGREED: Every project and every working group should create a list of priorities. (uli-k, 15:35:36)
    26. ACTION: tallgren will start a wiki page (uli-k, 15:38:20)

  4. •Colorado + Danube planning and activities (uli-k, 15:38:41)
    1. Discussion is about how the OpenStack and OPNFV releases will match. (tallgren, 15:40:06)
    2. OpenStack Ocate will have a shorter release and will be mainly maintenance release (tallgren, 15:41:06)
    3. dmcbride has sent out a questionnaire to all PTLs about Ocata plan (tallgren, 15:41:59)
    4. Proposal is: Danube will be based on Newton and E-release will be based on Pike. Ocata would be skipped (tallgren, 15:43:18)
    5. https://wiki.opnfv.org/display/COM/Release+Dates (tallgren, 15:51:19)
    6. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-functest/2016/opnfv-functest.2016-11-15-08.01.html (morgan_orange, 15:52:01)
    7. Functest agreed that Newton client will be integrated for Danube (morgan_orange, 15:53:16)
    8. https://wiki.opnfv.org/display/functest/OpenStack+python+clients (morgan_orange, 15:53:38)
    9. ACTION: dmcbride update upstream roadmap pagae (dmcbride, 15:53:55)
    10. https://wiki.opnfv.org/display/COM/Release+Dates (dmcbride, 15:54:07)
    11. jose_lausuch says that functest is committed to using OS Newton. Have not planned to support other versions within the Danube time frame. (dmcbride, 15:55:17)

  5. meeting schedule (uli-k, 15:56:59)
    1. morgan_orange it would be good for the Functest team to send out an outlook calendar invite as I didn't have this on my calendar and would like to have joined (if I had been up at 4AM) (bryan_att, 15:59:23)
    2. a single always-available meeting per account would ensure that at least meetings are never cancelled by someone starting the next (bryan_att, 16:00:23)
    3. ACTION: dmcbride to work on a proposal to resolve the meeting schedule issue (uli-k, 16:01:53)


Meeting ended at 16:02:27 UTC (full logs).

Action items

  1. morgan_orange send mail + create etherpad on Danube, E, ..priorities to the community
  2. tallgren will start a wiki page
  3. dmcbride update upstream roadmap pagae
  4. dmcbride to work on a proposal to resolve the meeting schedule issue


Action items, by person

  1. dmcbride
    1. dmcbride update upstream roadmap pagae
    2. dmcbride to work on a proposal to resolve the meeting schedule issue
  2. morgan_orange
    1. morgan_orange send mail + create etherpad on Danube, E, ..priorities to the community
  3. tallgren
    1. tallgren will start a wiki page


People present (lines said)

  1. tallgren (19)
  2. bryan_att (18)
  3. dmcbride (16)
  4. uli-k (13)
  5. morgan_orange (9)
  6. ChrisPriceAB (8)
  7. jose_lausuch (8)
  8. collabot` (7)
  9. StevenW (6)
  10. rpaik (4)
  11. Julien-zte (2)
  12. trevor_intel_ (1)
  13. timirnich (1)
  14. trozet (1)
  15. edgarstp (1)
  16. bin_ (1)
  17. [1]JonasB (1)
  18. XavierCosta (1)
  19. jmorgan1 (1)


Generated by MeetBot 0.1.4.