#opnfv-meeting: Weekly TSC meeting

Meeting started by tallgren at 14:59:49 UTC (full logs).

Meeting summary

    1. Tapio Tallgren (tallgren, 15:00:01)
    2. Uli Kleber (uli-k, 15:00:02)
    3. Mark Beierl (Proxy for Edgar StPierre) (mbeierl, 15:00:04)
    4. Bin Hu (bh526r, 15:00:21)
    5. Rossella Sblendido (rossella_s, 15:00:39)
    6. Morgan Richomme (morgan_orange, 15:01:01)
    7. Brian Skerry (bjskerry, 15:01:04)
    8. Fatih Degirmenci (fdegir, 15:01:05)
    9. Tim Irnich (timirnich, 15:01:08)
    10. bryan Sullivan (bryan_att, 15:02:07)

  1. approval of previous minutes (rpaik, 15:02:09)
    1. Jack Morgan (jmorgan1, 15:02:10)
    2. no comments on the minutes this previous minutes approved (rpaik, 15:02:25)
    3. xavier costa (XavierCosta, 15:02:26)

  2. agenda bashing (rpaik, 15:02:56)
    1. Stuart Mackie (StuartMackie, 15:03:30)
    2. Julien (Julien-zte, 15:03:58)
    3. Trevor Cooper (trevor_intel_, 15:04:24)
    4. Ash suggests discussing the Discourse tool trial (rpaik, 15:04:31)
    5. Dave Neary (dneary, 15:04:50)
    6. Chris Price (substituting for Hongbo) (ChrisPriceAB, 15:04:59)

  3. TSC meeting around the holidays (rpaik, 15:05:30)
    1. there will be a sufficient number of TSC representatives to run a meeting next week. (ChrisPriceAB, 15:06:59)
    2. AGREED: the TSC agrees to hold a meeting on the 20th of December (ChrisPriceAB, 15:07:43)
    3. meeting on the Dec 27 will be cancelled (ChrisPriceAB, 15:07:55)
    4. dmcbride notes that release meeting will follow the same pattern as the TSC meeting (rpaik, 15:08:09)

  4. December Board meeting updates (ChrisPriceAB, 15:08:16)
  5. board meeting summary (rpaik, 15:08:17)
    1. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-December/014070.html board meeting summary (rpaik, 15:08:32)
    2. http://techdiscuss.yunify.org (new discussion forum) (ashyoun__, 15:08:53)
    3. ttallgren outlines the TSC budget approved for 2017, including a technical writer to help establish needed user and community documentation (ChrisPriceAB, 15:09:43)
    4. ttallgren outlines a discussion around the OPNFV architecture discussion, which has lead to a discourse board for further discussion (ChrisPriceAB, 15:10:28)
    5. additionally the CVP (compliance and verification program) was discussed, the CVP paper has been distributed to TSC members for comment and feedback. (ChrisPriceAB, 15:11:34)
    6. TSC members are asked to provide feedback by 5pm PT on Wed (14th) (rpaik, 15:12:08)
    7. http://techdiscuss.yunify.org/ link to the discourse page where the architecture is being discussed (ChrisPriceAB, 15:12:10)

  6. Plugfest/Hacks update (rpaik, 15:12:35)
    1. We will discuss CI integration of scanning on tomorrow's security call (ashyoun__, 15:13:00)
    2. There will be a whitepaper produced following the plugfest, lincoln will be editor in cheif (ChrisPriceAB, 15:14:32)
    3. we had 70 people attending the Plugfest representing 23 organizations (rpaik, 15:14:47)

  7. Colorado/Danube planning and activities (rpaik, 15:15:11)
    1. Colorado 3.0 released last week (rpaik, 15:15:41)
    2. dmcbride notes that Milestone 5 & 6 are upcoming milestone (rpaik, 15:16:15)
    3. for milestone 2 dmcbride is following up on movie and orchestra teams (rpaik, 15:17:24)
    4. for milestone 3 follow-up is required for compass & daisy (rpaik, 15:18:09)
    5. Apex, Fuel and Joid are compliant with Milestone 3 for Danube (tallgren, 15:18:11)

  8. Danube priorities discussion (rpaik, 15:18:31)
    1. https://wiki.opnfv.org/pages/viewpage.action?pageId=8686146 (morgan_orange, 15:18:57)
    2. morgan_orange notes that for Danube CI is one of the main priorities and trying to come up with a name/tagline (rpaik, 15:20:55)
    3. the placeholder name is "Real CI Ready" for Danube (rpaik, 15:21:10)
    4. other priorities for testing and documentation were also listed on the wiki (rpaik, 15:22:00)
    5. there's also a section on future release priorities (rpaik, 15:22:49)
    6. morgan_orange encourages community members to continue contributing to the wiki page (rpaik, 15:24:51)
    7. bryan_att notes that this should be done before the next release starts (rpaik, 15:27:19)
    8. we should be doing the E release sooner, like now (bjskerry, 15:27:19)
    9. bryan_att asks what is the practical effect of these priorities? (bjskerry, 15:28:08)
    10. also a question on what is the practical impact of this decision and what is in "Core" (rpaik, 15:28:14)
    11. one of the impacts could be milestone definitions (with additional criteria) (rpaik, 15:29:10)
    12. the community could also make resource request to the Board (rpaik, 15:29:46)
    13. bryan_att notes we need to have a plug and play approach for different features (bjskerry, 15:32:04)
    14. morgan_orange should have some convergence on what each installer supports (bjskerry, 15:33:28)
    15. bryan_att counters it could be put on the feature projects to put them across all installers (bjskerry, 15:34:03)
    16. community members are encouraged to review/provide feedback on the "Danube community priorities" section and the TSC can vote on the priorities on Jan. 3, 2017 (rpaik, 15:35:48)

  9. Common configuration file and scenario naming (rpaik, 15:38:12)
    1. discussion on "core" features, and how we should get them across more installers; i.e. who owns it (bjskerry, 15:38:17)
    2. https://wiki.opnfv.org/download/attachments/8686731/Dynamic%20CI%20v2.pptx?version=1&modificationDate=1481634903265&api=v2 presentation on Dynamic CI Pipeline (rpaik, 15:40:14)
    3. uli-k discusses the goal of the common configuration file (rpaik, 15:41:19)
    4. the first step was to get an agreement on the common config files (which was reached at the Plugfest/Hackfest last week) (rpaik, 15:44:22)
    5. status on our effort https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2016-December/014038.html (jmorgan1, 15:44:22)
    6. ChrisPriceAB suggests doing a proof of concept to validate the concept (rpaik, 15:45:15)
    7. uli proposes a step-wise approach (bjskerry, 15:46:02)
    8. rosella_s suggested also looking at how OpenStack does this (rpaik, 15:47:49)
    9. jmorgan1 pod descriptors are done, please provide feedback (bjskerry, 15:48:33)
    10. community members should provide feedback on the presentation over the next two week before the TSC call on January 3rd (rpaik, 15:49:18)
    11. uli on scenario consolidation: big number of scenarios; some scenarios can be combined based on overlap (bjskerry, 15:49:48)
    12. uli: scenarios may be needed for development, but maybe not for release (bjskerry, 15:50:19)

  10. OpenRetriever creation review (rpaik, 15:51:20)
    1. Xuan discusses the project proposal that aims to create a platform to manage containers and VM (rpaik, 15:53:12)
    2. proposal is to use Container Orchestrator Engine with Kubernetes and OpenStack-Newton (rpaik, 15:55:44)
    3. focus will be on how VNFs are running on containers (rpaik, 15:56:19)
    4. will not be participating in the D-release, but will have a number of work items (rpaik, 16:00:13)
    5. proxy for bryan_att (rpaik, 16:01:36)
    6. VOTE: Voted on "does TSC approve creation of the OpenRetriever project?" Results are, 0: 2, +1: 13 (rpaik, 16:01:58)


Meeting ended at 16:02:29 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. rpaik (54)
  2. ChrisPriceAB (24)
  3. collabot (15)
  4. bjskerry (13)
  5. ashyoun__ (9)
  6. tallgren (8)
  7. jmorgan1 (8)
  8. dneary (6)
  9. fdegir (6)
  10. morgan_orange (4)
  11. timirnich (3)
  12. bh526r (2)
  13. uli-k (2)
  14. dmcbride (2)
  15. Julien-zte (2)
  16. rossella_s (2)
  17. mbeierl (2)
  18. naga (1)
  19. StuartMackie (1)
  20. XavierCosta (1)
  21. trevor_intel_ (1)
  22. bryan_att (1)


Generated by MeetBot 0.1.4.