#opnfv-meeting: OPNFV TSC

Meeting started by rpaik at 15:00:17 UTC (full logs).

Meeting summary

  1. rollcall (rpaik, 15:00:27)
    1. Bin Hu (bh526r, 15:00:36)
    2. Hongbo Tian (hongbo222, 15:00:37)
    3. Tapio Tallgren (tallgren, 15:00:42)
    4. Fatih Degirmenci (fdegir, 15:00:46)
    5. Uli Kleber (uli-k, 15:00:50)
    6. Brian Skerry (bjskerry, 15:00:53)
    7. Jack Morgan (jmorgan1, 15:01:02)
    8. Jose Lausuch (Tim Irnich' proxy) (jose_lausuch, 15:01:06)
    9. Xavier Costa (XavierCosta, 15:01:41)
    10. Morgan Richomme (morgan_orange, 15:01:45)
    11. Frank Brockners (frankbrockners, 15:01:49)

  2. approval previous minutes (rpaik, 15:02:14)
    1. no comments on minutes thus approved (rpaik, 15:02:26)

  3. agenda bashing (rpaik, 15:02:37)
    1. https://wiki.opnfv.org/display/meetings/TSC#TSC-February7,2017 today's agenda (rpaik, 15:03:07)
    2. Julien (Julien-zte, 15:03:08)
    3. Bryan Sullivan (bryan_att, 15:03:52)
    4. naga chumbalkar (naga_, 15:04:50)
    5. jmorgan1 will bring back the pod descriptor file next week (rpaik, 15:05:40)
    6. Stuart Mackie (StuartMackie, 15:05:45)
    7. no other topics for today (rpaik, 15:06:40)
    8. HELP: (naga_, 15:06:46)

  4. board meeting update (rpaik, 15:06:51)
    1. tallgren noted that the last Board meeting was focused on CVP discussions and several agenda topics including TSC update was not covered (rpaik, 15:08:35)
    2. C&C committee members participated inthe Board meeting for the CVP discussion (rpaik, 15:09:27)

  5. termination review (rpaik, 15:10:03)
    1. bryan_att notes that the PolicyTest project never took off since formation and a number of committers are no longer part of the OPNFV community (rpaik, 15:11:39)
    2. future work will likely be done in other projects like Copper (rpaik, 15:12:01)
    3. VOTE: Voted on "does the TSC approve terminating the PolicyTest project?" Results are, +1: 12 (rpaik, 15:13:21)
    4. TSC approves terminating the PolicyTest project (rpaik, 15:13:33)
    5. there was a question on ovn4nfv project will let the discussion continue on mailing lits (rpaik, 15:14:34)

  6. committer removal process (rpaik, 15:14:48)
    1. https://www.opnfv.org/software/technical-project-governance/tsc-charter TSC Charter (rpaik, 15:15:10)
    2. The current TSC charter describes how the PTL can request from the TSC a permission to remove the committer (tallgren, 15:16:02)
    3. Some PTLs have said that this process is too complicated (tallgren, 15:16:50)
    4. discussion on if the vote is needed or if an email notification is sufficient (rpaik, 15:18:53)
    5. The current practice is to vote on the TSC, but the charter does not require this (tallgren, 15:19:02)
    6. jmorgan1 also suggest 1-2 week review period after notification (rpaik, 15:19:50)
    7. ACTION: rpaik to draft a new text in the TSC Charter for community review (rpaik, 15:26:29)
    8. morgan_orange also discusses cases when committers are inactive for ~6 months (rpaik, 15:27:31)
    9. rpaik discusses regular reports of inactive committers that can be communicated to PTLs (rpaik, 15:29:16)

  7. Danube planning (rpaik, 15:29:33)
    1. dmcbride gave an update on MS5 and noted that 13 projects compliant/8 non-compliant/5 projects unreported (rpaik, 15:30:40)
    2. MS5 report: 13 compliant, 8 non-compliant, 5 not reported (tallgren, 15:30:47)
    3. MS6 is coming up one week from Friday (tallgren, 15:31:15)
    4. MS 6 is February 17th (rpaik, 15:31:19)
    5. https://wiki.opnfv.org/display/SWREL/Milestone+Compliance+for+Danube (rpaik, 15:31:51)
    6. https://wiki.opnfv.org/pages/viewpage.action?pageId=8690599 (dmcbride, 15:33:23)
    7. IRC-only release meeting for APAC (rpaik, 15:33:55)
    8. dmcbride notes that comparison with previous releases are little difficult as he's being more strict on milestone compliance (rpaik, 15:34:33)
    9. dmcbride has been working with PTLs of non-compliant project to determine the status but some maybe deferring to the E-release (rpaik, 15:36:26)
    10. discussion if there needs to be a better evaluation for MS3 (OpenStack integration) (rpaik, 15:40:36)
    11. https://wiki.opnfv.org/pages/viewpage.action?pageId=8690432 milestone exception process (rpaik, 15:41:15)
    12. dmcbride discusses options for milestone exceptions process (starting with the E-release) (rpaik, 15:42:55)
    13. suggestion to continue the discussion on Thursday technical community meeting (rpaik, 15:48:15)

  8. project creation review for SNAPS-OO (rpaik, 15:48:31)
    1. https://wiki.opnfv.org/display/PROJ/SNAPS-OO (RandyL_, 15:48:34)
    2. RandyL gives an overview of the proposal and noted that libraries have been used by Apex & Functest teams (rpaik, 15:50:41)
    3. code is Apache-2 and the plan is to move the code to OPNFV repo (rpaik, 15:51:26)
    4. jose_lausuch confirmed that Functest team plans to leverage some of the SNAPS-OO libraries (rpaik, 15:54:39)
    5. VOTE: Voted on "does the TSC approve creation of the SNAPS-OO project?" Results are, +1: 12 (rpaik, 15:58:29)
    6. project creation approved for SNAPS-OO (rpaik, 15:58:44)


Meeting ended at 15:59:31 UTC (full logs).

Action items

  1. rpaik to draft a new text in the TSC Charter for community review


Action items, by person

  1. rpaik
    1. rpaik to draft a new text in the TSC Charter for community review


People present (lines said)

  1. rpaik (48)
  2. collabot (13)
  3. tallgren (9)
  4. morgan_orange (5)
  5. uli-k (4)
  6. jmorgan1 (4)
  7. Julien-zte (3)
  8. naga_ (3)
  9. fdegir (3)
  10. StuartMackie (3)
  11. XavierCosta (3)
  12. jose_lausuch (3)
  13. bjskerry (3)
  14. frankbrockners (2)
  15. bh526r (2)
  16. hongbo222 (2)
  17. ChrisPriceAB (2)
  18. dmcbride (1)
  19. RandyL_ (1)
  20. bryan_att (1)


Generated by MeetBot 0.1.4.