#opnfv-meeting: Infra WG Weekly Meeting
Meeting started by fdegir at 16:00:09 UTC
(full logs).
Meeting summary
- Roll Call (fdegir, 16:00:14)
  - Jack Morgan (jmorgan1,
    16:01:12)
- Thaj (thaj,
    16:01:22)
- Fatih Degirmenci (fdegir,
    16:02:19)
- Chris Price (ChrisPriceAB,
    16:02:31)
- GTM
    https://global.gotomeeting.com/join/819733085 (ChrisPriceAB,
    16:03:38)
- Rudy (basic`,
    16:03:55)
 
 
- Agenda Bashing (fdegir, 16:04:48)
  - https://wiki.opnfv.org/display/INF/Infra+Working+Group
    (fdegir,
    16:04:52)
 
 
- Handling INFRA JIRA Issues (fdegir, 16:05:14)
  - fdegir proposes that Jira tickets should be
    closed if they are idle for a month or so (ChrisPriceAB,
    16:07:23)
- the infra wg chair will take care of the infra
    Jira list during his/her tenure (ChrisPriceAB,
    16:07:59)
- jackmorgan1 proposes a one week notice period
    should be provided to prompt action (ChrisPriceAB,
    16:08:33)
- AGREED: The infra WG
    chair will track Jira tasks and should notify prior to closing
    tickets before a one month idle timeout period (ChrisPriceAB,
    16:09:05)
 
 
- Pharos Architecture/Spec Change Request Process (fdegir, 16:09:24)
  - https://wiki.opnfv.org/display/INF/Pharos+Architecture+Change+Request+Process
    (fdegir,
    16:10:37)
- Everyone is welcomed to provide comments to
    change request process (fdegir,
    16:11:33)
 
 
- Handling access requests to OPNFV resources located in LF Lab (fdegir, 16:11:47)
  - OPNFV has 5 PODs in LF Lab (fdegir,
    16:12:00)
- https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
    (fdegir,
    16:14:30)
- THe above list contains the opnfv community
    members with the access to resources (fdegir,
    16:14:45)
- The access requests to resources located in LF
    Lab should be submitted to INFRA JIRA project (fdegir,
    16:15:44)
- If the access request is needed for emergency
    fixes, Infra WG Chair has authority to approve the request
    (fdegir,
    16:16:03)
- ACTION: basic` to
    update the list on
    https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
    (fdegir,
    16:16:48)
- AGREED: LF Lab
    resources will be handled via INFRA JIRA Project (fdegir,
    16:17:05)
 
 
- Issues with huawei-pod1 (fdegir, 16:17:15)
  - gsutil has been removed on huawei-pod1 jumphost
    without any advance notice (fdegir,
    16:19:24)
- It is important to keep CI PODs in known state
    so the CI is not disturbed by changes done to jumphosts for
    example (fdegir,
    16:22:09)
- This will become even more important when we
    move into dynamic POD allocation (fdegir,
    16:24:15)
- An idea could be to move installers into VMs on
    jumphosts but this might not be possible for all the
    installers (fdegir,
    16:25:09)
- Another idea is (re)provisioning jumphosts
    before each run (fdegir,
    16:25:26)
- ACTION: bryan_att to
    check the possibility of moving JOID into a VM (fdegir,
    16:26:43)
- ACTION: fdegir to
    check what Compass is doing (do they use VMs) (fdegir,
    16:27:03)
- ACTION: jmorgan1 to
    check what Daisy is doing (do they use VMs) (fdegir,
    16:27:22)
 
 
- OPNFV Cloud (fdegir, 16:27:45)
  - General discussion regarding the possibility of
    providing an OPNFV Baremetal Deployment to ODL for provisioning VMs
    to use for ODL CI. (fdegir,
    16:31:21)
- We will discuss this more coming weeks
    (fdegir,
    16:33:36)
 
 
- Action Item Review (fdegir, 16:34:30)
  - ACTION: jmorgan1
    Follow up with JOID project on hardware resources request for Europe
    or North American based POD (fdegir,
    16:34:58)
- ACTION: Documenting
    OPNFV Infra like how OpenStack does on ReadTheDocs (fdegir,
    16:36:03)
- ACTION: jmorgan1
    fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI (fdegir,
    16:36:50)
- ACTION: jmorgan1
    Julien Provide an example for POD descriptor file from ZTE
    labs (fdegir,
    16:37:39)
 
 
- AOB (fdegir, 16:38:25)
  - jmorgan1 talks about POD descriptor file and
    storing them in securedlab repo (fdegir,
    16:38:48)
- Lab owners get access to securedlab by asking
    to become pharos-contributor (fdegir,
    16:41:08)
- Lab owners create jenkins users for their labs
    and ask to get permissions for this user for securedlab repo
    (fdegir,
    16:41:45)
- jmorgan1 will present a tool which is similar
    to Ironic (fdegir,
    16:42:23)
- Intel will open source the tool (fdegir,
    16:42:28)
- Moving installers to VMs can be a topic for
    plugfest/hackfest (fdegir,
    16:45:07)
- ACTION: fdegir to
    create page for plugfest/hackfest planning (fdegir,
    16:45:24)
 
Meeting ended at 16:46:17 UTC
(full logs).
Action items
  - basic` to update the list on https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
- bryan_att to check the possibility of moving JOID into a VM
- fdegir to check what Compass is doing (do they use VMs)
- jmorgan1 to check what Daisy is doing (do they use VMs)
- jmorgan1 Follow up with JOID project on hardware resources request for Europe or North American based POD
- Documenting OPNFV Infra like how OpenStack does on ReadTheDocs
- jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
- jmorgan1 Julien Provide an example for POD descriptor file from ZTE labs
- fdegir to create page for plugfest/hackfest planning
Action items, by person
  -  fdegir 
    - fdegir to check what Compass is doing (do they use VMs)
- jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
- fdegir to create page for plugfest/hackfest planning
 
-  jmorgan1 
    - jmorgan1 to check what Daisy is doing (do they use VMs)
- jmorgan1 Follow up with JOID project on hardware resources request for Europe or North American based POD
- jmorgan1 fdegir uli-k Present OPNFV Infra Roadmap to Dynamic CI
- jmorgan1 Julien Provide an example for POD descriptor file from ZTE labs
 
- UNASSIGNED
    - basic` to update the list on https://wiki.opnfv.org/display/pharos/Lf+Lab#LfLab-OPNFVCommunityMemberswithAccesstoOPNFVLFLab
- bryan_att to check the possibility of moving JOID into a VM
- Documenting OPNFV Infra like how OpenStack does on ReadTheDocs
 
People present (lines said)
  - fdegir (46)
- ChrisPriceAB (7)
- collabot` (4)
- basic` (2)
- thaj (2)
- jmorgan1 (2)
- jose_lausuch (1)
Generated by MeetBot 0.1.4.