#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 15:00:28 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 15:00:33)
    1. Jack Morgan (jmorgan1, 15:00:57)
    2. Thaj (thaj, 15:01:00)
    3. Uli (uli-k, 15:01:03)
    4. Chris Price (ChrisPriceAB, 15:01:10)

  2. Dovetail requirements on Infra (fdegir, 15:02:01)
    1. uli-k explains what requirements Dovetail needs on Infra (fdegir, 15:03:16)
    2. Dovetail will test different scenarios and due to us not being able to share the PODs between different installers, Dovetail needs to run tests on different PODs per installer (fdegir, 15:04:02)
    3. Dan Radez (radez, 15:04:45)
    4. Dovetail can be run as part of usual daily jobs (fdegir, 15:05:33)
    5. Dovetail tests currently take about 30 minutes to run but this time will probably increase going forward (fdegir, 15:06:06)
    6. Once Danube release is totally out, PODs might be moved to master, possible causing issues for Dovetail (fdegir, 15:08:46)
    7. It is important to separate the support/resource needs for platform testing and support/resource needs for Dovetail development (fdegir, 15:13:10)
    8. ACTION: uli-k Matthew Li to come up with different options for further discussion (fdegir, 15:14:27)

  3. Flex Community Pharos lab introduction (fdegir, 15:15:14)
    1. Flex is planning to have an OPNFV Pharos Lab (fdegir, 15:16:19)
    2. Lab will be made available by early may (fdegir, 15:16:39)
    3. The lab will have OCP hardware (fdegir, 15:16:57)
    4. Flex will present their lab during next Infra WG Meeting (fdegir, 15:18:12)

  4. OPNFV Project's needs for creating additional Git (sub) repositories (fdegir, 15:18:28)
    1. Apex has 2 repositories keeping forks of upstream triple-o repositories in Github for staging until they are taken by upstream (fdegir, 15:19:40)
    2. Some people can't contribute to these repositories due to different issues and having repos hosted by OPNFV would help with these issues (fdegir, 15:20:26)
    3. jmorgan1 asks who will own these repositories (fdegir, 15:21:51)
    4. radez/aricg answer that the repositories will be owned by the requesting projects which is Apex in this case (fdegir, 15:22:35)
    5. This helps with the workflow of the OPNFV projects (dependency relations between changes, etc.) (fdegir, 15:23:46)
    6. Releng has similar needs to get additional repositories to ease the development effort (fdegir, 15:26:33)
    7. uli-k adds that we need to make sure the people should be able to find these repositories (fdegir, 15:27:18)
    8. This will be an addition on top of github and does not prevent people from putting stuff to github (fdegir, 15:28:46)
    9. There are different use cases that need to be documented (fdegir, 15:30:55)
    10. ACTION: aricg radez to work on creating an additional repo for Apex to trial this before bringing topic to TSC (fdegir, 15:32:31)
    11. ACTION: aricg fdegir to work on creating an additional repo for Releng to trial this before bringing topic to TSC (fdegir, 15:35:14)

  5. Pros and cons of different docker registries (fdegir, 15:35:56)
    1. Due to Amazon S3 outages, Docker Hub was impacted hitting OPNFV (fdegir, 15:36:42)
    2. Google is blocked in China which might not be a solution (fdegir, 15:36:54)
    3. Staying with what we have now might be the best option for the timebeing (fdegir, 15:38:27)
    4. This topic can be discussed during ONS (fdegir, 15:40:18)

  6. Review Danube Release Plan - Are we on track? (fdegir, 15:41:09)
    1. Infra Projects Danube Release Plan (fdegir, 15:41:46)
    2. https://wiki.opnfv.org/display/INF/Danube+Release+Plan (fdegir, 15:41:48)
    3. https://wiki.opnfv.org/display/INF/Infra_CleanUp (fdegir, 15:42:55)
    4. Moving installers to VMs on jumphost is one of the critical items (fdegir, 15:51:22)
    5. It is important to have release status check for the Infra plans (fdegir, 15:52:03)

  7. Organizing content in Infra Wiki space (fdegir, 15:52:25)
    1. The proposal is on https://wiki.opnfv.org/display/INF/Infra_CleanUp (fdegir, 15:52:53)
    2. ACTION: jmorgan1 fdegir uli-k to discuss what can be moved to RTD and what can stay on Wiki (fdegir, 15:55:37)
    3. There will be dochaton which the above item can become part of that effort (fdegir, 15:56:38)

  8. Secruity Group integration with the Infra WG (fdegir, 15:58:20)
    1. lhinds brought the topic to Infra projects PTLs (fdegir, 15:58:44)
    2. This will be discussed in more detail during one of the Infra WG (fdegir, 15:59:05)

  9. AOB (fdegir, 15:59:31)
    1. We need to discuss the effects of new project proposals on Infra (fdegir, 15:59:57)


Meeting ended at 16:00:31 UTC (full logs).

Action items

  1. uli-k Matthew Li to come up with different options for further discussion
  2. aricg radez to work on creating an additional repo for Apex to trial this before bringing topic to TSC
  3. aricg fdegir to work on creating an additional repo for Releng to trial this before bringing topic to TSC
  4. jmorgan1 fdegir uli-k to discuss what can be moved to RTD and what can stay on Wiki


Action items, by person

  1. aricg
    1. aricg radez to work on creating an additional repo for Apex to trial this before bringing topic to TSC
    2. aricg fdegir to work on creating an additional repo for Releng to trial this before bringing topic to TSC
  2. fdegir
    1. aricg fdegir to work on creating an additional repo for Releng to trial this before bringing topic to TSC
    2. jmorgan1 fdegir uli-k to discuss what can be moved to RTD and what can stay on Wiki
  3. jmorgan1
    1. jmorgan1 fdegir uli-k to discuss what can be moved to RTD and what can stay on Wiki
  4. radez
    1. aricg radez to work on creating an additional repo for Apex to trial this before bringing topic to TSC
  5. uli-k
    1. uli-k Matthew Li to come up with different options for further discussion
    2. jmorgan1 fdegir uli-k to discuss what can be moved to RTD and what can stay on Wiki


People present (lines said)

  1. fdegir (50)
  2. ChrisPriceAB (5)
  3. collabot` (3)
  4. radez (2)
  5. aricg (1)
  6. collabot (1)
  7. thaj (1)
  8. uli-k (1)
  9. jmorgan1 (1)


Generated by MeetBot 0.1.4.