#opnfv-meeting: dovetail weekly meeting

Meeting started by hongbo12123 at 13:00:31 UTC (full logs).

Meeting summary

    1. Hongbo (hongbo12123, 13:01:29)
    2. Georg Kunz (georgk, 13:01:37)
    3. Wenjing (Wenjing, 13:01:42)
    4. Thaj (thaj, 13:01:47)
    5. Lincoln Lavoie (lylavoie, 13:02:08)
    6. Jun Li (MatthewLi, 13:02:27)

  1. action items review (hongbo12123, 13:03:55)
  2. Test strategy doc and task assignments (hongbo12123, 13:05:38)
    1. https://wiki.opnfv.org/display/meetings/Dovetail (hongbo12123, 13:06:21)
    2. Trevor Cooper (trevor_intel_, 13:07:17)
    3. wenjing went over the stratety page (hongbo12123, 13:08:59)
    4. https://jira.opnfv.org/browse/DOVETAIL-352 (Wenjing, 13:09:00)
    5. there is jira ticket for the docoment of dovetail strategies (hongbo12123, 13:09:58)
    6. Two action items in last week’s minutes, which we will cover: (dneary, 13:10:53)
    7. #action detail the steps for the user for the workflow (dneary, 13:10:53)
    8. #action the dovetail team to review the document patch (dneary, 13:10:53)
    9. Agenda for April 7: (dneary, 13:10:53)
    10. - Test strategy doc and task assignments – there is an outstanding action item for everyone to review the patch and consider contributions: https://gerrit.opnfv.org/gerrit/#/c/32499/ (dneary, 13:10:53)
    11. - Plugfest activity planning: what should we get done: - Who are going to be there; - What tests we need to do – start testing the software toolchain, the full workflow and test guide docs; - Equipment and installer/scenario combinations; - Review new test areas that are ready (dneary, 13:10:55)
    12. Test area review status and we need to reach agreement on process. Also take a look at the sdnvpn submission as an example to follow. (dneary, 13:10:59)
    13. Test case description to help testers and reviewers understand/diagnose etc. – what is needed and what approach to add the descriptions: - The refstack cases; - Other feature cases (dneary, 13:11:04)
    14. Tools discussion (this is a placeholder in case additional discussion is needed) (dneary, 13:11:09)
    15. Jira plan still not in good shape – how do we get there before plugfest in 2 weeks. (dneary, 13:11:11)
    16. Update on the action item: CVP workflow, discussion with LF/Jose et al on hosting, login and related jira task to dovetail. (dneary, 13:11:13)
    17. Last minute comments on update to TSC/Board. (dneary, 13:11:16)

  3. Test strategy document (dneary, 13:12:34)
    1. Wenjing asks if we can confirm 3 things: (dneary, 13:12:47)
    2. 1. Is the skeleton for the test strategy doc good enough? (dneary, 13:13:02)
    3. 2. Who can volunteer to help write the sections? (dneary, 13:13:44)
    4. Trevor suggests that we need 3 documents: (dneary, 13:14:40)
    5. Test Strategy (trevor_intel_, 13:16:14)
    6. https://gerrit.opnfv.org/gerrit/#/c/32499/ (georgk, 13:16:31)
    7. Guide for developing the tool (dneary, 13:17:07)
    8. The guide to adding new tests to the Dovetail suite (dneary, 13:17:18)
    9. The test user guide: How to prepare a system, run the test suite, and validate the results (dneary, 13:18:44)
    10. https://gerrit.opnfv.org/gerrit/#/c/32499/1 (trevor_intel_, 13:19:30)
    11. Dave says his understanding is that the test strategy document is supposed to be destined for how to validate conformance - target audience is people testing an SUT (dneary, 13:19:50)
    12. Dave suggests a glossary of terms - there is clearly some confusion. (dneary, 13:25:46)
    13. Trevor suggests that the top priority should be the requirements document of which test areas and test cases we want to develop, and the workflow for proposing tests for inclusion in the test suite (dneary, 13:26:52)
    14. Georg and Trevor say that what the test cases are, and how they are added to the tool to be run by Dovetail, is a critical tasks, very practical, and the highest priority (dneary, 13:30:28)
    15. Wenjing agrees with Dave that expectations of the SUT and how to run the test suite is the highest priority (dneary, 13:32:09)
    16. Dave also suggests that "tool development guide" is not a good name, since adding a test case should not require changing the test tool (dneary, 13:32:37)
    17. Trevor proposes writing a draft document for tool requirements (in terms of what the tool needs to do for testing specific test areas) (dneary, 13:36:40)
    18. Sections 3,4,5 of test strategy document are around expectations of the SUT (preparing staging hosts, network configuration, and SUT configuration requirements) - Dave suggests the infra team is the natural owner. Wenjing spoke to Jack who is prepared to help (dneary, 13:43:10)
    19. dave to talk with chri to find some one for the security section (hongbo12123, 13:43:44)
    20. Section 6 (test suite execution and reporting) seems like something the testing WG should own (dneary, 13:43:56)
    21. Dave will talk to Chris to clarify if the Security section is around the security of test reporting and validation, or security considerations for the SUT (dneary, 13:44:36)
    22. Dave will also approach the security WG to see if they can help with this section (dneary, 13:45:18)
    23. Since Security is now under the Infra WG, Wenjing will also discuss the security section with the Infra working group (dneary, 13:49:00)
    24. Uli is in the Infra group, and has volunteered to take the action item to bring the security concerns back to the Infra WG (dneary, 13:50:13)

  4. Plugfest activity planning (dneary, 13:50:50)
    1. https://wiki.opnfv.org/display/dovetail/Dovetail+PlugFest+Plan+April+24-28 (hongbo12123, 13:50:58)
    2. https://wiki.opnfv.org/pages/viewpage.action?pageId=9569132 (trevor_intel_, 14:04:14)
    3. Hands-on lab track: Goal is to test Dovetail on non-Pharos hardware end-to-end (dneary, 14:12:09)
    4. Other tracks to propose: Trevor proposed some performance testing (dneary, 14:12:42)
    5. Plugfest - proposed add topics to Hackfest planning page 1) review docs 2) planning (trevor_intel_, 14:13:17)
    6. Georg proposed declaring specific goals for plugfest outcomes, to focus people on an objective (dneary, 14:13:27)
    7. Wenjing proposed reviewing test areas during plugfest as many project participants will be in Paris (dneary, 14:14:05)
    8. Dave proposed moving back to 1h meetings, as he finds 90 minute meetings a bit long (dneary, 14:15:33)
    9. AGREED: Revert to 60 minute meetings unless there is a specific need for more time (dneary, 14:15:49)


Meeting ended at 14:17:09 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. dneary (45)
  2. hongbo12123 (14)
  3. trevor_intel_ (6)
  4. collabot` (5)
  5. georgk (3)
  6. Wenjing (2)
  7. MatthewLi (1)
  8. thaj (1)
  9. lylavoie (1)
  10. jmorgan1 (1)
  11. trevor_intel (0)


Generated by MeetBot 0.1.4.