#opnfv-meeting: Infra working group

Meeting started by uli-k at 15:01:25 UTC (full logs).

Meeting summary

    1. Julien (Julien-zte, 15:01:30)

  1. roll-call (uli-k, 15:01:33)
    1. Thaj (thaj, 15:01:42)

  2. documentation cleanup (uli-k, 15:05:45)
    1. On hackfest we planned the way to using read-the-docs (uli-k, 15:06:06)
    2. jmorgan1 mentioned documents for end users and devide currently documents into separate parts (Julien-zte, 15:07:28)
    3. ACTION: aricg provide the missing module for documentation tools in infra repo so patch 33935 will verify +1 (uli-k, 15:11:37)
    4. Julien-zte proposes to cover APIs for all projects (uli-k, 15:13:49)
    5. Trevor clarifies that this is responsibilitiy of the opnfvdocs project (uli-k, 15:14:14)
    6. ACTION: everybody to send comments to the patch. (uli-k, 15:18:53)

  3. hackfest review (uli-k, 15:19:07)
    1. ACTION: Create JIRA tickets to create PDF for LF and Ericsson labs Jose Lausuch  (uli-k, 15:21:33)
    2. ACTION: Create JIRA tickets to create PDF for Intel and Huawei labs Jack Morgan (uli-k, 15:21:46)
    3. ACTION: Create JIRA tickets for PDF converter, 1 per installer aricg (uli-k, 15:22:20)
    4. there are some information still missing in the pdf, so that shall be added to the template. (uli-k, 15:25:51)
    5. during the work on the converter file, we will find some of these gaps. (uli-k, 15:26:17)
    6. : config files are added for compass. Patch is : https://gerrit.opnfv.org/gerrit/#/c/34341/1 (thaj, 15:27:14)
    7. https://gerrit.opnfv.org/gerrit/#/c/34281/ (aricg, 15:27:53)
    8. Julien-zte clarifies that daisy installer currently runs in VMs and they plan to use PDF natively. (uli-k, 15:34:21)
    9. : Aric: Basically Jenkins will clone the repo and do deployment. In case of PDF in secured lab, how jenkins will do cloning for PDF config files? (thaj, 15:35:18)
    10. aricg clarifies that all jumphosts currently run centos (uli-k, 15:37:31)
    11. Open whether Ericsson labs use Ubuntu (uli-k, 15:38:39)
    12. AGREED: Jumphosts should run the newest Centos version (uli-k, 15:40:19)
    13. ACTION: jmorgan1 to add that to Pharos spec (uli-k, 15:40:33)
    14. daisy creates new installer VM from an image (uli-k, 15:41:44)
    15. ACTION: Clarify how Compass create installer VM instances Ulrich Kleber (uli-k, 15:42:01)
    16. ACTION: Create JIRA ticket for adjustments for jenkins jobs to support dynamic POD allocation Fatih Degirmenci (uli-k, 15:43:38)
    17. before we implement that, we need to have installers be able to use PDF information (natively or via converter) (uli-k, 15:44:15)
    18. ACTION: Create Jira ticket for installers to consume PDF information aricg (uli-k, 15:45:54)
    19. ACTION: Update step 1 in scenario workflow to ensure the pool is not an installer pool but CI POD pool Ulrich Kleber (uli-k, 15:47:24)
    20. ACTION: Add slide in scenario workflows on CI POD to reflect the process better Ulrich Kleber (uli-k, 15:47:43)
    21. ACTION: Create non-voting security scanning jobs (verify and periodic) Luke Hinds (uli-k, 15:48:05)
    22. reach out to community to develop user stories to better tailor documentation (rtd and wiki) for various classes of users (end users vs developers etc) (aricg, 15:50:05)
    23. uli-k mentions octopus will focus on scenario file work items. (Julien-zte, 15:51:11)
    24. list of current octopus submitters https://gist.github.com/Aricg/9753c12914244f573dd735ba5f2fc05b (aricg, 15:53:22)
    25. Best current idea is to be the first in OPNFV to consolidate projects. (uli-k, 15:56:00)
    26. But that should mean combine all the infra projects and also clean up some like genesis and bgs (uli-k, 15:57:51)
    27. AGREED: think about it and decide later. (uli-k, 15:58:06)

  4. Migration of stackalytics.com for OPNFV (uli-k, 16:02:11)
    1. Julien shows the kind of statistics that can be created that way. (uli-k, 16:02:35)
    2. there are a large number of "independent" people contributing, because the register with non-company account. (uli-k, 16:03:20)
    3. the tools cannot use source from different hosts in parallel. (uli-k, 16:03:47)


Meeting ended at 16:08:26 UTC (full logs).

Action items

  1. aricg provide the missing module for documentation tools in infra repo so patch 33935 will verify +1
  2. everybody to send comments to the patch.
  3. Create JIRA tickets to create PDF for LF and Ericsson labs Jose Lausuch 
  4. Create JIRA tickets to create PDF for Intel and Huawei labs Jack Morgan
  5. Create JIRA tickets for PDF converter, 1 per installer aricg
  6. jmorgan1 to add that to Pharos spec
  7. Clarify how Compass create installer VM instances Ulrich Kleber
  8. Create JIRA ticket for adjustments for jenkins jobs to support dynamic POD allocation Fatih Degirmenci
  9. Create Jira ticket for installers to consume PDF information aricg
  10. Update step 1 in scenario workflow to ensure the pool is not an installer pool but CI POD pool Ulrich Kleber
  11. Add slide in scenario workflows on CI POD to reflect the process better Ulrich Kleber
  12. Create non-voting security scanning jobs (verify and periodic) Luke Hinds


Action items, by person

  1. aricg
    1. aricg provide the missing module for documentation tools in infra repo so patch 33935 will verify +1
    2. Create JIRA tickets for PDF converter, 1 per installer aricg
    3. Create Jira ticket for installers to consume PDF information aricg
  2. jmorgan1
    1. jmorgan1 to add that to Pharos spec
  3. UNASSIGNED
    1. everybody to send comments to the patch.
    2. Create JIRA tickets to create PDF for LF and Ericsson labs Jose Lausuch 
    3. Create JIRA tickets to create PDF for Intel and Huawei labs Jack Morgan
    4. Clarify how Compass create installer VM instances Ulrich Kleber
    5. Create JIRA ticket for adjustments for jenkins jobs to support dynamic POD allocation Fatih Degirmenci
    6. Update step 1 in scenario workflow to ensure the pool is not an installer pool but CI POD pool Ulrich Kleber
    7. Add slide in scenario workflows on CI POD to reflect the process better Ulrich Kleber
    8. Create non-voting security scanning jobs (verify and periodic) Luke Hinds


People present (lines said)

  1. uli-k (39)
  2. collabot (6)
  3. aricg (4)
  4. Julien-zte (3)
  5. thaj (3)
  6. jmorgan1 (0)


Generated by MeetBot 0.1.4.