#opnfv-meeting: Weekly TSC meeting

Meeting started by tallgren at 13:59:24 UTC (full logs).

Meeting summary

    1. Tapio Tallgren (tallgren, 14:00:12)
    2. Morgan Richomme (IRC only) (morgan_orange, 14:00:16)
    3. Uli (uli-k, 14:00:17)
    4. hongbo (hongbo2839, 14:00:18)
    5. rprakas (rprakash, 14:00:22)
    6. Frank Brockners (frankbrockners, 14:00:29)
    7. Bin Hu (bh526r, 14:00:35)
    8. Fatih Degirmenci (fdegir, 14:00:40)
    9. Carlos Goncalves (proxy for Xavier Costa) (cgoncalves, 14:00:45)
    10. Jack Morgan (jmorgan1, 14:00:48)
    11. Brian Skerry (bjskerry, 14:01:03)
    12. Tim Irnich (timirnich, 14:01:16)

  1. approval of previous minutes (rpaik, 14:02:23)
    1. Rossella Sblendido (rossella_, 14:02:38)
    2. no comments thus previous minutes approved (rpaik, 14:02:40)
    3. Mark Beierl (proxy for Edgar StPierre) (mbeierl, 14:02:42)
    4. Bryan Sullivan (bryan_att, 14:03:02)
    5. no other agenda topics suggested (rpaik, 14:03:34)

  2. annual award reminder (rpaik, 14:03:43)
    1. Annual awards voting ends tomorrow (tallgren, 14:04:02)

  3. Danube/Euphrates planning (rpaik, 14:05:12)
    1. Dave Neary (dneary, 14:05:59)
    2. Trevor Cooper (trevor_intel_, 14:06:20)
    3. dmcbride notes that there's a full compliance on MS2 for Euphrates (with Escalator dropping out) (rpaik, 14:06:25)
    4. MS3 (installer integration) is today and dmcbride will be following up with installer teams (rpaik, 14:07:01)
    5. daily meetings will start for Danube 3.0 (rpaik, 14:07:24)
    6. Danube 3 is coming out on June 8th. It is the last Danube release (tallgren, 14:07:27)
    7. dmcbride reviewed 3 sub-milestones for MS3 and noted that there's no change to the overall release schedule (rpaik, 14:10:23)
    8. 3.0 is OpenStack integration + nosdn + Functest support for health check (rpaik, 14:11:29)
    9. 3.1 is installers passing health check (rpaik, 14:12:16)
    10. 3.2 is deploying integrated SDN scenario and passing health check (rpaik, 14:12:52)
    11. MS4 will be "test framework ready" (rpaik, 14:15:09)
    12. for SDN controllers, it's up to the team to deploy which controller is deployed (rpaik, 14:17:31)
    13. discussion on adding a similar milestone for Kubernetes (rpaik, 14:19:23)
    14. fuqiao (fuqiao, 14:20:03)
    15. suggestion to change OpenStack/Kubernetes to VIM (rpaik, 14:20:23)
    16. Kubernetes does not work with Functest at the moment but this is planned within the next two weeks (tallgren, 14:21:05)
    17. So the Functest+Kubernetes integration will be ready by MS4 (Test case ready) (tallgren, 14:21:40)
    18. Julien (Julien-zte, 14:25:37)
    19. 3.0 is OpenStack integration + nosdn + Functest support for health check/3.1 is installers passing health check/3.2 is deploying integrated SDN scenario and passing health check (rpaik, 14:26:24)
    20. with 2-3 weeks in between each milestone (mbeierl, 14:27:05)
    21. 3.0 is OpenStack integration + nosdn/no feature + Functest support for health check (rpaik, 14:27:38)
    22. VOTE: Voted on "does the TSC approve additional sub-milestones for Milestone 3?" Results are, 0: 1, +1: 16 (rpaik, 14:28:34)
    23. https://wiki.opnfv.org/download/attachments/2925933/MS3%20MS4%20changes.pdf?version=1&modificationDate=1496154486772&api=v2 (dmcbride, 14:28:44)

  4. Dovetail discussion/approval (rpaik, 14:28:59)
    1. Wenjing reviewed the overall CVP process and went over files for test cases (e.g. for BGPVPN) (rpaik, 14:33:34)
    2. It is not decided at the moment whether all tests need to pass for certification (tallgren, 14:34:13)
    3. there is still no consensus on optional test cases (whether one needs to pass optional test cases or not) (rpaik, 14:34:28)
    4. ACTION: trevor_intel_ and DoveTail team, add a description on what level of test case passing should be enough to pass the CVP into to the addendum for Danube. :) (ChrisPriceAB, 14:34:51)
    5. there are also docs for test case requirements, user documentation, and Danube addendum (rpaik, 14:36:50)
    6. https://wiki.opnfv.org/display/dovetail/Dovetail+Documentation+for+Review (rpaik, 14:37:15)
    7. test results will be captured in testresults.opnfv.org (rpaik, 14:38:19)
    8. The CVP program will be announced (but not launched) in the Summit (tallgren, 14:40:07)
    9. CVP will be introduced at the upcoming Summit (i.e. our intent), but this will not be an official launch (rpaik, 14:40:09)
    10. frankbrockners asked if all mandatory tests are subset of OpenStack tests (as all tests in IPV6, HA, BGPVPN are optional) (rpaik, 14:43:11)
    11. dneary notes that focus has been on documentation prior to test cases becoming mandatory (rpaik, 14:46:16)
    12. discussion if there's a need to define a "bar" that is actually testing OPNFV (rpaik, 14:50:17)
    13. decision on mandatory/optional tests were made by individual project teams (rpaik, 14:52:16)
    14. rosella asks what the process for determining mandatory or optional test cases is. (ChrisPriceAB, 14:52:17)
    15. Tim gives an example of why he selected to be optional, due to not all NFVi will support SDNVPN features. At this time a criteria for selection has not yet been documented. (ChrisPriceAB, 14:53:25)
    16. tallgren asks if we need an optional section to the testing at this time. As there are very few optional test cases at this time. (ChrisPriceAB, 14:55:31)
    17. rpaik asks what the TSC is being asked for today (ChrisPriceAB, 14:59:26)
    18. frankbrockners adds that the comments from the TSC indicate DoveTail is heading in the right direction however it is too early approve the scope as a program. (ChrisPriceAB, 15:00:43)
    19. timirnich asks that the TSC provides input to the project as to what tests would be valuable to be added to the test suites for the CVP (ChrisPriceAB, 15:01:13)
    20. frankbrockers states that a good starting point would be to ensure we evaluate the key features provided as market messages for any given release. (ChrisPriceAB, 15:02:04)
    21. frankbrockners adds that key ingredients of the release should be tested in the CVP (rpaik, 15:02:06)
    22. timirnich states items like robustness are key for OPNFV, beyond what the existing refstack test cases provide. (ChrisPriceAB, 15:02:50)


Meeting ended at 15:05:53 UTC (full logs).

Action items

  1. trevor_intel_ and DoveTail team, add a description on what level of test case passing should be enough to pass the CVP into to the addendum for Danube. :)


Action items, by person

  1. trevor_intel_
    1. trevor_intel_ and DoveTail team, add a description on what level of test case passing should be enough to pass the CVP into to the addendum for Danube. :)


People present (lines said)

  1. rpaik (38)
  2. tallgren (12)
  3. collabot` (12)
  4. ChrisPriceAB (10)
  5. jmorgan1 (5)
  6. cgoncalves (4)
  7. mbeierl (4)
  8. morgan_orange (3)
  9. hongbo2839 (3)
  10. dneary (2)
  11. bh526r (2)
  12. rossella_ (2)
  13. bjskerry (2)
  14. fuqiao (2)
  15. fdegir (2)
  16. frankbrockners (2)
  17. uli-k (2)
  18. Julien-zte (2)
  19. timirnich (2)
  20. bryan_att (2)
  21. trevor_intel_ (1)
  22. dmcbride (1)
  23. rprakash (1)


Generated by MeetBot 0.1.4.