#opnfv-meeting: Infra WG Meeting

Meeting started by fdegir at 15:02:43 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 15:02:51)
    1. Ray Paik (rpaik, 15:02:51)
    2. Jose Lausuch (jose_lausuch, 15:02:53)
    3. Luke Hinds (lhinds, 15:02:57)
    4. Aric Gardner (aricg-, 15:02:58)
    5. radez (radez, 15:02:59)
    6. Thaj (thaj, 15:03:16)
    7. Uli (uli-k, 15:03:33)

  2. LaaS (fdegir, 15:03:46)
    1. https://wiki.opnfv.org/display/INF/Lab+as+a+Service (fdegir, 15:04:08)
    2. Bryan Sullivan (bryan_att, 15:04:13)
    3. Julien (Julien-zte, 15:05:18)
    4. LaaS will simplify developer access for readily deployed scenarios. (uli-k, 15:07:30)
    5. LaaS aims to provide one-click deployments of OPNFV (fdegir, 15:07:39)
    6. Apart from providing OPNFV deployments, it can also provide just OS installation on a number of machines so developers can do everything from scratch (fdegir, 15:09:09)
    7. the necessary things we need to have to be able to go forward here are: (uli-k, 15:11:18)
    8. 1. hardware resources (uli-k, 15:11:26)
    9. 2. human resources for the maintenance and for the implemention of the LaaS specifics (uli-k, 15:11:53)
    10. 3. dynamic CI needs to be available, (uli-k, 15:12:12)
    11. fdegir if PDF and SDF are supported by installers, the dynamic pod can supported easily (Julien-zte, 15:12:39)
    12. we don't need the full dynamic CI, but all installers need to use the PDF (uli-k, 15:13:24)
    13. we already have some hardware that we can use for LaaS (uli-k, 15:18:55)
    14. We need to finalize BoM which is listed on Wiki (fdegir, 15:22:13)
    15. https://wiki.opnfv.org/display/INF/Lab+as+a+Service#LabasaService-LaaSHardware (fdegir, 15:22:15)
    16. ACTION: bryan_att Clarify HW requirements for ONAP (fdegir, 15:23:31)
    17. We need to come up with rough cost estimates for development/CI purposes to have an idea about how much it would cost to run this on public cloud vs hosted environment (fdegir, 15:25:22)
    18. bryan_att explains that ONAP part may run in a cloud environment and connect to a LaaS POD (uli-k, 15:27:26)
    19. ACTION: Bryan_att Provide some use cases on the LaaS page so we can go a second step (uli-k, 15:36:48)
    20. further discussion next week based on that use cases. (uli-k, 15:38:10)
    21. Once we come up with initial usecases, we need to ask OPNFV Installers to see which ones can support them (fdegir, 15:38:14)

  3. ONAP and OPNFV Lab sharing and XCI (uli-k, 15:38:59)
    1. https://wiki.opnfv.org/display/COM/ONAP?preview=/11700125/11700646/ONAP-OPNFV%20%20lab%20sharing.png (bryan_att, 15:39:41)
    2. https://wiki.opnfv.org/display/COM/ONAP (bryan_att, 15:39:57)
    3. there needs to be some more details specified about these connections: ONAP will connect to management interface, while tests, and traffic go to different planes. (uli-k, 15:45:09)
    4. Security also needs to be considered (uli-k, 15:45:23)
    5. Bryan_att proposes to prototype this in OPNFV (uli-k, 15:45:55)
    6. LaaS can be such prototype. (uli-k, 15:47:40)
    7. thus we now go forward with LaaS and then specify more details for this lab sharing .... (uli-k, 15:48:06)
    8. agree uli-k, we'd better start from LaaS and then considering other features. (Julien-zte, 15:48:53)
    9. labs.opnfv.org (Julien-zte, 15:48:59)
    10. labs.opnfv.org (Julien-zte, 15:49:19)
    11. another future action is to connect the Pharos dashboard with the LaaS, but let's go first steps first (uli-k, 15:51:10)

  4. LF status page (uli-k, 15:51:38)
    1. we already have status.opnfv.org (uli-k, 15:51:53)
    2. http://status.opnfv.org (rpaik, 15:52:07)
    3. but we should link that from wiki (uli-k, 15:52:11)
    4. fdegir proposes directly from Infra page (uli-k, 15:52:29)
    5. https://wiki.opnfv.org/display/INF (aricg-, 15:52:38)
    6. it will be discussed also tomorrow on TSC (uli-k, 15:53:03)
    7. can we leave a contact in this page, status.opnfv.org? (Julien-zte, 15:53:29)

  5. utilise signing for pulling img files (uli-k, 15:54:46)
    1. lhinds explains the security risk of that given command (uli-k, 15:55:27)
    2. we should introduce at least some checksum verification (uli-k, 15:55:45)
    3. verify plugin will help users to better understand findings of the verify step (uli-k, 15:57:24)
    4. AGREED: to introduce the verify plugin (uli-k, 15:57:41)
    5. AGREED: to introduce checksum verification when scripts pull img files (checksum will be in the script) (uli-k, 16:00:13)
    6. it needs to be implemented in the backlog for the anteater issues. (uli-k, 16:00:40)
    7. a.https://gerrit.googlesource.com/plugins/verify-status/+doc/master/src/main/resources/Documentation/about.md (uli-k, 16:01:56)
    8. next week, Luke will host the meetings. (uli-k, 16:02:09)


Meeting ended at 16:02:45 UTC (full logs).

Action items

  1. bryan_att Clarify HW requirements for ONAP
  2. Bryan_att Provide some use cases on the LaaS page so we can go a second step


Action items, by person

  1. bryan_att
    1. bryan_att Clarify HW requirements for ONAP
    2. Bryan_att Provide some use cases on the LaaS page so we can go a second step


People present (lines said)

  1. uli-k (34)
  2. Julien-zte (29)
  3. fdegir (24)
  4. collabot (4)
  5. aricg- (3)
  6. bryan_att (3)
  7. rpaik (2)
  8. lhinds (1)
  9. radez (1)
  10. thaj (1)
  11. jose_lausuch (1)


Generated by MeetBot 0.1.4.