#opnfv-meeting: Infra WG Weekly Meeting

Meeting started by fdegir at 16:00:36 UTC (full logs).

Meeting summary

  1. Rollcall (fdegir, 16:00:42)
    1. David Blaisonneau (David_Orange, 16:01:12)
    2. Aric Gardner (aricg, 16:01:16)
    3. Tianwei wu (hw_wutianwei, 16:01:20)
    4. Agenda is its on the usual place (fdegir, 16:01:32)
    5. Trevor Bramwell (bramwelt, 16:01:41)
    6. Jack Morgan (jmorgan1, 16:01:41)
    7. David McBride (dmcbride, 16:01:43)
    8. https://wiki.opnfv.org/display/INF/Infra+Working+Group (fdegir, 16:01:49)

  2. Zuulv3 Prototype (fdegir, 16:02:31)
    1. We brought up 1 VM to start the prototype (fdegir, 16:03:09)
    2. https://etherpad.opnfv.org/p/opnfv-zuul-prototype (fdegir, 16:03:17)

  3. Huawei Lab Migration (fdegir, 16:03:57)
    1. Huawei lab will be migrated during this week (fdegir, 16:04:17)
    2. Tim Irnich (timirnich, 16:04:18)
    3. PODs that will be impacted are pod7 pod12 and virtual 5 to 7 (fdegir, 16:05:48)
    4. The PODs will be offline during the migration (fdegir, 16:06:11)
    5. Impacted projects are Compass and Joid - needs to be verified (fdegir, 16:07:09)
    6. ACTION: hw_wutianwei and fdegir to contact the affected projects (fdegir, 16:07:39)
    7. An ARM based POD will be added as well (fdegir, 16:08:01)
    8. To connect the new PODs to Jenkins, a ticket is needed to be sent to LF Helpdesk (fdegir, 16:09:10)

  4. CI Resources for JOID (fdegir, 16:11:57)
    1. narinder` sent a ticket to opnfv-helpdesk (fdegir, 16:12:28)
    2. Joid doesn't have any resources to run baremetal jobs (fdegir, 16:12:43)
    3. intel-pod18 needs to be connected to OPNFV Jenkins (fdegir, 16:13:04)
    4. To connect this POD to OPNFV Jenkins, workaround needs to be applied for port 80 (fdegir, 16:13:47)
    5. Once the POD is connected to Jenkins, it needs to be labelled with joid-baremetal (fdegir, 16:14:37)
    6. And finally the slave needs to be added to slave-params.yml (fdegir, 16:15:14)
    7. https://gerrit.opnfv.org/gerrit/gitweb?p=releng.git;a=blob;f=jjb/global/slave-params.yml (fdegir, 16:15:15)
    8. ACTION: narinder` to work with aricg/bramwelt to fix the slave (fdegir, 16:15:51)

  5. XCI at Plugfest (fdegir, 16:16:42)
    1. XCI session is scheduled for Day 3 (fdegir, 16:17:50)
    2. https://wiki.opnfv.org/display/EVNT/Euphrates+Plugfest+Schedule#EuphratesPlugfestSchedule-Day3(December6th)Schedule (fdegir, 16:17:54)
    3. Practices/principles to follow in order to be part of XCI need to be agreed on (fdegir, 16:19:05)
    4. Infra/CI practices such as PDF/IDF/SDF & dynamic CI, having people/hw, etc. which will be documented (fdegir, 16:19:20)

  6. Sending Out MoM (fdegir, 16:23:40)
    1. Meeting minutes are sent to tech-discuss - see the last week's minutes (fdegir, 16:23:58)
    2. https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-November/019274.html (fdegir, 16:24:00)

  7. How to use special hw and run tests on them (fdegir, 16:25:03)
    1. Some features require special hw or specific configuration which need to be handled (fdegir, 16:25:34)
    2. Discussion is needed to find out how to work on this (fdegir, 16:26:02)
    3. One option could be incorporating this into ongoing discussion to refresh Pharos spec (fdegir, 16:26:29)
    4. This is needed in order to easily find out which features are offered by which labs/PODs (fdegir, 16:27:55)
    5. Based on the information provided by the labs, we can automatically decide where a certain deployment should go or enable test frameworks to pick right test cases (fdegir, 16:28:48)
    6. Pharos spec can have some basic use cases and the above things could be additions on top of the base spec (fdegir, 16:31:32)
    7. A topic for plugfest has been added to the agenda: Testing hardware/software interactions brainstorming (fdegir, 16:33:34)
    8. https://wiki.opnfv.org/display/EVNT/Euphrates+Plugfest+Schedule#EuphratesPlugfestSchedule-Day4(December7th)Schedule (fdegir, 16:33:40)
    9. The day/time might change coming days (fdegir, 16:33:47)
    10. ACTION: timirnich to follow up the topic during plugfest (fdegir, 16:34:05)

  8. Define test requirements for gating scenarios for the release (fdegir, 16:35:34)
    1. This is simply improving release criteria by using the results from test runs (fdegir, 16:36:26)
    2. Tooling support is needed (fdegir, 16:41:12)
    3. Release Criteria needs to be discussed and brought up to TSC for approval once things are clarified within community (fdegir, 16:42:15)
    4. ACTION: dmcbride to followup the topic to ensure this gets discussed during the plugfest (fdegir, 16:43:31)

  9. Action Item Review (fdegir, 16:44:00)
    1. Open: Move PDF from Octopus repo to Pharos repo (fdegir, 16:44:15)
    2. Open: Talk about OPNFV Zuulv3 prototype within LF Infra/Releng to see how it fits into overall LF strategy/backlog (fdegir, 16:44:33)
    3. Open: Review the no of PODs installers have (fdegir, 16:45:19)
    4. Open: Update documents on CI POD requirements (fdegir, 16:45:53)
    5. Open: Clean up securelab access including creating new ldap group for lab owners (fdegir, 16:47:20)
    6. The encryption will be done per lab basis as needed and the above action item can be closed once the PDFs moved to pharos repo (fdegir, 16:47:49)
    7. After some time, securedlab usage should be blocked (fdegir, 16:48:15)
    8. Open: Clean up non-active Pharos committers - lab owners will be made Pharos committers (fdegir, 16:48:52)
    9. Open: Pharos project needs to define hardware details to be included (fdegir, 16:49:32)
    10. Done: Send email to Lab owners to request them to input lab information into dashboard (fdegir, 16:49:35)
    11. Done: Infra WG needs to decide how to manage documentation - we have two proposal (fdegir, 16:50:13)
    12. ACTION: jmorgan1 to decide how to handle pharos/hw infra documentation (fdegir, 16:50:30)
    13. Done: start email thread on transitioning docker build script to the releng project (fdegir, 16:51:15)
    14. Open: schedule a Plugfest discussion on logging facilities (fdegir, 16:52:29)
    15. Joe Kidder (Joe____, 16:56:35)


Meeting ended at 16:57:23 UTC (full logs).

Action items

  1. hw_wutianwei and fdegir to contact the affected projects
  2. narinder` to work with aricg/bramwelt to fix the slave
  3. timirnich to follow up the topic during plugfest
  4. dmcbride to followup the topic to ensure this gets discussed during the plugfest
  5. jmorgan1 to decide how to handle pharos/hw infra documentation


Action items, by person

  1. aricg
    1. narinder` to work with aricg/bramwelt to fix the slave
  2. bramwelt
    1. narinder` to work with aricg/bramwelt to fix the slave
  3. dmcbride
    1. dmcbride to followup the topic to ensure this gets discussed during the plugfest
  4. fdegir
    1. hw_wutianwei and fdegir to contact the affected projects
  5. hw_wutianwei
    1. hw_wutianwei and fdegir to contact the affected projects
  6. jmorgan1
    1. jmorgan1 to decide how to handle pharos/hw infra documentation
  7. timirnich
    1. timirnich to follow up the topic during plugfest


People present (lines said)

  1. fdegir (67)
  2. collabot (4)
  3. hw_wutianwei (3)
  4. aricg (1)
  5. timirnich (1)
  6. Joe____ (1)
  7. bramwelt (1)
  8. jmorgan1 (1)
  9. dmcbride (1)
  10. David_Orange (1)


Generated by MeetBot 0.1.4.