#opnfv-meeting: Airship Installer Project Kickoff Meeting

Meeting started by bh526r at 13:00:12 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r, 13:00:23)
    1. Bin Hu (bh526r, 13:01:01)
    2. Sridhar Rao (bh526r, 13:01:11)
    3. Rajesh Rajamani (bh526r, 13:01:31)
    4. Bin Yang (bh526r, 13:02:23)
    5. Georg Kunz (bh526r, 13:02:29)
    6. Kaspars Skels (bh526r, 13:04:19)
    7. Mark Beierl (bh526r, 13:05:06)
    8. Mark Beierl (mbeierl, 13:05:19)

  2. Admin Update (bh526r, 13:10:27)
    1. All agreed to 6am PT Thursdays considering all factors (bh526r, 13:11:39)
    2. Bin Yang suggested biweekly (bh526r, 13:11:57)
    3. All agreed to biweekly. If needed, we can adjust in the future (bh526r, 13:12:41)

  3. Project Plan (bh526r, 13:13:19)
    1. Mark Shostak (bh526r, 13:16:49)
    2. Bin shared initial goal of getting Airship deployed manually and proof out everything in one or more community labs (bh526r, 13:20:35)
    3. Bin shared that we followed community process and requested hardware resources from Intel community lab, and got pod 17 & pod 18 resources (bh526r, 13:21:30)
    4. Rajesh indicated that Spirent will establish a lab, and replicate the deployment in Intel lab into Spirent lab (bh526r, 13:22:54)
    5. So we will have at least 2 labs - Intel lab and Spirent lab (bh526r, 13:25:30)
    6. Bin introduced initial 3 JIRA issues for this initial goal and activities (bh526r, 13:26:21)
    7. Kaspars gave more details of the work planned to do (bh526r, 13:26:36)
    8. Mark asked if we plan to develop a tool to convert PDF into Airship declarative YAML (bh526r, 13:27:12)
    9. Bin shared that the tool is on the plan of record. Once we finish the initial deployment in Intel lab and Spirent lab, the tool development will be put on the list of tasks. (bh526r, 13:28:41)
    10. If we will have more community resources to help develop the tool, it will accelerate the work of tool development (bh526r, 13:29:14)
    11. Mark also asked CI/CD (bh526r, 13:29:25)
    12. Kaspars shared that current CI/CD is Jenkins based, and managed by Treasuremap component. We are also investigating if CircleCI makes sense. (bh526r, 13:30:26)
    13. Sridhar asks about the hardware profile, topology etc. (bh526r, 13:31:26)
    14. Kaspars shared some details of the YAML files for hardware profile, networking / VLAN etc. (bh526r, 13:32:07)
    15. ACTION: Kaspars to prepare a deep dive of hardware topology diagram, and how it describes Intel lab topology. (bh526r, 13:44:02)
    16. Georg asked how to handle missing features, such as DPDK, and provide input to upstream Airship community (bh526r, 13:45:12)
    17. Bin shared how IPv6 and Doctor did in the past regarding providing new features to upstream (OpenStack) (bh526r, 13:51:26)
    18. The 1st step is to document all gaps between current Airship features and CNTT specs (bh526r, 13:52:48)
    19. Then we bring the gaps to upstream Airship, start communication and coordination (bh526r, 13:56:10)
    20. If Airship can commit to some features in a timely manner, great. (bh526r, 13:59:18)
    21. If not, we may start to work on those features in parallel to meet CNTT needs, then eventually upstream our patch to Airship community. This is because of our "upstream first" principle in OPNFV (bh526r, 14:00:36)
    22. Georg agreed it is a good approach, and also indicated that communication and collaboration is extremely important (bh526r, 14:01:35)
    23. ACTION: Georg happily agree to take the action of gap analysis once CNTT spec is stable (bh526r, 14:02:08)
    24. Sridhar asked if we need description document before CNTT reference mode (bh526r, 14:03:40)
    25. Bin answered that once CNTT specs is ready, we need to translate it into machine-readable format, which is the YAML consumed by Airship (bh526r, 14:04:22)
    26. All are excited. (bh526r, 14:05:22)

  4. AOB (bh526r, 14:05:30)
    1. We will resume in 2 weeks and give project update (bh526r, 14:06:50)
    2. Meeting adjourned (bh526r, 14:06:56)


Meeting ended at 14:07:00 UTC (full logs).

Action items

  1. Kaspars to prepare a deep dive of hardware topology diagram, and how it describes Intel lab topology.
  2. Georg happily agree to take the action of gap analysis once CNTT spec is stable


People present (lines said)

  1. bh526r (44)
  2. collabot` (3)
  3. kskels (1)
  4. mbeierl (1)


Generated by MeetBot 0.1.4.