#opnfv-meeting: OPNFV TSC 2019-08-27

Meeting started by bh526r at 13:00:09 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r, 13:00:17)
    1. Mark Beierl (mbeierl, 13:00:26)
    2. Bin Hu (bh526r, 13:00:41)
    3. Trevor Cooper (trevor_intel, 13:01:15)
    4. Panagiotis Karalis (pkaralis, 13:01:59)
    5. Frank Brockners (frankbrockners, 13:03:53)
    6. Meeting kicks off with Antitrust policy review (mbeierl, 13:04:09)
    7. Georg Kunz (georgk, 13:04:48)
    8. Jack Morgan (jento, 13:05:28)
    9. Al Morton (mbeierl, 13:06:27)
    10. Fu Qiao (mbeierl, 13:07:16)
    11. Fu Qiao (bh526r, 13:07:19)
    12. Sridhar Rao (bh526r, 13:07:47)
    13. Sunku Ranganath (bh526r, 13:08:16)
    14. Dan Xu (bh526r, 13:08:47)

  2. Approval of Previous Minutes (bh526r, 13:09:15)
    1. AGREED: Minutes approved (bh526r, 13:09:24)
    2. no comments on minutes (mbeierl, 13:09:27)

  3. agenda bashing (mbeierl, 13:10:06)
    1. Manuel Buil (mbuil, 13:10:43)
    2. Heather Kirksey to send out email about PM updates (mbeierl, 13:11:57)
    3. no chair report this week (mbeierl, 13:12:16)
    4. suggested topics: FY20 budget introduction followed by Iruya release discussion (mbeierl, 13:13:37)
    5. Marketing update will be deferred (mbeierl, 13:14:26)
    6. Brandon Wick to send out update emails (mbeierl, 13:14:35)
    7. Heather stated that MAC liaison from OPNFV is still required (mbeierl, 13:14:59)
    8. Brandon confirms Bob Monkman will step into the MAC position (mbeierl, 13:16:00)
    9. Franck asks if any TSC member missed the meeting yesterday? (mbeierl, 13:16:59)
    10. Sunku confirms he did miss the meeting (mbeierl, 13:17:28)
    11. frankbrockners asks for clarification on current allocation for comparison (mbeierl, 13:18:59)

  4. 2020 Budget Process (bh526r, 13:19:16)
    1. Arpit clarifies that the process is more about the directional guidelines vs. details (mbeierl, 13:19:48)
    2. frankbrockners confirms that we would like to go over current allocation to see how we performed over the past year (mbeierl, 13:20:10)
    3. Arpit requests OPNFV to identify higher priorities for community if we anticipate changes (mbeierl, 13:21:23)
    4. Arpit asks if the everyone has reviewed spreadsheet (mbeierl, 13:21:49)
    5. bh526r suggests we review it (mbeierl, 13:21:59)
    6. Arpit informs that TSC input to the MAC is being taken into account (mbeierl, 13:22:48)
    7. Kenny posted budget planning webinar recording: (bh526r, 13:23:31)
    8. Marketing content FY20 is around messaging (mbeierl, 13:23:52)
    9. https://drive.google.com/file/d/1GNzxzZBCRVI_Znp2zHYL6btVzNSSs38U/view?usp=sharing (mbeierl, 13:25:01)
    10. Marketing is primarily LFN, whereas project release budget and messaging is joint with project (mbeierl, 13:26:21)
    11. What does OPNFV want to highlight in the coming year? (mbeierl, 13:26:39)
    12. Conversation moves to Developer Collaboration budget overview (mbeierl, 13:28:15)
    13. Does OPNFV see a general hosting cost going up or down? (mbeierl, 13:28:48)
    14. frankbrockners states hardware refresh / move to metal as a service had budget already set aside, and it is an open line item (mbeierl, 13:29:34)
    15. frankbrockners confirms OPNFV needs to make some decisions regarding bare metal (mbeierl, 13:30:13)
    16. Conversation oves to LF support, headcount related input (mbeierl, 13:30:57)
    17. will there be significant changes in this area? (mbeierl, 13:31:11)
    18. if the workload increases, why? (mbeierl, 13:31:24)
    19. same with new hardware, will there be changes - along with why (mbeierl, 13:31:52)
    20. frankbrockners confirms that the "TAC discretionary funding" was really project specific (ie: OPNFV) discretionary funding (mbeierl, 13:32:49)
    21. Pause for discussion or QA (mbeierl, 13:34:51)
    22. no questions (mbeierl, 13:35:17)
    23. Arpit states this is a much more structured and simpler approach this year (mbeierl, 13:35:58)
    24. Jim confirms we are not asking for numerical values (dollar figures). (mbeierl, 13:36:27)
    25. Arpit confirms this is about asks (ie: we want a whitepaper) vs. allocation of dollars. (mbeierl, 13:36:59)
    26. financial trade off (eg: we want 5 events, vs there is budget for only 3) is going to be managed by SPC (mbeierl, 13:38:26)
    27. Arpit will work with Jim to provide OPNFV with actuals from FY19 (mbeierl, 13:40:30)
    28. frankbrockners asks bh526r if thought has been given to how to run this process to reach conclusions within TSC (mbeierl, 13:41:18)
    29. bh526r replies need fy19 numbers from Arpit so TSC can educate itself. (mbeierl, 13:41:55)
    30. bh526r asks frankbrockners if he can take lead (mbeierl, 13:42:08)
    31. frankbrockners suggests we need an interim meeting to cover discussions - must be done as a community, not as a single person perform the collection of ideas (mbeierl, 13:43:00)
    32. bh526r asks if this same time slot on Wednesday is free? (mbeierl, 13:43:20)
    33. frankbrockners asks about Thursday, but there as conflicts (mbeierl, 13:43:40)
    34. frankbrockners and bh526r suggest Friday (mbeierl, 13:43:59)
    35. frankbrockners proposes 6:00 am PDT on Friday (mbeierl, 13:44:24)
    36. frankbrockners acknowledges this is late for APAC (mbeierl, 13:44:45)
    37. frankbrockners asks all to give thought and review ahead of the Friday meeting (mbeierl, 13:44:58)
    38. jmorgan1 asks if this is open to all or closed for TSC only (mbeierl, 13:45:10)
    39. frankbrockners suggests the meeting be open for all (mbeierl, 13:45:22)
    40. Arpit restates this is not about dollar figures, it is about resourcing, so it is not confidential (mbeierl, 13:46:00)
    41. ACTION: Jim Baker to send out email for Friday meeting (mbeierl, 13:46:18)
    42. jmorgan1 asks that Jim Baker also send the invite to tech-discuss (mbeierl, 13:46:37)

  5. Iruya planning (mbeierl, 13:47:09)
    1. dmcbride shares two possible proposals (mbeierl, 13:47:30)
    2. dmcbride first shows traditional release process, compressed for remaining time in year, and showing major holidays and events (mbeierl, 13:48:04)
    3. proposed schedule: MS0: Sept 9 -> MS9: Dec 13. (mbeierl, 13:48:42)
    4. mbeierl asks if MS2 is relevant for other projects such as functest - does MS2 apply beyond installers (mbeierl, 13:51:07)
    5. Cedric confirms Functest has its schedule for alignment with OpenStack already planned (mbeierl, 13:51:46)
    6. dmcbride confirms that it is not completely installer centric, that there is cross-dependencies (mbeierl, 13:52:28)
    7. dmcbride shares second proposal (mbeierl, 13:52:39)
    8. reduced milestones: MS0 -> MS4 (mbeierl, 13:53:36)
    9. Cédric we leverage on our own SUT to verify Functest (gates and daily jobs) (ollivier, 13:53:38)
    10. Cédric no longer cross-dependencies from Functest point of view (ollivier, 13:54:19)
    11. MS0: start; MS1: release plan, MS2: preliminary review; MS3: final review; MS4: release and tag. (mbeierl, 13:54:37)
    12. same schedule, MS0: Sep9, MS4: Dec 13. (mbeierl, 13:55:00)
    13. Cédric OpenStack Train will be released in October. Is Stein still selected for I-Release? (ollivier, 13:55:51)
    14. frankbrockners suggests we decide whether or not to release in December first (mbeierl, 13:57:36)
    15. dmcbride confirms 60%/40% in favour of performing the release (mbeierl, 13:58:45)
    16. suggested vote text: "Should Iruya follow the regular release cadence (i.e. Iruya to be released this year)? (-1,0,1)" (mbeierl, 13:59:55)
    17. dmcbride proxy for acm (dmcbride, 14:01:18)
    18. frankbrockners calls for any further votes (mbeierl, 14:01:52)
    19. VOTE: Voted on "Should Iruya follow the regular release cadence (i.e. Iruya to be released this year)?" Results are, 1: 9, -1: 1 (mbeierl, 14:01:57)
    20. frankbrockners asks if 'intent to participate' is the same milestone (mbeierl, 14:03:00)
    21. dmcbride confirms that the production of a release plan is the same as the intent to participate (mbeierl, 14:03:21)


Meeting ended at 14:04:13 UTC (full logs).

Action items

  1. Jim Baker to send out email for Friday meeting


People present (lines said)

  1. mbeierl (86)
  2. bh526r (14)
  3. collabot` (12)
  4. ollivier (5)
  5. trevor_intel (3)
  6. xudan (2)
  7. frankbrockners (2)
  8. dmcbride (2)
  9. georgk (2)
  10. mbuil (2)
  11. pkaralis (2)
  12. pberberian (1)
  13. jento (1)


Generated by MeetBot 0.1.4.